diff options
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch | 39 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4154.bb) | 5 |
2 files changed, 2 insertions, 42 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch deleted file mode 100644 index ae8ccbf2..00000000 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From 8435bfb432282bdb900492f479233d2772f57f7c Mon Sep 17 00:00:00 2001 | ||
2 | From: 8tab <tab.debugteam@gmail.com> | ||
3 | Date: Thu, 21 May 2020 14:21:58 +0200 | ||
4 | Subject: [PATCH] Add workaround for gcc 10 internal compiler error | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | There is a regression in recent gcc (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95241), | ||
10 | that make IGC fail to compile: | ||
11 | In file included from /home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/Models.cpp:7: | ||
12 | /home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/bxml/Model7P5.hpp:1258:34: in ‘constexpr’ expansion of ‘iga::Field(((const char*)"MathFC"), 24, 4)’ | ||
13 | /home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/bxml/Model7P5.hpp:2085:5: internal compiler error: in tree_to_uhwi, at tree.h:4519 | ||
14 | 2085 | }; | ||
15 | | ^ | ||
16 | |||
17 | Upstream-Status: Submitted [https://github.com/intel/intel-graphics-compiler/pull/135] | ||
18 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
19 | --- | ||
20 | visa/iga/IGALibrary/Backend/Native/Field.hpp | 2 +- | ||
21 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/visa/iga/IGALibrary/Backend/Native/Field.hpp b/visa/iga/IGALibrary/Backend/Native/Field.hpp | ||
24 | index 4b97280b..04855576 100644 | ||
25 | --- a/visa/iga/IGALibrary/Backend/Native/Field.hpp | ||
26 | +++ b/visa/iga/IGALibrary/Backend/Native/Field.hpp | ||
27 | @@ -150,8 +150,8 @@ namespace iga | ||
28 | // a simple encoded field (single contiguous) | ||
29 | constexpr Field(const char *_name, int offset, int length) | ||
30 | : name(_name) | ||
31 | - , fragments{Fragment(_name, offset, length)} | ||
32 | { | ||
33 | + fragments[0] = Fragment(_name, offset, length); | ||
34 | } | ||
35 | // a zero fill field or must-be-zero field | ||
36 | constexpr Field(const char *_name, int length, | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4154.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb index 7083ab94..ecb0f536 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4154.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4241.bb | |||
@@ -6,14 +6,13 @@ hardware architecture." | |||
6 | LICENSE = "MIT & BSD-3-Clause" | 6 | LICENSE = "MIT & BSD-3-Clause" |
7 | LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \ | 7 | LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \ |
8 | file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb \ | 8 | file://IGC/Compiler/LegalizationPass.cpp;beginline=1;endline=25;md5=4abf1738ff96b18e34186eb763e28eeb \ |
9 | file://NOTICES.txt;md5=a43460284ff9e81adceffa047c306eef" | 9 | file://NOTICES.txt;md5=b12e73994de4fbe0f688cf0bc91512a0" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ | 11 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ |
12 | file://0001-skip-execution-of-ElfPackager.patch \ | 12 | file://0001-skip-execution-of-ElfPackager.patch \ |
13 | file://0001-add-workaround-for-gcc-10-error.patch \ | ||
14 | " | 13 | " |
15 | 14 | ||
16 | SRCREV = "173eb2a0f5d0a16f4abc07bbd093056bf0c04ae5" | 15 | SRCREV = "9a456d81355b266ac60b26c1865935b4a266d6e2" |
17 | 16 | ||
18 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
19 | 18 | ||