summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb2
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb1
-rw-r--r--lib/oeqa/runtime/cases/intel_vaapi_driver.py8
-rw-r--r--lib/oeqa/runtime/cases/microcode.py11
-rw-r--r--lib/oeqa/runtime/cases/mkl_dnn.py4
-rw-r--r--lib/oeqa/runtime/miutils/tests/mkl_dnn_test.py4
-rw-r--r--recipes-core/microcode/intel-microcode_20210216.bb (renamed from recipes-core/microcode/intel-microcode_20201118.bb)4
-rw-r--r--recipes-kernel/linux/linux-intel-dev.bb6
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb35
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb6
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb32
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb6
12 files changed, 90 insertions, 29 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb
index 502200fa..e762246c 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb
@@ -31,7 +31,7 @@ DEPENDS_append_class-target = " clang-cross-x86_64"
31 31
32RDEPENDS_${PN} += "opencl-clang" 32RDEPENDS_${PN} += "opencl-clang"
33 33
34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}" 34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.1.0', d)}"
35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF" 35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF"
36 36
37# VectorCompiler doesn't build with LLVM11 as of this release. 37# VectorCompiler doesn't build with LLVM11 as of this release.
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
index 57b56d73..d0c852ab 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -24,6 +24,7 @@ COMPATIBLE_HOST_libc-musl = "null"
24EXTRA_OECMAKE += "\ 24EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
26 -DCMAKE_SKIP_RPATH=TRUE \ 26 -DCMAKE_SKIP_RPATH=TRUE \
27 -DPREFERRED_LLVM_VERSION="11.1.0" \
27 " 28 "
28 29
29do_install_append_class-native() { 30do_install_append_class-native() {
diff --git a/lib/oeqa/runtime/cases/intel_vaapi_driver.py b/lib/oeqa/runtime/cases/intel_vaapi_driver.py
index 85d2dd39..b78b2859 100644
--- a/lib/oeqa/runtime/cases/intel_vaapi_driver.py
+++ b/lib/oeqa/runtime/cases/intel_vaapi_driver.py
@@ -16,14 +16,14 @@ class VaapiDriverTest(OERuntimeTestCase):
16 (status, output) = self.target.run('gst-inspect-1.0 vaapi') 16 (status, output) = self.target.run('gst-inspect-1.0 vaapi')
17 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output)) 17 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output))
18 18
19 (status, output) = self.target.run('export LIBVA_DRIVER_NAME=i965; ' 19 (status, output) = self.target.run('export GST_VAAPI_ALL_DRIVERS=1; '
20 'gst-launch-1.0 -ev videotestsrc num-buffers=60 ! ' 20 'gst-launch-1.0 -ev videotestsrc num-buffers=60 ! '
21 'timeoverlay ! vaapih264enc ! mp4mux ! filesink location=/tmp/vtest_h264.mp4') 21 'vaapih264enc ! mp4mux ! filesink location=/tmp/vtest_h264.mp4')
22 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output)) 22 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output))
23 23
24 @OETestDepends(['intel_vaapi_driver.VaapiDriverTest.test_gstreamer_can_encode_with_intel_vaapi_driver']) 24 @OETestDepends(['intel_vaapi_driver.VaapiDriverTest.test_gstreamer_can_encode_with_intel_vaapi_driver'])
25 def test_gstreamer_can_decode_with_intel_vaapi_driver(self): 25 def test_gstreamer_can_decode_with_intel_vaapi_driver(self):
26 (status, output) = self.target.run('export LIBVA_DRIVER_NAME=i965; ' 26 (status, output) = self.target.run('export GST_VAAPI_ALL_DRIVERS=1; '
27 'gst-launch-1.0 filesrc location=/tmp/vtest_h264.mp4 ! ' 27 'gst-launch-1.0 filesrc location=/tmp/vtest_h264.mp4 ! '
28 'qtdemux ! h264parse ! vaapih264dec ! vaapisink') 28 'qtdemux ! h264parse ! vaapih264dec ! vaapisink')
29 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output)) 29 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output))
diff --git a/lib/oeqa/runtime/cases/microcode.py b/lib/oeqa/runtime/cases/microcode.py
index 6ce36a6f..52c1cdb4 100644
--- a/lib/oeqa/runtime/cases/microcode.py
+++ b/lib/oeqa/runtime/cases/microcode.py
@@ -16,20 +16,15 @@ class MicrocodeTest(OERuntimeTestCase):
16 16
17 @OEHasPackage(["iucode-tool"]) 17 @OEHasPackage(["iucode-tool"])
18 def test_microcode_update(self): 18 def test_microcode_update(self):
19 (status, output) = self.target.run('iucode_tool /lib/firmware/intel-ucode/ -tb -lS | grep rev') 19 (status, output) = self.target.run('iucode_tool /lib/firmware/intel-ucode/ -tb -l --scan-system=2 | grep rev')
20 if status:
21 self.skipTest("The iucode_tool detected no microcode for update.")
22 20
23 selected_microcodes = output.splitlines() 21 selected_microcodes = output.splitlines()
24 selected_rev_list = self.get_revision_from_microcode_string_list(selected_microcodes, "rev (\w*)") 22 selected_rev_list = self.get_revision_from_microcode_string_list(selected_microcodes, "rev (\w*)")
25 self.assertTrue(selected_rev_list, msg="Could not find any rev from iucode_tool selected microcode.")
26 23
27 (status, output) = self.target.run('dmesg | grep microcode') 24 (status, output) = self.target.run("dmesg | grep 'microcode updated early'")
28 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output))
29 25
30 updated_microcodes = output.splitlines() 26 updated_microcodes = output.splitlines()
31 updated_rev_list = self.get_revision_from_microcode_string_list(updated_microcodes, "revision=(\w*)") 27 updated_rev_list = self.get_revision_from_microcode_string_list(updated_microcodes, "revision (\w*)")
32 self.assertTrue(updated_rev_list, msg="Could not find any updated revision from microcode dmesg.")
33 28
34 for ul in updated_rev_list: 29 for ul in updated_rev_list:
35 self.assertTrue(ul in selected_rev_list, msg="Updated revision, %s, not in selected revision list (%s)" % 30 self.assertTrue(ul in selected_rev_list, msg="Updated revision, %s, not in selected revision list (%s)" %
diff --git a/lib/oeqa/runtime/cases/mkl_dnn.py b/lib/oeqa/runtime/cases/mkl_dnn.py
index c2d3180d..8d50df54 100644
--- a/lib/oeqa/runtime/cases/mkl_dnn.py
+++ b/lib/oeqa/runtime/cases/mkl_dnn.py
@@ -14,7 +14,7 @@ class MklDnn(OERuntimeTestCase):
14 def tearDownClass(cls): 14 def tearDownClass(cls):
15 cls.mkldnntest.tear_down() 15 cls.mkldnntest.tear_down()
16 16
17 @OEHasPackage(['onednn', 'libdnnl1']) 17 @OEHasPackage(['onednn', 'libdnnl2'])
18 @OEHasPackage(['onednn-src', 'libdnnl-src']) 18 @OEHasPackage(['onednn-src', 'libdnnl-src'])
19 @OEHasPackage(['onednn-dev', 'libdnnl-dev']) 19 @OEHasPackage(['onednn-dev', 'libdnnl-dev'])
20 @OEHasPackage(['gcc']) 20 @OEHasPackage(['gcc'])
@@ -25,7 +25,7 @@ class MklDnn(OERuntimeTestCase):
25 (status, output) = self.mkldnntest.test_mkldnn_can_compile_and_execute() 25 (status, output) = self.mkldnntest.test_mkldnn_can_compile_and_execute()
26 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output)) 26 self.assertEqual(status, 0, msg='status and output: %s and %s' % (status, output))
27 27
28 @OEHasPackage(['onednn', 'libdnnl1']) 28 @OEHasPackage(['onednn', 'libdnnl2'])
29 @OEHasPackage(['onednn-test', 'libdnnl-test']) 29 @OEHasPackage(['onednn-test', 'libdnnl-test'])
30 def test_mkldnn_benchdnn_package_available(self): 30 def test_mkldnn_benchdnn_package_available(self):
31 (status, output) = self.mkldnntest.test_mkldnn_benchdnn_package_available() 31 (status, output) = self.mkldnntest.test_mkldnn_benchdnn_package_available()
diff --git a/lib/oeqa/runtime/miutils/tests/mkl_dnn_test.py b/lib/oeqa/runtime/miutils/tests/mkl_dnn_test.py
index 3f563722..869a4cbe 100644
--- a/lib/oeqa/runtime/miutils/tests/mkl_dnn_test.py
+++ b/lib/oeqa/runtime/miutils/tests/mkl_dnn_test.py
@@ -49,9 +49,7 @@ class MkldnnTest(object):
49 return self._run_mkldnn_benchdnn_test('./benchdnn --reorder --batch=inputs/reorder/test_reorder_bfloat16') 49 return self._run_mkldnn_benchdnn_test('./benchdnn --reorder --batch=inputs/reorder/test_reorder_bfloat16')
50 50
51 def test_mkldnn_rnn_api(self): 51 def test_mkldnn_rnn_api(self):
52 # test_rnn_inference was not yet ready and was expected to fail 52 return self._run_mkldnn_benchdnn_test('./benchdnn --rnn --batch=inputs/rnn/test_rnn_all')
53 # while waiting it to be ready, use test_rnn_small for now
54 return self._run_mkldnn_benchdnn_test('./benchdnn --rnn --batch=inputs/rnn/test_rnn_small')
55 53
56 def test_mkldnn_shuffle_api(self): 54 def test_mkldnn_shuffle_api(self):
57 return self._run_mkldnn_benchdnn_test('./benchdnn --shuffle --batch=inputs/shuffle/test_shuffle_bfloat16') \ No newline at end of file 55 return self._run_mkldnn_benchdnn_test('./benchdnn --shuffle --batch=inputs/shuffle/test_shuffle_bfloat16') \ No newline at end of file
diff --git a/recipes-core/microcode/intel-microcode_20201118.bb b/recipes-core/microcode/intel-microcode_20210216.bb
index b47c8157..69c8f08c 100644
--- a/recipes-core/microcode/intel-microcode_20201118.bb
+++ b/recipes-core/microcode/intel-microcode_20210216.bb
@@ -11,12 +11,12 @@ DESCRIPTION = "The microcode data file contains the latest microcode\
11 if the file is placed in the /etc/firmware directory of the Linux system." 11 if the file is placed in the /etc/firmware directory of the Linux system."
12 12
13LICENSE = "Intel-Microcode-License" 13LICENSE = "Intel-Microcode-License"
14LIC_FILES_CHKSUM = "file://license;md5=6b58767419df274d2409b294ddae17e6" 14LIC_FILES_CHKSUM = "file://license;md5=d8405101ec6e90c1d84b082b0c40c721"
15 15
16SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https;branch=main \ 16SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https;branch=main \
17 " 17 "
18 18
19SRCREV = "49bb67f32a2e3e631ba1a9a73da1c52e1cac7fd9" 19SRCREV = "4c5f3fdcc7f5d2b6c1bcc11001ed58923db481ab"
20 20
21DEPENDS = "iucode-tool-native" 21DEPENDS = "iucode-tool-native"
22S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-intel-dev.bb b/recipes-kernel/linux/linux-intel-dev.bb
index abe6fb36..f99b1f19 100644
--- a/recipes-kernel/linux/linux-intel-dev.bb
+++ b/recipes-kernel/linux/linux-intel-dev.bb
@@ -19,9 +19,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19 19
20DEPENDS += "elfutils-native openssl-native util-linux-native" 20DEPENDS += "elfutils-native openssl-native util-linux-native"
21 21
22LINUX_VERSION ?= "5.8.0" 22LINUX_VERSION ?= "5.11-rc6"
23SRCREV_machine ?= "bcf876870b95592b52519ed4aafcf9d95999bc9c" 23SRCREV_machine ?= "1048ba83fb1c00cd24172e23e8263972f6b5d9ac"
24SRCREV_meta ?= "2bcb4b9e8a85412849095463d4b891d9bbfbd1ad" 24SRCREV_meta ?= "3356fb62fb5eadec1f5c3c4248f1f8dbab968aa1"
25 25
26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
27PV = "${LINUX_VERSION}+git${SRCPV}" 27PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
new file mode 100644
index 00000000..361b5dfc
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -0,0 +1,35 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 "
15
16KBRANCH = "5.10/preempt-rt"
17KMETA_BRANCH = "yocto-5.10"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.10.30"
22SRCREV_machine ?= "8b07bfbd844f73cbedc1f8eaa63e8b79295745d8"
23SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc"
24
25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
28# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
29# In which 'CONFIG_DRM_GMA3600' config option is dropped.
30# This causes warning during config audit. So suppress the harmless warning for now.
31KCONF_BSP_AUDIT_LEVEL = "0"
32
33# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
34# causes config warning too.
35KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index 21fa7a60..2ec2a002 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -18,9 +18,9 @@ KMETA_BRANCH = "yocto-5.4"
18 18
19DEPENDS += "elfutils-native openssl-native util-linux-native" 19DEPENDS += "elfutils-native openssl-native util-linux-native"
20 20
21LINUX_VERSION ?= "5.4.70" 21LINUX_VERSION ?= "5.4.115"
22SRCREV_machine ?= "6f0f7e5dd27c1798d0d58ccdf3cccebf79aef8a0" 22SRCREV_machine ?= "00c7e2e1841e0ed3c1249c0e4bcacbd70435d62e"
23SRCREV_meta ?= "8d0ed83a864cc91eef4d2abbc90f13d4ecd1c213" 23SRCREV_meta ?= "9e2546ab8d63f70ba458eb159d29ce6736ffd3e4"
24 24
25LINUX_KERNEL_TYPE = "preempt-rt" 25LINUX_KERNEL_TYPE = "preempt-rt"
26 26
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
new file mode 100644
index 00000000..dae4118a
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -0,0 +1,32 @@
1require linux-intel.inc
2
3KBRANCH = "5.10/yocto"
4KMETA_BRANCH = "yocto-5.10"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7
8SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 "
10
11DEPENDS += "elfutils-native openssl-native util-linux-native"
12
13LINUX_VERSION ?= "5.10.41"
14SRCREV_machine ?= "916ac934a98bc8206c1b5e1500c891dbcb43aac7"
15SRCREV_meta ?= "cd049697e9b2d3e9118110d476075ff8f87202cc"
16
17# For Crystalforest and Romley
18KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
19KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
20
21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
23
24# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
25# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
26# In which 'CONFIG_DRM_GMA3600' config option is dropped.
27# This causes warning during config audit. So suppress the harmless warning for now.
28KCONF_BSP_AUDIT_LEVEL = "0"
29
30# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
31# causes config warning too.
32KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index ce53dc5e..910b0cfd 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -9,9 +9,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
9 9
10DEPENDS += "elfutils-native openssl-native util-linux-native" 10DEPENDS += "elfutils-native openssl-native util-linux-native"
11 11
12LINUX_VERSION ?= "5.4.81" 12LINUX_VERSION ?= "5.4.115"
13SRCREV_machine ?= "b3d20595bdf59d0784cb8256445fff65df26c4ac" 13SRCREV_machine ?= "2521f747baec6ccd170456c0fe697c48844a080d"
14SRCREV_meta ?= "8930d401f840f6cdff4ac887f6f6832d8cd44112" 14SRCREV_meta ?= "9e2546ab8d63f70ba458eb159d29ce6736ffd3e4"
15 15
16# For Crystalforest and Romley 16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"