summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MAINTAINERS4
-rw-r--r--meta-fishriver/COPYING.MIT17
-rw-r--r--meta-fishriver/README114
-rw-r--r--meta-fishriver/README.sources17
-rw-r--r--meta-fishriver/binary/.gitignore0
-rw-r--r--meta-fishriver/conf/layer.conf12
-rw-r--r--meta-fishriver/conf/machine/fishriver.conf17
-rw-r--r--meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig3
-rw-r--r--meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf26
-rw-r--r--meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend8
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend8
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend9
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto_3.2.bbappend8
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto_3.4.bbappend8
16 files changed, 0 insertions, 255 deletions
diff --git a/MAINTAINERS b/MAINTAINERS
index 5bcf470f..3bf0add1 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -56,10 +56,6 @@ EMENLOW
56M: Tom Zanussi <tom.zanussi@intel.com> 56M: Tom Zanussi <tom.zanussi@intel.com>
57F: meta-emenlow/ 57F: meta-emenlow/
58 58
59FISHRIVER
60M: Tom Zanussi <tom.zanussi@intel.com>
61F: meta-fishriver/
62
63FRI2 59FRI2
64M: Darren Hart <dvhart@linux.intel.com> 60M: Darren Hart <dvhart@linux.intel.com>
65F: meta-fri2/ 61F: meta-fri2/
diff --git a/meta-fishriver/COPYING.MIT b/meta-fishriver/COPYING.MIT
deleted file mode 100644
index fb950dc6..00000000
--- a/meta-fishriver/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-fishriver/README b/meta-fishriver/README
deleted file mode 100644
index 1dd0a4ce..00000000
--- a/meta-fishriver/README
+++ /dev/null
@@ -1,114 +0,0 @@
1This README file contains information on building the meta-fishriver
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5
6Dependencies
7============
8
9This layer depends on:
10
11 URI: git://git.openembedded.org/bitbake
12 branch: master
13
14 URI: git://git.openembedded.org/openembedded-core
15 layers: meta
16 branch: master
17
18 URI: git://git.yoctoproject.org/meta-intel
19 layers: intel
20 branch: master
21
22
23Patches
24=======
25
26Please submit any patches against this BSP to the Yocto mailing list
27(yocto@yoctoproject.org) and cc: the maintainer:
28
29Maintainer: Tom Zanussi <tom.zanussi@intel.com>
30
31Please see the meta-intel/MAINTAINERS file for more details.
32
33
34Table of Contents
35=================
36
37 I. Building the meta-fishriver BSP layer
38 II. Booting the images in /binary
39
40
41I. Building the meta-fishriver BSP layer
42========================================
43
44In order to build an image with BSP support for a given release, you
45need to download the corresponding BSP tarball from the 'Board Support
46Package (BSP) Downloads' page of the Yocto Project website.
47
48Having done that, and assuming you extracted the BSP tarball contents
49at the top-level of your yocto build tree, you can build a fishriver
50image by adding the location of the meta-fishriver layer to
51bblayers.conf, along with the meta-intel layer itself (to access
52common metadata shared between BSPs) e.g.:
53
54 yocto/meta-intel \
55 yocto/meta-intel/meta-fishriver \
56
57To enable the fishriver layer, add the fishriver MACHINE to local.conf:
58
59 MACHINE ?= "fishriver"
60
61You should then be able to build a fishriver image as such:
62
63 $ source oe-init-build-env
64 $ bitbake core-image-sato
65
66At the end of a successful build, you should have a live image that
67you can boot from a USB flash drive (see instructions on how to do
68that below, in the section 'Booting the images from /binary').
69
70As an alternative to downloading the BSP tarball, you can also work
71directly from the meta-intel git repository. For each BSP in the
72'meta-intel' repository, there are multiple branches, one
73corresponding to each major release starting with 'laverne' (0.90), in
74addition to the latest code which tracks the current master (note that
75not all BSPs are present in every release). Instead of extracting a
76BSP tarball at the top level of your yocto build tree, you can
77equivalently check out the appropriate branch from the meta-intel
78repository at the same location.
79
80
81II. Booting the images in /binary
82=================================
83
84This BSP contains bootable live images, which can be used to directly
85boot Yocto off of a USB flash drive.
86
87Under Linux, insert a USB flash drive. Assuming the USB flash drive
88takes device /dev/sdf, use dd to copy the live image to it. For
89example:
90
91# dd if=core-image-sato-fishriver-20101207053738.hddimg of=/dev/sdf
92# sync
93# eject /dev/sdf
94
95This should give you a bootable USB flash device. Insert the device
96into a bootable USB socket on the target, and power on. This should
97result in a system booted to the Sato graphical desktop.
98
99If you want a terminal, use the arrows at the top of the UI to move to
100different pages of available applications, one of which is named
101'Terminal'. Clicking that should give you a root terminal.
102
103If you want to ssh into the system, you can use the root terminal to
104ifconfig the IP address and use that to ssh in. The root password is
105empty, so to log in type 'root' for the user name and hit 'Enter' at
106the Password prompt: and you should be in.
107
108----
109
110If you find you're getting corrupt images on the USB (it doesn't show
111the syslinux boot: prompt, or the boot: prompt contains strange
112characters), try doing this first:
113
114# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-fishriver/README.sources b/meta-fishriver/README.sources
deleted file mode 100644
index 76180f1a..00000000
--- a/meta-fishriver/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.2/poky-denzil-7.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-fishriver/binary/.gitignore b/meta-fishriver/binary/.gitignore
deleted file mode 100644
index e69de29b..00000000
--- a/meta-fishriver/binary/.gitignore
+++ /dev/null
diff --git a/meta-fishriver/conf/layer.conf b/meta-fishriver/conf/layer.conf
deleted file mode 100644
index 61e292be..00000000
--- a/meta-fishriver/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "fishriver"
9BBFILE_PATTERN_fishriver := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fishriver = "6"
11
12LAYERDEPENDS_fishriver = "intel"
diff --git a/meta-fishriver/conf/machine/fishriver.conf b/meta-fishriver/conf/machine/fishriver.conf
deleted file mode 100644
index ec2e87f7..00000000
--- a/meta-fishriver/conf/machine/fishriver.conf
+++ /dev/null
@@ -1,17 +0,0 @@
1#@TYPE: Machine
2#@NAME: fishriver
3
4#@DESCRIPTION: Machine configuration for Fish River Island systems
5# i.e. Z530/E660 + EG20T
6
7PREFERRED_VERSION_linux-yocto ?= "3.4%"
8
9require conf/machine/include/tune-atom.inc
10require conf/machine/include/ia32-base.inc
11
12XSERVER ?= "${XSERVER_IA32_BASE} \
13 ${XSERVER_IA32_EXT} \
14 ${XSERVER_IA32_VESA} \
15 "
16
17APPEND += "video=vesafb vga=0x318"
diff --git a/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig b/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 6644a842..00000000
--- a/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}"
diff --git a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf
deleted file mode 100644
index da4fc3c6..00000000
--- a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf
+++ /dev/null
@@ -1,26 +0,0 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
deleted file mode 100644
index 7a502bd7..00000000
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_fishriver = "fishriver"
3KMACHINE_fishriver = "fishriver"
4
5# Update the following to use a different BSP branch or meta SRCREV
6#KBRANCH_fishriver = "yocto/standard/preempt-rt/base"
7#SRCREV_machine_pn-linux-yocto-rt_fishriver ?= XXXX
8#SRCREV_meta_pn-linux-yocto-rt_fishriver ?= XXXX
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
deleted file mode 100644
index a91a4259..00000000
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_fishriver = "fishriver"
3KMACHINE_fishriver = "fishriver"
4
5# Update the following to use a different BSP branch or meta SRCREV
6#KBRANCH_fishriver = "standard/preempt-rt/base"
7#SRCREV_machine_pn-linux-yocto-rt_fishriver ?= XXXX
8#SRCREV_meta_pn-linux-yocto-rt_fishriver ?= XXXX
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend
deleted file mode 100644
index 6ac6ef59..00000000
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_fishriver = "fishriver"
4KMACHINE_fishriver = "fishriver"
5KBRANCH_fishriver = "yocto/standard/fishriver"
6KERNEL_FEATURES_append_fishriver += " cfg/smp.scc"
7
8SRCREV_machine_pn-linux-yocto_fishriver ?= "c139592c96722727a9f074515a4061c3820da1a6"
9SRCREV_meta_pn-linux-yocto_fishriver ?= "59314a3523e360796419d76d78c6f7d8c5ef2593"
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto_3.2.bbappend
deleted file mode 100644
index 9a2f678d..00000000
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.2.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_fishriver = "fishriver"
4KMACHINE_fishriver = "fishriver"
5KBRANCH_fishriver = "standard/default/fishriver"
6
7SRCREV_machine_pn-linux-yocto_fishriver ?= "969edd015a46eed77d6c3daeffdc299dd06e3397"
8SRCREV_meta_pn-linux-yocto_fishriver ?= "5b4c9dc78b5ae607173cc3ddab9bce1b5f78129b"
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto_3.4.bbappend
deleted file mode 100644
index c0d04dc3..00000000
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_fishriver = "fishriver"
4KMACHINE_fishriver = "fishriver"
5KBRANCH_fishriver = "standard/fishriver"
6
7SRCREV_machine_pn-linux-yocto_fishriver ?= "3fa06aa29078fdb2af431de2d3fdae7d281ba85f"
8SRCREV_meta_pn-linux-yocto_fishriver ?= "5bdc655034a58a7147176a8a882d81e2fd51e4b9"