summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb11
-rw-r--r--meta-crystalforest/README21
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-gladden.conf1
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-server.conf1
4 files changed, 21 insertions, 13 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
index fb863b0a..fdeebbb8 100644
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
@@ -45,14 +45,6 @@ do_compile() {
45 oe_runmake KERNEL_CC="${KERNEL_CC}" 45 oe_runmake KERNEL_CC="${KERNEL_CC}"
46} 46}
47 47
48KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
49MODULE_DIR="${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
50
51do_install() {
52 install -m 0755 -d ${MODULE_DIR}
53 install -m 0755 ${S}/qat_mem.ko ${MODULE_DIR}
54}
55
56do_install_append() { 48do_install_append() {
57 install -m 0755 -d ${D}${bindir} \ 49 install -m 0755 -d ${D}${bindir} \
58 ${D}${includedir}/engines/qat_engine/qat_mem 50 ${D}${includedir}/engines/qat_engine/qat_mem
@@ -61,5 +53,4 @@ do_install_append() {
61 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/ 53 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
62} 54}
63 55
64FILES_${PN} += "${bindir}/qat_mem_test \ 56FILES_${PN} += "${bindir}/qat_mem_test"
65 ${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
index e658039a..625bdbc7 100644
--- a/meta-crystalforest/README
+++ b/meta-crystalforest/README
@@ -74,7 +74,7 @@ Table of Contents
74 I. Building the meta-crystalforest BSP layer 74 I. Building the meta-crystalforest BSP layer
75 II. Booting the images in /binary 75 II. Booting the images in /binary
76III. Enabling Intel DPDK and QuickAssist Technology 76III. Enabling Intel DPDK and QuickAssist Technology
77 77IV. Enabling libcrypto kernel module for QuickAssist Technology
78 78
79I. Building the meta-crystalforest BSP layer 79I. Building the meta-crystalforest BSP layer
80======================================= 80=======================================
@@ -165,6 +165,25 @@ contact your Intel Field Sales Representative or visit Intel Embedded Design
165Center (www.intel.com/p/en_US/embedded/designcenter) for instructions on how 165Center (www.intel.com/p/en_US/embedded/designcenter) for instructions on how
166to locate and use these recipes. 166to locate and use these recipes.
167 167
168IV. Enabling libcrypto kernel module for QuickAssist Technology
169===============================================================
170
171Since the Kernel Module names of Libcrypto and Zlib for QuickAssist
172Technology recipes are same, enabling both causes the build to fail.
173
174Please see Bug #4126 for more description.
175
176By default Crystal Forest builds zlib-qat-module.
177For enabling the libcrypto kernel module recipe, do the following:
178
179Crystal Forest Gladden:
180Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-gladden.conf
181and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
182
183Crystal Forest Server:
184Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-server.conf
185and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
186
168---- 187----
169 188
170If you find you're getting corrupt images on the USB (it doesn't show 189If you find you're getting corrupt images on the USB (it doesn't show
diff --git a/meta-crystalforest/conf/machine/crystalforest-gladden.conf b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
index 5eb3daff..2615d7a6 100644
--- a/meta-crystalforest/conf/machine/crystalforest-gladden.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
@@ -22,7 +22,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \ 22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
23 canterbury-corpus \ 23 canterbury-corpus \
24 zlib-qat-module \ 24 zlib-qat-module \
25 openssl-qat-module \
26 " 25 "
27#This Kernel Option is required for Intel Quick Assist Technology Software. 26#This Kernel Option is required for Intel Quick Assist Technology Software.
28APPEND += "acpi_enforce_resources=lax" 27APPEND += "acpi_enforce_resources=lax"
diff --git a/meta-crystalforest/conf/machine/crystalforest-server.conf b/meta-crystalforest/conf/machine/crystalforest-server.conf
index 2e567978..443ac056 100644
--- a/meta-crystalforest/conf/machine/crystalforest-server.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-server.conf
@@ -22,7 +22,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \ 22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
23 canterbury-corpus \ 23 canterbury-corpus \
24 zlib-qat-module \ 24 zlib-qat-module \
25 openssl-qat-module \
26 " 25 "
27#This Kernel Option is required for Intel Quick Assist Technology Software. 26#This Kernel Option is required for Intel Quick Assist Technology Software.
28APPEND += "acpi_enforce_resources=lax" 27APPEND += "acpi_enforce_resources=lax"