summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-crystalforest/README26
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-gladden.conf (renamed from meta-crystalforest/conf/machine/crystalforest-stargo.conf)4
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-server.conf (renamed from meta-crystalforest/conf/machine/crystalforest-shumway.conf)4
-rw-r--r--meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-gladden/machconfig (renamed from meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig)0
-rw-r--r--meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-server/machconfig (renamed from meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig)0
-rw-r--r--meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-gladden/xorg.conf (renamed from meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf)0
-rw-r--r--meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-server/xorg.conf (renamed from meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf)0
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend21
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend20
9 files changed, 36 insertions, 39 deletions
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
index 7b88b224..2a25edce 100644
--- a/meta-crystalforest/README
+++ b/meta-crystalforest/README
@@ -3,11 +3,11 @@ BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details. 3Please see the corresponding sections below for details.
4 4
5The 'Crystal Forest' platform consists of two versions. 5The 'Crystal Forest' platform consists of two versions.
61. STARGO 61. GLADDEN
72. SHUMWAY 72. SERVER
8 8
9Stargo Platform is based on Intel Sandy Bridge Gladden Processor,plus the Cave Creek chipset. 9Gladden Platform is based on Intel Sandy Bridge Gladden Processor,plus the Cave Creek chipset.
10Shumway Platform is based on two Intel Sandy Bridge (SNB-EP ES2 Grade and SNB-EN ES2 Grade) 10Server Platform is based on two Intel Sandy Bridge (SNB-EP ES2 Grade and SNB-EN ES2 Grade)
11Processors plus two Cave Creek Chipsets. 11Processors plus two Cave Creek Chipsets.
12 12
13Both Platforms uses Matrox graphics Card. 13Both Platforms uses Matrox graphics Card.
@@ -64,13 +64,13 @@ common metadata shared between BSPs) e.g.:
64 yocto/meta-intel \ 64 yocto/meta-intel \
65 yocto/meta-intel/meta-crystalforest \ 65 yocto/meta-intel/meta-crystalforest \
66 66
67To enable the Crystal Forest Stargo layer, add the crystalforest-stargo MACHINE to local.conf: 67To enable the Crystal Forest Gladden layer, add the crystalforest-gladden MACHINE to local.conf:
68 68
69 MACHINE ?= "crystalforest-stargo" 69 MACHINE ?= "crystalforest-gladden"
70 70
71To enable the Crystal Forest Shumway layer, add the crystalforest-shumway MACHINE to local.conf: 71To enable the Crystal Forest Server layer, add the crystalforest-server MACHINE to local.conf:
72 72
73 MACHINE ?= "crystalforest-shumway" 73 MACHINE ?= "crystalforest-server"
74 74
75 75
76You should then be able to build a crystalforest image as such: 76You should then be able to build a crystalforest image as such:
@@ -103,15 +103,15 @@ Under Linux, insert a USB flash drive. Assuming the USB flash drive
103takes device /dev/sdf, use dd to copy the live image to it. For 103takes device /dev/sdf, use dd to copy the live image to it. For
104example: 104example:
105 105
106To boot the Stargo Platform: 106To boot the Gladden Platform:
107 107
108# dd if=core-image-sato-crystalforest-stargo-20120829033154.hddimg of=/dev/sdf 108# dd if=core-image-sato-crystalforest-gladden-20120829033154.hddimg of=/dev/sdf
109# sync 109# sync
110# eject /dev/sdf 110# eject /dev/sdf
111 111
112To boot the Shumway Platform: 112To boot the Server Platform:
113 113
114# dd if=core-image-sato-crystalforest-shumway-20120829044852.hddimg of=/dev/sdf 114# dd if=core-image-sato-crystalforest-server-20120829044852.hddimg of=/dev/sdf
115# sync 115# sync
116# eject /dev/sdf 116# eject /dev/sdf
117 117
@@ -135,5 +135,3 @@ the syslinux boot: prompt, or the boot: prompt contains strange
135characters), try doing this first: 135characters), try doing this first:
136 136
137# dd if=/dev/zero of=/dev/sdf bs=1M count=512 137# dd if=/dev/zero of=/dev/sdf bs=1M count=512
138
139
diff --git a/meta-crystalforest/conf/machine/crystalforest-stargo.conf b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
index 575a504d..a84088aa 100644
--- a/meta-crystalforest/conf/machine/crystalforest-stargo.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
@@ -1,7 +1,7 @@
1#@TYPE: Machine 1#@TYPE: Machine
2#@NAME: crystalforest-stargo 2#@NAME: crystalforest-gladden
3 3
4#@DESCRIPTION: Machine configuration for Crystal Forest (STARGO) systems 4#@DESCRIPTION: Machine configuration for Crystal Forest (GLADDEN) systems
5# i.e. One Sandy Bridge based Gladden Processor + One Cave Creek Chipset 5# i.e. One Sandy Bridge based Gladden Processor + One Cave Creek Chipset
6 6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
diff --git a/meta-crystalforest/conf/machine/crystalforest-shumway.conf b/meta-crystalforest/conf/machine/crystalforest-server.conf
index 0a2141c8..2bbc4f31 100644
--- a/meta-crystalforest/conf/machine/crystalforest-shumway.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-server.conf
@@ -1,7 +1,7 @@
1#@TYPE: Machine 1#@TYPE: Machine
2#@NAME: crystalforest-shumway 2#@NAME: crystalforest-server
3 3
4#@DESCRIPTION: Machine configuration for Crystal Forest Server (SHUMWAY) systems 4#@DESCRIPTION: Machine configuration for Crystal Forest Server systems
5# i.e. Two Sandy Bridge Jaketown processors (SNB-EP ES2 Grade and SNB-EN ES2 Grade) + Two Cave Creek Chipsets. 5# i.e. Two Sandy Bridge Jaketown processors (SNB-EP ES2 Grade and SNB-EN ES2 Grade) + Two Cave Creek Chipsets.
6 6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" 7PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
diff --git a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-gladden/machconfig
index ffce0122..ffce0122 100644
--- a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-shumway/machconfig
+++ b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-gladden/machconfig
diff --git a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-server/machconfig
index ffce0122..ffce0122 100644
--- a/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-stargo/machconfig
+++ b/meta-crystalforest/recipes-bsp/formfactor/formfactor/crystalforest-server/machconfig
diff --git a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-gladden/xorg.conf
index 28ad0bf7..28ad0bf7 100644
--- a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-shumway/xorg.conf
+++ b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-gladden/xorg.conf
diff --git a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-server/xorg.conf
index 28ad0bf7..28ad0bf7 100644
--- a/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-stargo/xorg.conf
+++ b/meta-crystalforest/recipes-graphics/xorg-xserver/xserver-xf86-config/crystalforest-server/xorg.conf
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
index 240ba2fa..1295b850 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -1,18 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_crystalforest-stargo = "crystalforest-stargo" 3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladen"
4KMACHINE_crystalforest-stargo = "crystalforest" 4KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-stargo = "standard/preempt-rt/base" 5KBRANCH_crystalforest-gladden = "standard/preempt-rt/base"
6 6
7SRCREV_machine_pn-linux-yocto-rt_crystalforest-stargo ?= "9032b1e9daf5b4396f939981c3be95f67802d18c" 7SRCREV_machine_pn-linux-yocto-rt_crystalforest-gladden ?= "9032b1e9daf5b4396f939981c3be95f67802d18c"
8SRCREV_meta_pn-linux-yocto-rt_crystalforest-stargo ?= "9e3bdb7344054264b750e53fbbb6394cc1c942ac" 8SRCREV_meta_pn-linux-yocto-rt_crystalforest-gladden ?= "9e3bdb7344054264b750e53fbbb6394cc1c942ac"
9 9
10COMPATIBLE_MACHINE_crystalforest-server = "crystalforest-server"
11KMACHINE_crystalforest-server = "crystalforest"
12KBRANCH_crystalforest-server = "standard/preempt-rt/base"
10 13
11COMPATIBLE_MACHINE_crystalforest-shumway = "crystalforest-shumway" 14SRCREV_machine_pn-linux-yocto-rt_crystalforest-server ?= "9032b1e9daf5b4396f939981c3be95f67802d18c"
12KMACHINE_crystalforest-shumway = "crystalforest" 15SRCREV_meta_pn-linux-yocto-rt_crystalforest-server ?= "9e3bdb7344054264b750e53fbbb6394cc1c942ac"
13KBRANCH_crystalforest-shumway = "standard/preempt-rt/base"
14
15SRCREV_machine_pn-linux-yocto-rt_crystalforest-shumway ?= "9032b1e9daf5b4396f939981c3be95f67802d18c"
16SRCREV_meta_pn-linux-yocto-rt_crystalforest-shumway ?= "9e3bdb7344054264b750e53fbbb6394cc1c942ac"
17 16
18module_autoload_uio = "uio" 17module_autoload_uio = "uio"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
index a065abae..84183077 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,17 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_crystalforest-stargo = "crystalforest-stargo" 3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
4KMACHINE_crystalforest-stargo = "crystalforest" 4KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-stargo = "standard/common-pc-64/crystalforest" 5KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"
6 6
7SRCREV_machine_pn-linux-yocto_crystalforest-stargo ?= "449f7f520350700858f21a5554b81cc8ad23267d" 7SRCREV_machine_pn-linux-yocto_crystalforest-gladden ?= "449f7f520350700858f21a5554b81cc8ad23267d"
8SRCREV_meta_pn-linux-yocto_crystalforest-stargo ?= "2ec32d511b62d44b63e8560a9b1d6895a5dac695" 8SRCREV_meta_pn-linux-yocto_crystalforest-gladden ?= "2ec32d511b62d44b63e8560a9b1d6895a5dac695"
9 9
10COMPATIBLE_MACHINE_crystalforest-shumway = "crystalforest-shumway" 10COMPATIBLE_MACHINE_crystalforest-server = "crystalforest-server"
11KMACHINE_crystalforest-shumway = "crystalforest" 11KMACHINE_crystalforest-server = "crystalforest"
12KBRANCH_crystalforest-shumway = "standard/common-pc-64/crystalforest" 12KBRANCH_crystalforest-server = "standard/common-pc-64/crystalforest"
13 13
14SRCREV_machine_pn-linux-yocto_crystalforest-shumway ?= "449f7f520350700858f21a5554b81cc8ad23267d" 14SRCREV_machine_pn-linux-yocto_crystalforest-server ?= "449f7f520350700858f21a5554b81cc8ad23267d"
15SRCREV_meta_pn-linux-yocto_crystalforest-shumway ?= "2ec32d511b62d44b63e8560a9b1d6895a5dac695" 15SRCREV_meta_pn-linux-yocto_crystalforest-server ?= "2ec32d511b62d44b63e8560a9b1d6895a5dac695"
16 16
17module_autoload_uio = "uio" 17module_autoload_uio = "uio"