diff options
-rw-r--r-- | recipes-opencl/igc/files/0001-Fix-for-the-gcc-9-issue.patch | 76 | ||||
-rw-r--r-- | recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb | 1 |
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes-opencl/igc/files/0001-Fix-for-the-gcc-9-issue.patch b/recipes-opencl/igc/files/0001-Fix-for-the-gcc-9-issue.patch new file mode 100644 index 00000000..70447176 --- /dev/null +++ b/recipes-opencl/igc/files/0001-Fix-for-the-gcc-9-issue.patch | |||
@@ -0,0 +1,76 @@ | |||
1 | From c3e985e0e82e9b4c2cc8d4dbfd8ff7890daa50e0 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Wesierski, Lukasz" <lukasz.wesierski@intel.com> | ||
3 | Date: Thu, 6 Jun 2019 21:00:00 -0700 | ||
4 | Subject: [PATCH] Fix for the gcc-9 issue. | ||
5 | |||
6 | Fixes #91 | ||
7 | |||
8 | Change-Id: I8149771d6add9645126cb94584f46485c256a488 | ||
9 | |||
10 | Upstream-Status: Backport | ||
11 | [https://github.com/intel/intel-graphics-compiler/commit/b95b2220ddd1d50b718cae6829d832a14ff60790] | ||
12 | |||
13 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
14 | --- | ||
15 | IGC/AdaptorOCL/cif/cif/common/cif.h | 8 ++++++++ | ||
16 | IGC/common/LLVMWarningsPop.hpp | 4 ++++ | ||
17 | IGC/common/LLVMWarningsPush.hpp | 10 ++++++++++ | ||
18 | 3 files changed, 22 insertions(+) | ||
19 | |||
20 | diff --git a/IGC/AdaptorOCL/cif/cif/common/cif.h b/IGC/AdaptorOCL/cif/cif/common/cif.h | ||
21 | index 99d67d5a..00352964 100644 | ||
22 | --- a/IGC/AdaptorOCL/cif/cif/common/cif.h | ||
23 | +++ b/IGC/AdaptorOCL/cif/cif/common/cif.h | ||
24 | @@ -310,6 +310,14 @@ struct InterfacesList { | ||
25 | requestedInterfaceId, std::forward<DefaultValueT>(defaultValue), std::forward<Args>(args)...); | ||
26 | } | ||
27 | |||
28 | + /// Calls Callable::Call with all contained interfaces (sequentially, one at a time) as template parameters. | ||
29 | + /// Arguments will be forwarded as regular function parameters to Callable::Call. | ||
30 | + template <typename Callable, typename RetType, typename DefaultValueT> | ||
31 | + static RetType forwardToOne(InterfaceId_t requestedInterfaceId, DefaultValueT &&defaultValue) { | ||
32 | + return forwardToOneImpl<0, RetType, Callable, DefaultValueT, InterfacePack<SupportedInterfaces...>>( | ||
33 | + requestedInterfaceId, std::forward<DefaultValueT>(defaultValue)); | ||
34 | + } | ||
35 | + | ||
36 | /// Calls Callable::Call with all contained interfaces (sequentially, one at a time) as template parameters. | ||
37 | /// Arguments will be forwarded as regular function parameters to Callable::Call. | ||
38 | template <typename Callable, typename... Args> | ||
39 | diff --git a/IGC/common/LLVMWarningsPop.hpp b/IGC/common/LLVMWarningsPop.hpp | ||
40 | index 9875acb8..f8e405d2 100644 | ||
41 | --- a/IGC/common/LLVMWarningsPop.hpp | ||
42 | +++ b/IGC/common/LLVMWarningsPop.hpp | ||
43 | @@ -57,3 +57,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
44 | #ifdef _MSC_VER | ||
45 | # pragma warning( pop ) | ||
46 | #endif | ||
47 | + | ||
48 | +#if defined(__linux__) | ||
49 | +# pragma GCC diagnostic pop | ||
50 | +#endif | ||
51 | diff --git a/IGC/common/LLVMWarningsPush.hpp b/IGC/common/LLVMWarningsPush.hpp | ||
52 | index bab4a5e1..aca8db34 100644 | ||
53 | --- a/IGC/common/LLVMWarningsPush.hpp | ||
54 | +++ b/IGC/common/LLVMWarningsPush.hpp | ||
55 | @@ -55,8 +55,18 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
56 | # pragma warning( push ) | ||
57 | #endif | ||
58 | |||
59 | +#if defined(__linux__) | ||
60 | +# pragma GCC diagnostic push | ||
61 | +#endif | ||
62 | + | ||
63 | #include <llvm/Config/llvm-config.h> | ||
64 | |||
65 | +#if defined(__linux__) | ||
66 | +# if __GNUC__ > 8 | ||
67 | +# pragma GCC diagnostic ignored "-Winit-list-lifetime" | ||
68 | +# endif | ||
69 | +#endif | ||
70 | + | ||
71 | #if defined( _WIN32 ) || defined( _WIN64 ) | ||
72 | |||
73 | // 'inline' : used more than once | ||
74 | -- | ||
75 | 2.17.0 | ||
76 | |||
diff --git a/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb b/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb index 83aba578..f64b97fd 100644 --- a/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb +++ b/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb | |||
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc | |||
9 | 9 | ||
10 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \ | 10 | SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \ |
11 | file://0001-skip-execution-of-ElfPackager.patch \ | 11 | file://0001-skip-execution-of-ElfPackager.patch \ |
12 | file://0001-Fix-for-the-gcc-9-issue.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRCREV = "ebfc688126900a821e407a96417800919b793447" | 15 | SRCREV = "ebfc688126900a821e407a96417800919b793447" |