diff options
-rw-r--r-- | common/recipes-core/images/core-image-minimal-initramfs.bbappend | 3 | ||||
-rw-r--r-- | conf/machine/intel-core2-32.conf | 2 | ||||
-rw-r--r-- | conf/machine/intel-corei7-64.conf | 2 |
3 files changed, 3 insertions, 4 deletions
diff --git a/common/recipes-core/images/core-image-minimal-initramfs.bbappend b/common/recipes-core/images/core-image-minimal-initramfs.bbappend index 1611beb7..4ddca375 100644 --- a/common/recipes-core/images/core-image-minimal-initramfs.bbappend +++ b/common/recipes-core/images/core-image-minimal-initramfs.bbappend | |||
@@ -1,3 +1,6 @@ | |||
1 | # Use initramfs-framework instead of initramfs-live* | 1 | # Use initramfs-framework instead of initramfs-live* |
2 | PACKAGE_INSTALL_remove_intel-x86-common = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi" | 2 | PACKAGE_INSTALL_remove_intel-x86-common = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi" |
3 | PACKAGE_INSTALL_append_intel-x86-common = " initramfs-framework-base initramfs-module-udev initramfs-module-setup-live initramfs-module-install-efi" | 3 | PACKAGE_INSTALL_append_intel-x86-common = " initramfs-framework-base initramfs-module-udev initramfs-module-setup-live initramfs-module-install-efi" |
4 | |||
5 | # Add i915 graphics firmware | ||
6 | PACKAGE_INSTALL_append_intel-x86-common = " linux-firmware-i915" | ||
diff --git a/conf/machine/intel-core2-32.conf b/conf/machine/intel-core2-32.conf index bc2c7640..abe6f901 100644 --- a/conf/machine/intel-core2-32.conf +++ b/conf/machine/intel-core2-32.conf | |||
@@ -30,8 +30,6 @@ SYSLINUX_OPTS = "serial 0 115200" | |||
30 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyPCH0" | 30 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyPCH0" |
31 | APPEND += "rootwait console=ttyS0,115200 console=ttyPCH0,115200 console=tty0" | 31 | APPEND += "rootwait console=ttyS0,115200 console=ttyPCH0,115200 console=tty0" |
32 | 32 | ||
33 | PACKAGE_INSTALL_append_pn-core-image-minimal-initramfs = " linux-firmware-i915" | ||
34 | |||
35 | IMAGE_FSTYPES += "wic" | 33 | IMAGE_FSTYPES += "wic" |
36 | WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}" | 34 | WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}" |
37 | do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" | 35 | do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" |
diff --git a/conf/machine/intel-corei7-64.conf b/conf/machine/intel-corei7-64.conf index d88be2db..a8097fc3 100644 --- a/conf/machine/intel-corei7-64.conf +++ b/conf/machine/intel-corei7-64.conf | |||
@@ -31,8 +31,6 @@ SYSLINUX_OPTS = "serial 0 115200" | |||
31 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyS2" | 31 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1 115200;ttyS2" |
32 | APPEND += "rootwait console=ttyS0,115200 console=tty0" | 32 | APPEND += "rootwait console=ttyS0,115200 console=tty0" |
33 | 33 | ||
34 | PACKAGE_INSTALL_append_pn-core-image-minimal-initramfs = " linux-firmware-i915" | ||
35 | |||
36 | IMAGE_FSTYPES += "wic" | 34 | IMAGE_FSTYPES += "wic" |
37 | WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}" | 35 | WKS_FILE ?= "${@bb.utils.contains_any("EFI_PROVIDER", "systemd-boot rmc-boot", "systemd-bootdisk.wks", "mkefidisk.wks", d)}" |
38 | do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" | 36 | do_image_wic[depends] += "gptfdisk-native:do_populate_sysroot mtools-native:do_populate_sysroot dosfstools-native:do_populate_sysroot" |