diff options
-rw-r--r-- | common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch | 20 | ||||
-rw-r--r-- | common/recipes-bsp/amt/lms/readlink-declaration.patch | 18 | ||||
-rw-r--r-- | common/recipes-bsp/amt/lms_7.1.20.bb | 43 |
3 files changed, 81 insertions, 0 deletions
diff --git a/common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch b/common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch new file mode 100644 index 00000000..6bb03e3a --- /dev/null +++ b/common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | Add a missing debug ifdef causing compilation problems. | ||
2 | |||
3 | Upstream-Status: Submitted | ||
4 | |||
5 | Signed-off-by: Tom Zanussi <tom.zanussi (a] intel.com> | ||
6 | |||
7 | Index: lms-7.1.20/src/tools/ATNetworkTool.cpp | ||
8 | =================================================================== | ||
9 | --- lms-7.1.20.orig/src/tools/ATNetworkTool.cpp 2012-04-30 23:24:56.693879920 -0500 | ||
10 | +++ lms-7.1.20/src/tools/ATNetworkTool.cpp 2012-04-30 23:25:32.363473948 -0500 | ||
11 | @@ -302,7 +302,9 @@ | ||
12 | close(s); | ||
13 | return -1; | ||
14 | } | ||
15 | +#ifdef LMS_NET_DEBUG | ||
16 | printf("successfully binded local\n"); | ||
17 | +#endif | ||
18 | |||
19 | } | ||
20 | if (bind(s, addr, addrlen) == -1) { | ||
diff --git a/common/recipes-bsp/amt/lms/readlink-declaration.patch b/common/recipes-bsp/amt/lms/readlink-declaration.patch new file mode 100644 index 00000000..0246d501 --- /dev/null +++ b/common/recipes-bsp/amt/lms/readlink-declaration.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Add a missing include causing compilation (missing declaration) problems. | ||
2 | |||
3 | Upstream-Status: Submitted | ||
4 | |||
5 | Signed-off-by: Tom Zanussi <tom.zanussi (a] intel.com> | ||
6 | |||
7 | Index: lms-7.1.20/src/tools/ATVersion.cpp | ||
8 | =================================================================== | ||
9 | --- lms-7.1.20.orig/src/tools/ATVersion.cpp 2012-05-29 20:34:34.061997035 -0500 | ||
10 | +++ lms-7.1.20/src/tools/ATVersion.cpp 2012-05-29 20:35:22.671412948 -0500 | ||
11 | @@ -40,6 +40,7 @@ | ||
12 | #include <cerrno> | ||
13 | #include <fstream> | ||
14 | #include <dirent.h> | ||
15 | +#include <unistd.h> | ||
16 | |||
17 | #define AT_VERSION_ARGUMENT "--version" | ||
18 | #define AT_VERSION_MAXSIZE 40 | ||
diff --git a/common/recipes-bsp/amt/lms_7.1.20.bb b/common/recipes-bsp/amt/lms_7.1.20.bb new file mode 100644 index 00000000..3fd8c278 --- /dev/null +++ b/common/recipes-bsp/amt/lms_7.1.20.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | DESCRIPTION = "Intel Local Manageability Service allows applications \ | ||
2 | to access the Intel Active Management Technology (AMT) firmware via \ | ||
3 | the Intel Management Engine Interface (MEI)." | ||
4 | HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers" | ||
5 | |||
6 | LICENSE = "Modified BSD" | ||
7 | |||
8 | PR = "r0" | ||
9 | SRC_URI = "http://software.intel.com/file/37962 \ | ||
10 | file://atnetworktool-printf-fix.patch \ | ||
11 | file://readlink-declaration.patch" | ||
12 | |||
13 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' | ||
14 | |||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=7264184cf88d9f27b719a9656255b47b" | ||
16 | |||
17 | SRC_URI[md5sum] = "687b76e78bfdbcf567c0e842c1fe240a" | ||
18 | SRC_URI[sha256sum] = "cc0457f0044e924794bb1aeae9a72c28666a525cd8a963d0d92970222946e75b" | ||
19 | |||
20 | inherit autotools update-rc.d | ||
21 | |||
22 | INITSCRIPT_NAME = "lms" | ||
23 | INITSCRIPT_PARAMS = "defaults" | ||
24 | |||
25 | PV_SUB = "25" | ||
26 | |||
27 | do_unpack2() { | ||
28 | # The downloaded 37962 filename is actually lms+7.1.20.25.zip. | ||
29 | # It contains lms-7.1.20-25.tar.gz. | ||
30 | # It contains lms-7.1.20-25.tar.gz untars to lms-7.1.20 | ||
31 | mv ${WORKDIR}/37962 ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip | ||
32 | unzip -o ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip | ||
33 | mv ${WORKDIR}/${PN}-${PV}/outputdir/${PN}-${PV}-${PV_SUB}.tar.gz ${WORKDIR}/ | ||
34 | cd ${WORKDIR} | ||
35 | tar -xvzf ${PN}-${PV}-${PV_SUB}.tar.gz | ||
36 | } | ||
37 | |||
38 | addtask unpack2 after do_unpack before do_patch | ||
39 | |||
40 | do_install_append () { | ||
41 | install -d ${D}${sysconfdir}/init.d | ||
42 | install -m 0755 ${WORKDIR}/${PN}-${PV}/scripts/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
43 | } | ||