diff options
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.12.bbappend | 10 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.12.bbappend | 18 |
2 files changed, 2 insertions, 26 deletions
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend index de336b04..daa7dd6b 100644 --- a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend +++ b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend | |||
@@ -1,9 +1 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON ?= "" | require meta-intel-compat-kernel.inc | |
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend index b99001ed..daa7dd6b 100644 --- a/recipes-kernel/linux/linux-yocto_4.12.bbappend +++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend | |||
@@ -1,17 +1 @@ | |||
1 | KERNEL_FEATURES_INTEL_COMMON ?= "" | require meta-intel-compat-kernel.inc | |
2 | |||
3 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | ||
4 | KMACHINE_core2-32-intel-common = "intel-core2-32" | ||
5 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
6 | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | ||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | ||
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | ||
10 | |||
11 | # For Crystalforest and Romley | ||
12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
14 | |||
15 | # For FRI2, NUC | ||
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi" | ||
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi" | ||