diff options
-rw-r--r-- | meta-isg/meta-haswell-wc/COPYING.MIT | 17 | ||||
-rw-r--r-- | meta-isg/meta-haswell-wc/README | 152 | ||||
-rw-r--r-- | meta-isg/meta-haswell-wc/README.sources | 17 | ||||
-rw-r--r-- | meta-isg/meta-haswell-wc/conf/layer.conf | 12 |
4 files changed, 198 insertions, 0 deletions
diff --git a/meta-isg/meta-haswell-wc/COPYING.MIT b/meta-isg/meta-haswell-wc/COPYING.MIT new file mode 100644 index 00000000..89de3547 --- /dev/null +++ b/meta-isg/meta-haswell-wc/COPYING.MIT | |||
@@ -0,0 +1,17 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-isg/meta-haswell-wc/README b/meta-isg/meta-haswell-wc/README new file mode 100644 index 00000000..0f0af715 --- /dev/null +++ b/meta-isg/meta-haswell-wc/README | |||
@@ -0,0 +1,152 @@ | |||
1 | This README file contains information on building the meta-haswell-wc | ||
2 | BSP layer, and booting the images contained in the /binary directory. | ||
3 | Please see the corresponding sections below for details. | ||
4 | |||
5 | The BSP is made specifically for 4th Gen Intel Core Processor (Haswell) | ||
6 | Development Kit with Mobile Intel QM87 & HM86 Chipset (formerly known as | ||
7 | Shark Bay). This BSP assumes that integrated graphics are being used. | ||
8 | The "haswell-wc" BSP is meant to support "Walnut Canyon" Shark Bay | ||
9 | development kit. | ||
10 | |||
11 | Further information about the Haswell Platforms supported by this BSP can be | ||
12 | found here: | ||
13 | |||
14 | http://www.intel.com/content/www/us/en/intelligent-systems/shark-bay/4th-generation-core-qm87-hm86-chipsets.html | ||
15 | |||
16 | Information on all IntelĀ® embedded platforms can be found here: | ||
17 | |||
18 | http://www.intel.com/p/en_US/embedded/hwsw/hardware | ||
19 | |||
20 | |||
21 | Compliance | ||
22 | ========== | ||
23 | |||
24 | This BSP is compliant with the Yocto Project as per the requirements | ||
25 | listed here: | ||
26 | |||
27 | https://www.yoctoproject.org/webform/yocto-project-compatible-registration | ||
28 | |||
29 | |||
30 | Dependencies | ||
31 | ============ | ||
32 | |||
33 | This layer depends on: | ||
34 | |||
35 | URI: git://git.openembedded.org/bitbake | ||
36 | branch: master | ||
37 | |||
38 | URI: git://git.openembedded.org/openembedded-core | ||
39 | layers: meta | ||
40 | branch: master | ||
41 | |||
42 | URI: git://git.yoctoproject.org/meta-intel | ||
43 | layers: intel | ||
44 | branch: master | ||
45 | |||
46 | Patches | ||
47 | ======= | ||
48 | |||
49 | Please submit any patches against this BSP to the Yocto mailing list | ||
50 | (yocto@yoctoproject.org) and cc: the maintainer: | ||
51 | |||
52 | Maintainer: Ong Boon Leong <boon.leong.ong@intel.com> | ||
53 | |||
54 | Please see the meta-intel/MAINTAINERS file for more details. | ||
55 | |||
56 | |||
57 | Table of Contents | ||
58 | ================= | ||
59 | |||
60 | I. Building the meta-haswell-wc BSP layer | ||
61 | II. Booting the images in /binary | ||
62 | |||
63 | |||
64 | I. Building the meta-haswell-wc BSP layer | ||
65 | ======================================= | ||
66 | |||
67 | In order to build an image with BSP support for a given release, you | ||
68 | need to download the corresponding BSP tarball from the 'Board Support | ||
69 | Package (BSP) Downloads' page of the Yocto Project website. | ||
70 | |||
71 | Having done that, and assuming you extracted the BSP tarball contents | ||
72 | at the top-level of your yocto build tree, you can build a haswell-wc | ||
73 | image by adding the location of the meta-haswell-wc layer to | ||
74 | bblayers.conf, along with the meta-intel layer itself (to access | ||
75 | common metadata shared between BSPs) e.g.: | ||
76 | |||
77 | yocto/meta-intel \ | ||
78 | yocto/meta-intel/meta-isg/meta-haswell-wc \ | ||
79 | |||
80 | To enable the haswell-wc layer, add the haswell-wc MACHINE to local.conf: | ||
81 | |||
82 | MACHINE ?= "haswell-wc" | ||
83 | |||
84 | You should then be able to build a haswell-wc image as such: | ||
85 | |||
86 | $ source oe-init-build-env | ||
87 | $ bitbake core-image-sato | ||
88 | |||
89 | At the end of a successful build, you should have a live image that | ||
90 | you can boot from a USB flash drive (see instructions on how to do | ||
91 | that below, in the section 'Booting the images from /binary'). | ||
92 | |||
93 | NOTE: The 'haswell-wc' machine will include support for hardware video | ||
94 | acceleration via gstreamer if and only if the "commercial" string is | ||
95 | added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf. | ||
96 | |||
97 | For example: | ||
98 | |||
99 | LICENSE_FLAGS_WHITELIST = "commercial" | ||
100 | |||
101 | The reason this is needed is to prevent the image from including | ||
102 | anything that might violate the license terms of the packages used to | ||
103 | implement the the video acceleration feature, such as gst-ffmpeg and | ||
104 | ffmpeg. As always, please consult the licenses included in the | ||
105 | specific packages for details if you use packages that require | ||
106 | particular LICENSE_FLAGS. | ||
107 | |||
108 | As an alternative to downloading the BSP tarball, you can also work | ||
109 | directly from the meta-intel git repository. For each BSP in the | ||
110 | 'meta-intel' repository, there are multiple branches, one | ||
111 | corresponding to each major release starting with 'laverne' (0.90), in | ||
112 | addition to the latest code which tracks the current master (note that | ||
113 | not all BSPs are present in every release). Instead of extracting a | ||
114 | BSP tarball at the top level of your yocto build tree, you can | ||
115 | equivalently check out the appropriate branch from the meta-intel | ||
116 | repository at the same location. | ||
117 | |||
118 | |||
119 | II. Booting the images in /binary | ||
120 | ================================= | ||
121 | |||
122 | This BSP contains bootable live images, which can be used to directly | ||
123 | boot Yocto off of a USB flash drive. | ||
124 | |||
125 | Under Linux, insert a USB flash drive. Assuming the USB flash drive | ||
126 | takes device /dev/sdf, use dd to copy the live image to it. For | ||
127 | example: | ||
128 | |||
129 | # dd if=core-image-sato-haswell-wc.hddimg of=/dev/sdf | ||
130 | # sync | ||
131 | # eject /dev/sdf | ||
132 | |||
133 | This should give you a bootable USB flash device. Insert the device | ||
134 | into a bootable USB socket on the target, and power on. This should | ||
135 | result in a system booted to the Sato graphical desktop. | ||
136 | |||
137 | If you want a terminal, use the arrows at the top of the UI to move to | ||
138 | different pages of available applications, one of which is named | ||
139 | 'Terminal'. Clicking that should give you a root terminal. | ||
140 | |||
141 | If you want to ssh into the system, you can use the root terminal to | ||
142 | ifconfig the IP address and use that to ssh in. The root password is | ||
143 | empty, so to log in type 'root' for the user name and hit 'Enter' at | ||
144 | the Password prompt: and you should be in. | ||
145 | |||
146 | ---- | ||
147 | |||
148 | If you find you're getting corrupt images on the USB (it doesn't show | ||
149 | the syslinux boot: prompt, or the boot: prompt contains strange | ||
150 | characters), try doing this first: | ||
151 | |||
152 | # dd if=/dev/zero of=/dev/sdf bs=1M count=512 | ||
diff --git a/meta-isg/meta-haswell-wc/README.sources b/meta-isg/meta-haswell-wc/README.sources new file mode 100644 index 00000000..8cde68e8 --- /dev/null +++ b/meta-isg/meta-haswell-wc/README.sources | |||
@@ -0,0 +1,17 @@ | |||
1 | The sources for the packages comprising the images shipped with this | ||
2 | BSP can be found at the following location: | ||
3 | |||
4 | http://downloads.yoctoproject.org/mirror/sources/ | ||
5 | |||
6 | The metadata used to generate the images shipped with this BSP, in | ||
7 | addition to the code contained in this BSP, can be found at the | ||
8 | following location: | ||
9 | |||
10 | http://downloads.yoctoproject.org/releases/yocto/yocto-1.4/poky-dylan-9.0.2.tar.bz2 | ||
11 | |||
12 | The metadata used to generate the images shipped with this BSP, in | ||
13 | addition to the code contained in this BSP, can also be found at the | ||
14 | following locations: | ||
15 | |||
16 | git://git.yoctoproject.org/poky.git | ||
17 | git://git.yoctoproject.org/meta-intel | ||
diff --git a/meta-isg/meta-haswell-wc/conf/layer.conf b/meta-isg/meta-haswell-wc/conf/layer.conf new file mode 100644 index 00000000..bfd1f823 --- /dev/null +++ b/meta-isg/meta-haswell-wc/conf/layer.conf | |||
@@ -0,0 +1,12 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "haswell-wc" | ||
9 | BBFILE_PATTERN_haswell-wc := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_haswell-wc = "6" | ||
11 | |||
12 | LAYERDEPENDS_haswell-wc = "intel" | ||