diff options
-rw-r--r-- | recipes-kernel/linux/linux-intel.inc | 5 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-dev.bbappend | 5 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.10.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.12.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.4.bbappend | 8 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-rt_4.9.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend | 7 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend | 7 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.10.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.12.bbappend | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.4.bbappend | 10 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_4.9.bbappend | 4 |
14 files changed, 1 insertions, 73 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc index f03ef463..b8a9798b 100644 --- a/recipes-kernel/linux/linux-intel.inc +++ b/recipes-kernel/linux/linux-intel.inc | |||
@@ -22,7 +22,7 @@ KCONF_BSP_AUDIT_LEVEL = "2" | |||
22 | 22 | ||
23 | KERNEL_FEATURES_INTEL_COMMON ?= "" | 23 | KERNEL_FEATURES_INTEL_COMMON ?= "" |
24 | 24 | ||
25 | COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32|intel-quark)" | 25 | COMPATIBLE_MACHINE ?= "(intel-corei7-64|intel-core2-32)" |
26 | COMPATIBLE_MACHINE_intel-x86-common = "${MACHINE}" | 26 | COMPATIBLE_MACHINE_intel-x86-common = "${MACHINE}" |
27 | 27 | ||
28 | KMACHINE_core2-32-intel-common = "intel-core2-32" | 28 | KMACHINE_core2-32-intel-common = "intel-core2-32" |
@@ -31,9 +31,6 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
31 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 31 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
32 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 32 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
33 | 33 | ||
34 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
35 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "features/qat/qat.scc" | ||
36 | |||
37 | # Functionality flags | 34 | # Functionality flags |
38 | KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" | 35 | KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" |
39 | KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" | 36 | KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" |
diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend index ee33ecc3..6173148c 100644 --- a/recipes-kernel/linux/linux-yocto-dev.bbappend +++ b/recipes-kernel/linux/linux-yocto-dev.bbappend | |||
@@ -8,11 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | |||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | 10 | ||
11 | # Quark / X1000 BSP Info | ||
12 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
13 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
14 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
15 | |||
16 | # NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV | 11 | # NOTE: We do not set SRCREVs here as -dev is intended to be built with AUTOREV |
17 | # and setting them here breaks the default mechanism to use AUTOREV if the | 12 | # and setting them here breaks the default mechanism to use AUTOREV if the |
18 | # default SRCREV is set and linux-yocto-dev is the preferred provider. | 13 | # default SRCREV is set and linux-yocto-dev is the preferred provider. |
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend index 17569a1c..de336b04 100644 --- a/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend +++ b/recipes-kernel/linux/linux-yocto-rt_4.10.bbappend | |||
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | |||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend index 17569a1c..de336b04 100644 --- a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend +++ b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend | |||
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | |||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend index c18f4a11..b8dba297 100644 --- a/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend +++ b/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend | |||
@@ -23,11 +23,3 @@ KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}" | |||
23 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | 23 | SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}" |
24 | SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | 24 | SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" |
25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
26 | |||
27 | LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
28 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
29 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
30 | KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
31 | SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
32 | SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | ||
33 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend index 9d2e3c0b..3e591799 100644 --- a/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend +++ b/recipes-kernel/linux/linux-yocto-rt_4.9.bbappend | |||
@@ -7,7 +7,3 @@ KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | |||
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | |||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend index b8d3d81c..e8c27707 100644 --- a/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend +++ b/recipes-kernel/linux/linux-yocto-tiny_4.10.bbappend | |||
@@ -2,18 +2,14 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | KERNEL_FEATURES_INTEL_COMMON ?= "" | 3 | KERNEL_FEATURES_INTEL_COMMON ?= "" |
4 | 4 | ||
5 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
6 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | 5 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" |
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 6 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
8 | 7 | ||
9 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base" | ||
10 | KBRANCH_core2-32-intel-common = "standard/tiny/base" | 8 | KBRANCH_core2-32-intel-common = "standard/tiny/base" |
11 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" | 9 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" |
12 | 10 | ||
13 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
14 | KMACHINE_core2-32-intel-common = "intel-core2-32" | 11 | KMACHINE_core2-32-intel-common = "intel-core2-32" |
15 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 12 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
16 | 13 | ||
17 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
18 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 14 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 15 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend index b8d3d81c..e8c27707 100644 --- a/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend +++ b/recipes-kernel/linux/linux-yocto-tiny_4.12.bbappend | |||
@@ -2,18 +2,14 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | KERNEL_FEATURES_INTEL_COMMON ?= "" | 3 | KERNEL_FEATURES_INTEL_COMMON ?= "" |
4 | 4 | ||
5 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
6 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | 5 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" |
7 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 6 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
8 | 7 | ||
9 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base" | ||
10 | KBRANCH_core2-32-intel-common = "standard/tiny/base" | 8 | KBRANCH_core2-32-intel-common = "standard/tiny/base" |
11 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" | 9 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" |
12 | 10 | ||
13 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
14 | KMACHINE_core2-32-intel-common = "intel-core2-32" | 11 | KMACHINE_core2-32-intel-common = "intel-core2-32" |
15 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 12 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
16 | 13 | ||
17 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
18 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 14 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
19 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 15 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend index 54430e21..84bb1d23 100644 --- a/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend +++ b/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend | |||
@@ -4,30 +4,23 @@ EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${ | |||
4 | 4 | ||
5 | KERNEL_FEATURES_INTEL_COMMON ?= "" | 5 | KERNEL_FEATURES_INTEL_COMMON ?= "" |
6 | 6 | ||
7 | LINUX_VERSION_i586-nlp-32-intel-common = "4.4.87" | ||
8 | LINUX_VERSION_core2-32-intel-common = "4.4.87" | 7 | LINUX_VERSION_core2-32-intel-common = "4.4.87" |
9 | LINUX_VERSION_corei7-64-intel-common = "4.4.87" | 8 | LINUX_VERSION_corei7-64-intel-common = "4.4.87" |
10 | 9 | ||
11 | SRCREV_meta_i586-nlp-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" | ||
12 | SRCREV_meta_core2-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" | 10 | SRCREV_meta_core2-32-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" |
13 | SRCREV_meta_corei7-64-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" | 11 | SRCREV_meta_corei7-64-intel-common = "804d2b3164ec25ed519fd695de9aa0908460c92e" |
14 | 12 | ||
15 | SRCREV_machine_i586-nlp-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" | ||
16 | SRCREV_machine_core2-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" | 13 | SRCREV_machine_core2-32-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" |
17 | SRCREV_machine_corei7-64-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" | 14 | SRCREV_machine_corei7-64-intel-common = "85b913cc9d5e13602d69e50bd9cf1a6ef242f9ee" |
18 | 15 | ||
19 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
20 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | 16 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" |
21 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 17 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
22 | 18 | ||
23 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base" | ||
24 | KBRANCH_core2-32-intel-common = "standard/tiny/intel/base" | 19 | KBRANCH_core2-32-intel-common = "standard/tiny/intel/base" |
25 | KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base" | 20 | KBRANCH_corei7-64-intel-common = "standard/tiny/intel/base" |
26 | 21 | ||
27 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
28 | KMACHINE_core2-32-intel-common = "intel-core2-32" | 22 | KMACHINE_core2-32-intel-common = "intel-core2-32" |
29 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 23 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
30 | 24 | ||
31 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
32 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 25 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
33 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 26 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
diff --git a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend index 9ecdb95a..84d61ab4 100644 --- a/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend +++ b/recipes-kernel/linux/linux-yocto-tiny_4.9.bbappend | |||
@@ -2,30 +2,23 @@ FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" | 3 | EXTRA_OEMAKE = "LD=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}ld AR=${STAGING_BINDIR_NATIVE}/${HOST_SYS}/${TARGET_PREFIX}gcc-ar" |
4 | 4 | ||
5 | LINUX_VERSION_i586-nlp-32-intel-common = "4.9.13" | ||
6 | LINUX_VERSION_core2-32-intel-common = "4.9.13" | 5 | LINUX_VERSION_core2-32-intel-common = "4.9.13" |
7 | LINUX_VERSION_corei7-64-intel-common = "4.9.13" | 6 | LINUX_VERSION_corei7-64-intel-common = "4.9.13" |
8 | 7 | ||
9 | SRCREV_meta_i586-nlp-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" | ||
10 | SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" | 8 | SRCREV_meta_core2-32-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" |
11 | SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" | 9 | SRCREV_meta_corei7-64-intel-common = "8f3bc608ae61c5333043167fa31bac33be93c3de" |
12 | 10 | ||
13 | SRCREV_machine_i586-nlp-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" | ||
14 | SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" | 11 | SRCREV_machine_core2-32-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" |
15 | SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" | 12 | SRCREV_machine_corei7-64-intel-common = "95c0a80ee83f1cf8e59d733f36e8a9dfd50a0098" |
16 | 13 | ||
17 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
18 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" | 14 | COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" |
19 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | 15 | COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" |
20 | 16 | ||
21 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/base" | ||
22 | KBRANCH_core2-32-intel-common = "standard/tiny/base" | 17 | KBRANCH_core2-32-intel-common = "standard/tiny/base" |
23 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" | 18 | KBRANCH_corei7-64-intel-common = "standard/tiny/base" |
24 | 19 | ||
25 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
26 | KMACHINE_core2-32-intel-common = "intel-core2-32" | 20 | KMACHINE_core2-32-intel-common = "intel-core2-32" |
27 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 21 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
28 | 22 | ||
29 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | ||
30 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 23 | KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
31 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" | 24 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} cfg/fs/ext4.scc" |
diff --git a/recipes-kernel/linux/linux-yocto_4.10.bbappend b/recipes-kernel/linux/linux-yocto_4.10.bbappend index 20504637..b99001ed 100644 --- a/recipes-kernel/linux/linux-yocto_4.10.bbappend +++ b/recipes-kernel/linux/linux-yocto_4.10.bbappend | |||
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | |||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | 10 | ||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
14 | |||
15 | # For Crystalforest and Romley | 11 | # For Crystalforest and Romley |
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | 12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" |
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | 13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" |
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend index 20504637..b99001ed 100644 --- a/recipes-kernel/linux/linux-yocto_4.12.bbappend +++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend | |||
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | |||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | 10 | ||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
14 | |||
15 | # For Crystalforest and Romley | 11 | # For Crystalforest and Romley |
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | 12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" |
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | 13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" |
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend index 3b02a932..33d75f0a 100644 --- a/recipes-kernel/linux/linux-yocto_4.4.bbappend +++ b/recipes-kernel/linux/linux-yocto_4.4.bbappend | |||
@@ -24,16 +24,6 @@ SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SU | |||
24 | KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}" | 24 | KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}" |
25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 25 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
26 | 26 | ||
27 | # Quark / X1000 BSP Info | ||
28 | LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" | ||
29 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
30 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
31 | KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}" | ||
32 | SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}" | ||
33 | SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}" | ||
34 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
35 | |||
36 | |||
37 | # For Crystalforest and Romley | 27 | # For Crystalforest and Romley |
38 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | 28 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" |
39 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | 29 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" |
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend index a09fe1a4..9be620bb 100644 --- a/recipes-kernel/linux/linux-yocto_4.9.bbappend +++ b/recipes-kernel/linux/linux-yocto_4.9.bbappend | |||
@@ -8,10 +8,6 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" | |||
8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" | 8 | KMACHINE_corei7-64-intel-common = "intel-corei7-64" |
9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" | 9 | KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" |
10 | 10 | ||
11 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | ||
12 | KMACHINE_i586-nlp-32-intel-common = "intel-quark" | ||
13 | KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" | ||
14 | |||
15 | # For Crystalforest and Romley | 11 | # For Crystalforest and Romley |
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | 12 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" |
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | 13 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" |