summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/layer.conf5
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_1921.0.0.0.diff31
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb39
3 files changed, 75 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 3e75b0fe..e4ddd175 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -21,4 +21,9 @@ LAYERVERSION_intel = "5"
21LAYERSERIES_COMPAT_intel = "thud warrior" 21LAYERSERIES_COMPAT_intel = "thud warrior"
22 22
23 23
24BBFILES_DYNAMIC += " \
25 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \
26 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
27"
28
24require ${LAYERDIR}/conf/include/maintainers.inc 29require ${LAYERDIR}/conf/include/maintainers.inc
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_1921.0.0.0.diff b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_1921.0.0.0.diff
new file mode 100644
index 00000000..b68924a5
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_1921.0.0.0.diff
@@ -0,0 +1,31 @@
1From b92a5bda8015454a570990a3d9c4fba87010f1af Mon Sep 17 00:00:00 2001
2From: Alexander Usyskin <alexander.usyskin@intel.com>
3Date: Mon, 17 Jun 2019 13:27:33 +0300
4Subject: [PATCH] lms: drop rpath definitions
5
6Yocto fail to compile with this definitions.
7
8Upstream-Status: Inappropriate [configuration]
9Signed-off-by: Alexander Usyskin <alexander.usyskin@intel.com>
10---
11 CMakeLists.txt | 4 ----
12 1 file changed, 4 deletions(-)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index 04257fb..85d0445 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -107,10 +107,6 @@ install (DIRECTORY Docs/Licenses
19 FILES_MATCHING PATTERN "LICENSE.*"
20 )
21
22-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/UNS/GMS_COMMON")
23-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/WsmanClient")
24-list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/UNS/StatusEventHandler")
25-
26 if (BUILD_TESTS)
27 include (gtest.cmake)
28 endif (BUILD_TESTS)
29--
302.7.4
31
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb
new file mode 100644
index 00000000..8ed74486
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_1921.0.0.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Intel(R) Local Managability Service"
2DESCRIPTION = "Intel Local Manageability Service allows applications \
3to access the Intel Active Management Technology (AMT) firmware via \
4the Intel Management Engine Interface (MEI)."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
8
9COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
10
11inherit cmake systemd
12
13DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
14
15EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
16
17REQUIRED_DISTRO_FEATURES= "systemd"
18
19FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
20
21FILES_${PN} += "${libdir}/libLms*.so"
22FILES_SOLIBSDEV = ""
23INSANE_SKIP_${PN} += "dev-so"
24
25S = "${WORKDIR}/git"
26
27SYSTEMD_SERVICE_${PN} = "lms.service"
28
29SRC_URI = "git://github.com/intel/lms.git"
30SRCREV = "f7c374745ae7efb3ed7860fdc3f8abbb52dc9f8f"
31
32SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
33
34do_install_append() {
35 install -d ${D}${systemd_system_unitdir}
36 install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
37}
38
39RDEPENDS_${PN} += "ace"