diff options
-rw-r--r-- | common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend | 27 |
1 files changed, 23 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend index 90e43944..6bfa9686 100644 --- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend +++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend | |||
@@ -1,5 +1,24 @@ | |||
1 | # Temporary avoid warnings of duplicate files providers until | ||
2 | # mesa-dri & emgd-driver-bin recipes are fixed | ||
3 | SSTATE_DUPWHITELIST += "${STAGING_INCDIR}/KHR ${STAGING_INCDIR}/EGL \ | ||
4 | ${STAGING_INCDIR}/GLES ${STAGING_INCDIR}/GLES2" | ||
5 | 1 | ||
2 | # The emgd binary driver also provides egl, gles1, gles2 library & headers. | ||
3 | # To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image | ||
4 | # is bundling the emgd driver. | ||
5 | |||
6 | python __anonymous () { | ||
7 | import re | ||
8 | xserver = d.getVar('XSERVER', True) | ||
9 | if 'emgd-driver-bin' in xserver.split(' '): | ||
10 | extra_oeconf = d.getVar('EXTRA_OECONF', True).split() | ||
11 | take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] | ||
12 | put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] | ||
13 | pattern = re.compile("--with-egl-platforms") | ||
14 | new_extra_oeconf = [ ] | ||
15 | for i in extra_oeconf: | ||
16 | if ( i not in take_out ) and ( not pattern.match(i)): | ||
17 | new_extra_oeconf.append(i) | ||
18 | for i in put_in: | ||
19 | new_extra_oeconf.append(i) | ||
20 | |||
21 | d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf)) | ||
22 | depends = d.getVar('DEPENDS', True) | ||
23 | d.setVar('DEPENDS', depends + " emgd-driver-bin") | ||
24 | } | ||