summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb6
-rw-r--r--meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb3
2 files changed, 7 insertions, 2 deletions
diff --git a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
index d0e14a56..5153054c 100644
--- a/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
+++ b/meta-emenlow/recipes-graphics/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Userspace interface to kernel DRM services" 1DESCRIPTION = "Userspace interface to kernel DRM services"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7" 3LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
4PR = "r4" 4PR = "r5"
5 5
6PROVIDES = "libdrm-poulsbo" 6PROVIDES = "libdrm-poulsbo"
7 7
@@ -17,3 +17,7 @@ do_configure_prepend() {
17 sed -e 's/-ldrm/-ldrm_poulsbo/' -e 's/libdrm/libdrm_poulsbo/' \ 17 sed -e 's/-ldrm/-ldrm_poulsbo/' -e 's/libdrm/libdrm_poulsbo/' \
18 < ${S}/libdrm.pc.in > ${S}/libdrm_poulsbo.pc.in 18 < ${S}/libdrm.pc.in > ${S}/libdrm_poulsbo.pc.in
19} 19}
20
21do_install_append() {
22 ln -s libdrm_poulsbo.so.2.3.0 ${D}${libdir}/libdrm.so.2
23}
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
index f4b43ab0..0d675c6d 100644
--- a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
+++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration"
4# not Intel proprietary, but it has no obvious license attached to it. 4# not Intel proprietary, but it has no obvious license attached to it.
5LICENSE = "Intel-binary-only" 5LICENSE = "Intel-binary-only"
6LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8" 6LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8"
7PR = "r6" 7PR = "r7"
8 8
9inherit autotools 9inherit autotools
10 10
@@ -29,6 +29,7 @@ do_install() {
29 ${D}/${libdir}/xorg/modules/dri 29 ${D}/${libdir}/xorg/modules/dri
30 install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \ 30 install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \
31 ${D}/${libdir}/xorg/modules/drivers 31 ${D}/${libdir}/xorg/modules/drivers
32 ln -s ${libdir}/xorg/modules/dri ${D}${libdir}/dri
32} 33}
33 34
34S = "${WORKDIR}/${PN}-${PV}/mesa" 35S = "${WORKDIR}/${PN}-${PV}/mesa"