summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-support
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/sbsigntool/sbsigntool-native_git.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes-support/sbsigntool/sbsigntool-native_git.bb b/recipes-support/sbsigntool/sbsigntool-native_git.bb
new file mode 100644
index 00000000..430a6a78
--- /dev/null
+++ b/recipes-support/sbsigntool/sbsigntool-native_git.bb
@@ -0,0 +1,77 @@
1DESCRIPTION = "Utility for signing and verifying files for UEFI Secure Boot"
2LICENSE = "GPLv3 & LGPL-2.1 & LGPL-3.0 & MIT"
3
4# sbsigntool statically links to libccan.a which is built with modules
5# passed to "create-ccan-tree" (and their dependencies). Therefore,
6# we also keep track of all the ccan module licenses.
7LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=9eef91148a9b14ec7f9df333daebc746 \
8 file://COPYING;md5=a7710ac18adec371b84a9594ed04fd20 \
9 file://lib/ccan.git/ccan/endian/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
10 file://lib/ccan.git/ccan/htable/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
11 file://lib/ccan.git/ccan/list/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
12 file://lib/ccan.git/ccan/read_write_all/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
13 file://lib/ccan.git/ccan/talloc/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
14 file://lib/ccan.git/ccan/typesafe_cb/LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
15 file://lib/ccan.git/ccan/failtest/LICENSE;md5=6a6a8e020838b23406c81b19c1d46df6 \
16 file://lib/ccan.git/ccan/tlist/LICENSE;md5=6a6a8e020838b23406c81b19c1d46df6 \
17 file://lib/ccan.git/ccan/time/LICENSE;md5=838c366f69b72c5df05c96dff79b35f2 \
18"
19
20# The original upstream is git://kernel.ubuntu.com/jk/sbsigntool but it has
21# not been maintained and many patches have been backported in this repo.
22SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntools \
23 git://github.com/rustyrussell/ccan.git;protocol=https;destsuffix=git/lib/ccan.git;name=ccan \
24 "
25
26SRCREV_sbsigntools ?= "efbb550858e7bd3f43e64228d22aea440ef6a14d"
27SRCREV_ccan ?= "b1f28e17227f2320d07fe052a8a48942fe17caa5"
28SRCREV_FORMAT = "sbsigntools_ccan"
29
30DEPENDS = "binutils-native gnu-efi-native help2man-native openssl10-native util-linux-native"
31
32PV = "0.8-git${SRCPV}"
33
34S = "${WORKDIR}/git"
35
36inherit native autotools pkgconfig
37
38do_configure_prepend() {
39 cd ${S}
40
41 if [ ! -e lib/ccan ]; then
42
43 # Use empty SCOREDIR because 'make scores' is not run.
44 # The default setting depends on (non-whitelisted) host tools.
45 sed -i -e 's#^\(SCOREDIR=\).*#\1#' lib/ccan.git/Makefile
46
47 lib/ccan.git/tools/create-ccan-tree \
48 --build-type=automake lib/ccan \
49 talloc read_write_all build_assert array_size endian
50 fi
51
52 # Create generatable docs from git
53 (
54 echo "Authors of sbsigntool:"
55 echo
56 git log --format='%an' | sort -u | sed 's,^,\t,'
57 ) > AUTHORS
58
59 # Generate simple ChangeLog
60 git log --date=short --format='%ad %t %an <%ae>%n%n * %s%n' > ChangeLog
61
62 cd ${B}
63}
64
65def efi_arch(d):
66 import re
67 harch = d.getVar("HOST_ARCH")
68 if re.match("i[3456789]86", harch):
69 return "ia32"
70 return harch
71
72EXTRA_OEMAKE = "\
73 INCLUDES+='-I${S}/lib/ccan.git/ \
74 -I${STAGING_INCDIR_NATIVE}/efi \
75 -I${STAGING_INCDIR_NATIVE} \
76 -I${STAGING_INCDIR_NATIVE}/efi/${@efi_arch(d)}' \
77 "