summaryrefslogtreecommitdiffstats
path: root/recipes-rt/images/core-image-rt.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-rt/images/core-image-rt.bb
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-rt/images/core-image-rt.bb')
-rw-r--r--recipes-rt/images/core-image-rt.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-rt/images/core-image-rt.bb b/recipes-rt/images/core-image-rt.bb
new file mode 100644
index 00000000..4db0a579
--- /dev/null
+++ b/recipes-rt/images/core-image-rt.bb
@@ -0,0 +1,17 @@
1require recipes-core/images/core-image-minimal.bb
2
3# Skip processing of this recipe if linux-intel-rt is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers.
6python () {
7 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
8 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
9}
10
11DESCRIPTION = "A small image just capable of allowing a device to boot plus a \
12real-time test suite and tools appropriate for real-time use."
13DEPENDS = "linux-intel-rt"
14
15IMAGE_INSTALL += "rt-tests hwlatdetect"
16
17LICENSE = "MIT"