summaryrefslogtreecommitdiffstats
path: root/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-07-31 18:29:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-07-31 21:03:31 +0800
commit03f21762497caa871c949c4eff9f6c980fec3342 (patch)
treed8328473ff3ffda6e53bc6ea9554b0631e198b83 /recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
parente3d7b3aba6f65d7c4423fb77c34998cfd7e6ec3b (diff)
downloadmeta-intel-03f21762497caa871c949c4eff9f6c980fec3342.tar.gz
intel-graphics-compiler: build only when clang layer is included
igc needs components from LLVM and clang to be built. Move it to dynamic-layers/clang-layer so world builds don't fail when clang layer is not available. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb')
-rw-r--r--recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb27
1 files changed, 0 insertions, 27 deletions
diff --git a/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb b/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
deleted file mode 100644
index f64b97fd..00000000
--- a/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;md5=4e9a7f0d710a0546cbf5581e1565a986"
9
10SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \
11 file://0001-skip-execution-of-ElfPackager.patch \
12 file://0001-Fix-for-the-gcc-9-issue.patch \
13 "
14
15SRCREV = "ebfc688126900a821e407a96417800919b793447"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null"
23
24DEPENDS_class-target = " flex-native bison-native clang clang-cross-x86_64"
25
26EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=8.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2"
27EXTRA_OECMAKE += "-DCOMMON_CLANG_LIBRARY_NAME=common_clang"