diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2023-05-29 11:28:41 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2023-05-29 15:20:35 +0800 |
commit | 068182dbcf748cf6fc88bd89eafb1167aeb9fb8c (patch) | |
tree | 4dc9747830af15b610c0256fd06228e1948c58e7 /recipes-multimedia | |
parent | 5b78a9af8fe18f61d4fc9684bb967f097d132e5a (diff) | |
download | meta-intel-068182dbcf748cf6fc88bd89eafb1167aeb9fb8c.tar.gz |
intel-mediasdk: fix build with gcc13
Fixes:
11:08:59 | /build/poky/build/tmp/work/corei7-64-poky-linux/intel-mediasdk/23.2.1-r0/git/api/mfx_dispatch/linux/mfxparser.cpp:60:36: error: 'uint8_t' does not name a type
11:08:59 | 60 | uint8_t* data = reinterpret_cast<uint8_t*>(&id);
11:08:59 | | ^~~~~~~
11:08:59 | /build/poky/build/tmp/work/corei7-64-poky-linux/intel-mediasdk/23.2.1-r0/git/api/mfx_dispatch/linux/mfxparser.cpp:60:36: note: 'uint8_t' is defined in header '<cstdint>'; did you forget to '#include <cstdint>'?
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/mediasdk/files/fix-gcc13.patch | 15 | ||||
-rw-r--r-- | recipes-multimedia/mediasdk/intel-mediasdk_23.2.1.bb | 1 |
2 files changed, 16 insertions, 0 deletions
diff --git a/recipes-multimedia/mediasdk/files/fix-gcc13.patch b/recipes-multimedia/mediasdk/files/fix-gcc13.patch new file mode 100644 index 00000000..fb973870 --- /dev/null +++ b/recipes-multimedia/mediasdk/files/fix-gcc13.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Upstream-Status: Inactive-Upstream | ||
2 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | |||
4 | diff --git a/api/mfx_dispatch/linux/mfxparser.cpp b/api/mfx_dispatch/linux/mfxparser.cpp | ||
5 | index 9d3823ec3e..12e46d1881 100644 | ||
6 | --- a/api/mfx_dispatch/linux/mfxparser.cpp | ||
7 | +++ b/api/mfx_dispatch/linux/mfxparser.cpp | ||
8 | @@ -20,6 +20,7 @@ | ||
9 | |||
10 | #include <ctype.h> | ||
11 | #include <stdio.h> | ||
12 | +#include <stdint.h> | ||
13 | #include <stdlib.h> | ||
14 | #include <string.h> | ||
15 | |||
diff --git a/recipes-multimedia/mediasdk/intel-mediasdk_23.2.1.bb b/recipes-multimedia/mediasdk/intel-mediasdk_23.2.1.bb index 4bca7193..302229a2 100644 --- a/recipes-multimedia/mediasdk/intel-mediasdk_23.2.1.bb +++ b/recipes-multimedia/mediasdk/intel-mediasdk_23.2.1.bb | |||
@@ -35,6 +35,7 @@ PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND=ON, -DENABLE_WAYLAND=OFF, wayland way | |||
35 | 35 | ||
36 | SRC_URI = "git://github.com/Intel-Media-SDK/MediaSDK.git;protocol=https;nobranch=1;lfs=0 \ | 36 | SRC_URI = "git://github.com/Intel-Media-SDK/MediaSDK.git;protocol=https;nobranch=1;lfs=0 \ |
37 | file://0001-FindITT.cmake-fix-detection-of-header-library.patch \ | 37 | file://0001-FindITT.cmake-fix-detection-of-header-library.patch \ |
38 | file://fix-gcc13.patch \ | ||
38 | " | 39 | " |
39 | 40 | ||
40 | SRCREV = "e507e23470f1fc0f01395c10c97bd7b31acf0bce" | 41 | SRCREV = "e507e23470f1fc0f01395c10c97bd7b31acf0bce" |