summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/libva
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-04-24 13:38:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-27 16:26:48 +0800
commit61fc299113e561ac345ae56c1ea6c9f9a874dd13 (patch)
tree12af5f59ca5c5699679c84655ab2237a2f4a4cdb /recipes-multimedia/libva
parent3f99053c646f02ccd9a005f489bde89c41b88b95 (diff)
downloadmeta-intel-61fc299113e561ac345ae56c1ea6c9f9a874dd13.tar.gz
libva-intel: keep compatible with zeus
To avoid recipe version confilicts with oe-core recipes from dunfell and zeus, better to carry full recipe instead of require libva recipe. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia/libva')
-rw-r--r--recipes-multimedia/libva/libva-intel_2.7.0.bb42
1 files changed, 39 insertions, 3 deletions
diff --git a/recipes-multimedia/libva/libva-intel_2.7.0.bb b/recipes-multimedia/libva/libva-intel_2.7.0.bb
index 3c71e1ac..cb7d2666 100644
--- a/recipes-multimedia/libva/libva-intel_2.7.0.bb
+++ b/recipes-multimedia/libva/libva-intel_2.7.0.bb
@@ -1,15 +1,51 @@
1# Latest upgrades for media components depend upon libva v2.7.0 1# Latest upgrades for media components depend upon libva v2.7.0
2# So need this upgrade 2# So need this upgrade
3 3
4require recipes-graphics/libva/libva_2.6.1.bb 4SUMMARY = "Video Acceleration (VA) API for Linux"
5DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
6and API specification which enables and provides access to graphics \
7hardware (GPU) acceleration for video processing on Linux and UNIX \
8based operating systems. Accelerated processing includes video \
9decoding, video encoding, subpicture blending and rendering. The \
10specification was originally designed by Intel for its GMA (Graphics \
11Media Accelerator) series of GPU hardware, the API is however not \
12limited to GPUs or Intel specific hardware, as other hardware and \
13manufacturers can also freely use this API for hardware accelerated \
14video decoding."
5 15
6SRC_URI_remove = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2" 16HOMEPAGE = "https://01.org/linuxmedia/vaapi"
7SRC_URI_prepend = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2 " 17BUGTRACKER = "https://github.com/intel/libva/issues"
8 18
19SECTION = "x11"
20LICENSE = "MIT"
21LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
22
23SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2"
9SRC_URI[md5sum] = "bd5052569520e734eb8aeb0f503cfcae" 24SRC_URI[md5sum] = "bd5052569520e734eb8aeb0f503cfcae"
10SRC_URI[sha256sum] = "b75be416615dea75c74314fae8919dd72ca46d06b4e009e029661c2c51d87d70" 25SRC_URI[sha256sum] = "b75be416615dea75c74314fae8919dd72ca46d06b4e009e029661c2c51d87d70"
11 26
12S = "${WORKDIR}/libva-${PV}" 27S = "${WORKDIR}/libva-${PV}"
13 28
29UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
30
31DEPENDS = "libdrm virtual/mesa"
32
33inherit meson pkgconfig ${COMPAT_DISTRO_FEATURE_CHECK}
34
35REQUIRED_DISTRO_FEATURES = "opengl"
36
37PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
38PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes"
39PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland"
40
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42
43RDEPENDS_${PN}-x11 =+ "${PN}"
44RDEPENDS_${PN}-glx =+ "${PN}-x11"
45
46FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49
14PROVIDES = "libva" 50PROVIDES = "libva"
15RPROVIDES_${PN} += "libva" 51RPROVIDES_${PN} += "libva"