summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/itt
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-05-15 16:02:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-05-17 11:20:01 +0800
commite160f52a45935463d5138b9fa6cd52fb6de17e19 (patch)
treebb44f22119337bb430b0a17d9c86912bc092d0f0 /recipes-multimedia/itt
parentb92f5cbfe6d0e1b2bd02975d5d23ea0ead6fc684 (diff)
downloadmeta-intel-e160f52a45935463d5138b9fa6cd52fb6de17e19.tar.gz
itt: add recipe
Introduce Intel® Single Event API (Intel® SEAPI), which is the translator of itt_notify calls into several OS specific and third party tracing formats. It can be use as memory/performance/ whatever profile. Wiki: https://github.com/intel/IntelSEAPI/wiki Signed-off-by: Lim, Raynald <raynald.lim@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-multimedia/itt')
-rw-r--r--recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch33
-rw-r--r--recipes-multimedia/itt/itt_17.0.bb30
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch b/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch
new file mode 100644
index 00000000..6009669a
--- /dev/null
+++ b/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch
@@ -0,0 +1,33 @@
1From 6bced614fe448ee7fc6216b528e2c5684446f9c6 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 14 May 2019 16:57:27 +0800
4Subject: [PATCH] CMakeLists.txt: set output directory path
5
6Installer section of CMakeLists.txt expect bin
7direcotry should be present at PROJECT_SOURCE_DIR
8
9set(SEA_PROJECT_BIN ${PROJECT_SOURCE_DIR}/bin)
10
11Upstream-Status: Inappropriate
12
13Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
14---
15 CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 479c443..01f0124 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -65,7 +65,7 @@ foreach (Flag ${Flags})
23 message(STATUS "${Flag} = ${${Flag}}")
24 endforeach()
25
26-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/../../bin)
27+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_SOURCE_DIR}/bin)
28
29 set(EXECUTABLE_OUTPUT_PATH ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
30 set(LIBRARY_OUTPUT_PATH ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
31--
322.17.0
33
diff --git a/recipes-multimedia/itt/itt_17.0.bb b/recipes-multimedia/itt/itt_17.0.bb
new file mode 100644
index 00000000..a40a2e9b
--- /dev/null
+++ b/recipes-multimedia/itt/itt_17.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Intel® Single Event API"
2DESCRIPTION = "Intel® SEAPI is the translator of itt_notify calls into \
3several OS specific and third party tracing formats. \
4You can use it as memory/performance/whatever profiler."
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://sea_itt_lib/Copyright.txt;md5=7d54dfc8860742fb06b9c5ad28f41fcd"
8
9SRC_URI = "\
10 git://github.com/intel/IntelSEAPI.git;protocol=https \
11 file://0001-CMakeLists.txt-set-output-directory-path.patch \
12"
13SRCREV="36bff07521afffc0c0f7db79252338954ca7e6dd"
14S = "${WORKDIR}/git"
15
16inherit pkgconfig cmake
17
18EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=Release"
19EXTRA_OECMAKE += "-DDCO_PILOT=0"
20EXTRA_OECMAKE += "${@oe.utils.conditional('TARGET_ARCH','x86_64','','-DFORCE_32=ON',d)}"
21
22COMPATIBLE_HOST_libc-musl_class-target = "null"
23
24do_install() {
25 install -d -m 755 ${D}${libdir} ${D}${includedir}
26 install -m 644 ${S}/bin/*.a ${D}${libdir}
27 install -m 644 ${S}/ittnotify/include/ittnotify.h ${D}${includedir}
28}
29
30RDEPENDS_${PN}-dev_remove = "${PN} (= ${EXTENDPKGV})"