summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-11-22 15:36:16 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-24 22:34:33 +0800
commitf2cf31678cd60d9a203c20d6205021eefca5bbae (patch)
tree55722a9a4ffac2228e6dc9b3917fb8ca4b2c1181 /recipes-kernel
parentcb85d1a565c69f847de84c67a94ac2c7e860a40d (diff)
downloadmeta-intel-f2cf31678cd60d9a203c20d6205021eefca5bbae.tar.gz
linux-intel/5.15: add recipe
Add recipe to build LTS 5.15 kernel along with kernel configs from yocto-5.15 branch. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-intel_5.15.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel_5.15.bb b/recipes-kernel/linux/linux-intel_5.15.bb
new file mode 100644
index 00000000..be44c39a
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel_5.15.bb
@@ -0,0 +1,32 @@
1require linux-intel.inc
2
3KBRANCH = "5.15/linux"
4KMETA_BRANCH = "yocto-5.15"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7
8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 "
10
11DEPENDS += "elfutils-native openssl-native util-linux-native"
12
13LINUX_VERSION ?= "5.15.1"
14SRCREV_machine ?= "d7d7ea689cc887081dd8bf8ef2f296b5cd9c593e"
15SRCREV_meta ?= "bee5d6a15909f05935f4a61f83a72cddfca7934a"
16
17# For Crystalforest and Romley
18KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
19KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
20
21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
23
24# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
25# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
26# In which 'CONFIG_DRM_GMA3600' config option is dropped.
27# This causes warning during config audit. So suppress the harmless warning for now.
28KCONF_BSP_AUDIT_LEVEL = "0"
29
30# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
31# causes config warning too.
32KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"