summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-11-29 20:00:35 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-30 14:54:15 +0800
commit901f8f964bb42a6eb4f47fef6a6c0b1809a66e68 (patch)
tree4e5049ccf398a8ed040a4d9245869b0a9ea65344 /recipes-kernel
parentfe4d7319ff516856f39ffb31332ae7a707935b9a (diff)
downloadmeta-intel-901f8f964bb42a6eb4f47fef6a6c0b1809a66e68.tar.gz
linux-intel-rt/5.15: add recipe
Based on v5.15.2-rt19. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.15.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.15.bb b/recipes-kernel/linux/linux-intel-rt_5.15.bb
new file mode 100644
index 00000000..bc11cb63
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.15.bb
@@ -0,0 +1,29 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14 "
15
16KBRANCH = "5.15/preempt-rt"
17KMETA_BRANCH = "yocto-5.15"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.15.2"
22SRCREV_machine ?= "f09e0e5e5d73c753dbdf2e9f0ac2d533a51e8dd8"
23SRCREV_meta ?= "bee5d6a15909f05935f4a61f83a72cddfca7934a"
24
25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
28# causes config warning too.
29KCONF_AUDIT_LEVEL:core2-32-intel-common = "0"