summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-04 15:58:26 -0700
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-06 13:23:47 -0700
commit57bcd9c5957fa5572fc3b49db8a427143c17129b (patch)
tree8542a5979a7a617d24395d112fe769531fb8dffe /recipes-kernel
parent9e417c71d0236ec4484712d8f090757aef562e6a (diff)
downloadmeta-intel-57bcd9c5957fa5572fc3b49db8a427143c17129b.tar.gz
linux-yocto/4.12: use meta-intel-compat-kernel.inc instead
This sets all the necessary variables. The -rt kernel gains some AUTOLOAD settings, which is fine and should have been the case in the first place. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-yocto-rt_4.12.bbappend10
-rw-r--r--recipes-kernel/linux/linux-yocto_4.12.bbappend18
2 files changed, 2 insertions, 26 deletions
diff --git a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
index de336b04..daa7dd6b 100644
--- a/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto-rt_4.12.bbappend
@@ -1,9 +1 @@
1KERNEL_FEATURES_INTEL_COMMON ?= "" require meta-intel-compat-kernel.inc
2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend
index b99001ed..daa7dd6b 100644
--- a/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -1,17 +1 @@
1KERNEL_FEATURES_INTEL_COMMON ?= "" require meta-intel-compat-kernel.inc
2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11# For Crystalforest and Romley
12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
13KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
14
15# For FRI2, NUC
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"