summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-04-26 16:40:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-28 12:07:58 +0800
commit4d5791d9ff515ba1660234b1987eae4d4e90eeca (patch)
tree2b19da0cf9109d787c35ba56040a3b720468a766 /recipes-kernel
parent610cdb495cdc7eda95bfa03824220272ca256e7f (diff)
downloadmeta-intel-4d5791d9ff515ba1660234b1987eae4d4e90eeca.tar.gz
linux-intel/5.10: disable kernel config bsp audit for now15.0-hardknott-3.3
Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel[1] Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb In which 'CONFIG_DRM_GMA3600' config option is dropped. This causing warning during config audit. So suppress the harmless warning for now. WARNING: do_kernel_configcheck: [kernel config]: This BSP contains fragments with warnings: [INFO]: the following symbols were not found in the active configuration: - CONFIG_DRM_GMA3600 Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which causing config warning too: WARNING: do_configcheck: [kernel config]: specified values did not make it into the kernel's final configuration: [NOTE]: 'CONFIG_SND_SOC_INTEL_SST' last val (m) and .config val (n) do not match [INFO]: CONFIG_SND_SOC_INTEL_SST : n [INFO]: raw config text: config SND_SOC_INTEL_SST tristate depends on SND_SOC_INTEL_SST_TOPLEVEL && SND_SOC && SND && !UML && SOUND Config 'SND_SOC_INTEL_SST' has the following Direct dependencies (SND_SOC_INTEL_SST=m): SND_SOC_INTEL_SST_TOPLEVEL(=y) && SND_SOC(=m) && SND(=y) && !UML(undefined/n) (=y) && SOUND(=y) Parent dependencies are: SND_SOC [m] SND_SOC_INTEL_SST_TOPLEVEL [y] SND [y] UML [UML] SOUND [y] [INFO]: config 'CONFIG_SND_SOC_INTEL_SST' was set, but it wasn't assignable, check (parent) dependencies [INFO]: selection details for 'CONFIG_SND_SOC_INTEL_SST': Symbols currently n-selecting this symbol (no effect): - SND_SOC_INTEL_SKYLAKE_COMMON [1] https://github.com/intel/linux-intel-lts/commit/ab7a5829db53036342a00adb46c6ded27f9a33da Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb10
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb10
2 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
index 7d67fb0a..16e8149e 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -23,3 +23,13 @@ SRCREV_machine ?= "774cd893ee3f4044305e0a7bf5090e32b72578b3"
23SRCREV_meta ?= "eb09284047fec2f09d62068c338ae320c6681bd1" 23SRCREV_meta ?= "eb09284047fec2f09d62068c338ae320c6681bd1"
24 24
25LINUX_KERNEL_TYPE = "preempt-rt" 25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
28# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
29# In which 'CONFIG_DRM_GMA3600' config option is dropped.
30# This causes warning during config audit. So suppress the harmless warning for now.
31KCONF_BSP_AUDIT_LEVEL = "0"
32
33# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
34# causes config warning too.
35KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
index 399ab014..4e33b45e 100644
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -20,3 +20,13 @@ KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
20 20
21# Functionality flags 21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
23
24# Following commit is backported from mainline 5.12-rc to linux-intel 5.10 kernel
25# Commit: https://github.com/torvalds/linux/commit/26499e0518a77de29e7db2c53fb0d0e9e15be8fb
26# In which 'CONFIG_DRM_GMA3600' config option is dropped.
27# This causes warning during config audit. So suppress the harmless warning for now.
28KCONF_BSP_AUDIT_LEVEL = "0"
29
30# Disabling CONFIG_SND_SOC_INTEL_SKYLAKE for 32-bit, does not allow to set CONFIG_SND_SOC_INTEL_SST too, which
31# causes config warning too.
32KCONF_AUDIT_LEVEL_core2-32-intel-common = "0"