diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2019-01-25 12:50:01 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2019-03-07 09:47:24 +0800 |
commit | b6fd099d2a1fd5b0587d727d7f6916432072536e (patch) | |
tree | 9d4bb41b5988ad4fef60a59a966edabb9334a71f /recipes-kernel | |
parent | b5a428bc6be7e1c02ca7d0714e0a5d25f31b4a5f (diff) | |
download | meta-intel-b6fd099d2a1fd5b0587d727d7f6916432072536e.tar.gz |
linux-intel: remove 4.9 kernel and related bbapends
Remove support for building with 4.9 kernel in this release. Also remove
related bbapends with patches to fix builds for 4.9.
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
8 files changed, 0 insertions, 211 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch b/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch deleted file mode 100644 index 353126fe..00000000 --- a/recipes-kernel/cryptodev/cryptodev-module/0001-zc-Force-4.10-get_user_pages_remote-API.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 3fcc81ad127c267018aed96a359bbf01db1bd8ee Mon Sep 17 00:00:00 2001 | ||
2 | From: Saul Wold <sgw@linux.intel.com> | ||
3 | Date: Sat, 1 Apr 2017 11:43:31 -0700 | ||
4 | Subject: [PATCH] zc: Force 4.10 get_user_pages_remote API | ||
5 | |||
6 | This change forces the newer API, as the linux-intel 4.9-LTS kernel | ||
7 | backported the 4.10 API change in the page handling code. | ||
8 | |||
9 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
10 | --- | ||
11 | zc.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/zc.c b/zc.c | ||
15 | index ae464ff..b2759ce 100644 | ||
16 | --- a/zc.c | ||
17 | +++ b/zc.c | ||
18 | @@ -65,7 +65,7 @@ int __get_userbuf(uint8_t __user *addr, uint32_t len, int write, | ||
19 | #elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 9, 0)) | ||
20 | ret = get_user_pages_remote(task, mm, | ||
21 | (unsigned long)addr, pgcount, write, 0, pg, NULL); | ||
22 | -#elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)) | ||
23 | +#elif (LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0) & 0) | ||
24 | ret = get_user_pages_remote(task, mm, | ||
25 | (unsigned long)addr, pgcount, write ? FOLL_WRITE : 0, | ||
26 | pg, NULL); | ||
diff --git a/recipes-kernel/cryptodev/cryptodev-module_%.bbappend b/recipes-kernel/cryptodev/cryptodev-module_%.bbappend deleted file mode 100644 index c59ddb2f..00000000 --- a/recipes-kernel/cryptodev/cryptodev-module_%.bbappend +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | python() { | ||
4 | # When we add more kernels for linux-intel, we may have to add a Version check | ||
5 | if (d.getVar("PREFERRED_PROVIDER_virtual/kernel") == "linux-intel"): | ||
6 | src_uri = d.getVar("SRC_URI") | ||
7 | d.setVar("SRC_URI", src_uri + | ||
8 | " file://0001-zc-Force-4.10-get_user_pages_remote-API.patch") | ||
9 | } | ||
diff --git a/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch b/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch deleted file mode 100644 index 4fdc36f7..00000000 --- a/recipes-kernel/iwlwifi/backport-iwlwifi/0001-hrtimer-fix-version-numbers-because-production-kerne.patch +++ /dev/null | |||
@@ -1,87 +0,0 @@ | |||
1 | From ecb29b78ce946c802058be0c46a0d20432f412e5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Saul Wold <sgw@linux.intel.com> | ||
3 | Date: Thu, 28 Sep 2017 10:51:15 -0700 | ||
4 | Subject: [PATCH] hrtimer: fix version numbers because production kernel has | ||
5 | update | ||
6 | |||
7 | Decrease the version check because the OTC production kernel which is | ||
8 | 4.9 includes the HRTimer code that this is using. | ||
9 | |||
10 | Upstream-Status: [Backport] It's been backported into the older kernel | ||
11 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
12 | --- | ||
13 | backport-include/linux/hrtimer.h | 2 +- | ||
14 | drivers/net/wireless/intel/iwlwifi/mvm/tx.c | 2 +- | ||
15 | drivers/net/wireless/intel/iwlwifi/pcie/tx.c | 2 +- | ||
16 | drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c | 2 +- | ||
17 | net/mac80211/tx.c | 2 +- | ||
18 | 5 files changed, 5 insertions(+), 5 deletions(-) | ||
19 | |||
20 | diff --git a/backport-include/linux/hrtimer.h b/backport-include/linux/hrtimer.h | ||
21 | index bdcf106e1..ae128852d 100644 | ||
22 | --- a/backport-include/linux/hrtimer.h | ||
23 | +++ b/backport-include/linux/hrtimer.h | ||
24 | @@ -4,7 +4,7 @@ | ||
25 | #include_next <linux/hrtimer.h> | ||
26 | #include <linux/interrupt.h> | ||
27 | |||
28 | -#if LINUX_VERSION_IS_LESS(4,10,0) | ||
29 | +#if LINUX_VERSION_IS_LESS(4,9,0) | ||
30 | static inline void backport_hrtimer_start(struct hrtimer *timer, s64 time, | ||
31 | const enum hrtimer_mode mode) | ||
32 | { | ||
33 | diff --git a/drivers/net/wireless/intel/iwlwifi/mvm/tx.c b/drivers/net/wireless/intel/iwlwifi/mvm/tx.c | ||
34 | index cf1f95a01..e6f1ff294 100644 | ||
35 | --- a/drivers/net/wireless/intel/iwlwifi/mvm/tx.c | ||
36 | +++ b/drivers/net/wireless/intel/iwlwifi/mvm/tx.c | ||
37 | @@ -1310,7 +1310,7 @@ static void iwl_mvm_tx_lat_add_ts_ack(struct sk_buff *skb) | ||
38 | s64 ts_1 = ktime_to_ns(skb->tstamp) >> 32; | ||
39 | s64 diff = temp - ts_1; | ||
40 | |||
41 | -#if LINUX_VERSION_IS_LESS(4,10,0) | ||
42 | +#if LINUX_VERSION_IS_LESS(4,9,0) | ||
43 | skb->tstamp.tv64 += diff; | ||
44 | #else | ||
45 | skb->tstamp += diff; | ||
46 | diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/tx.c b/drivers/net/wireless/intel/iwlwifi/pcie/tx.c | ||
47 | index df81bce25..ad664bacd 100644 | ||
48 | --- a/drivers/net/wireless/intel/iwlwifi/pcie/tx.c | ||
49 | +++ b/drivers/net/wireless/intel/iwlwifi/pcie/tx.c | ||
50 | @@ -1955,7 +1955,7 @@ static void iwl_trans_pci_tx_lat_add_ts_write(struct sk_buff *skb) | ||
51 | s64 ts_1 = ktime_to_ns(skb->tstamp) >> 32; | ||
52 | s64 diff = temp - ts_1; | ||
53 | |||
54 | -#if LINUX_VERSION_IS_LESS(4,10,0) | ||
55 | +#if LINUX_VERSION_IS_LESS(4,9,0) | ||
56 | skb->tstamp.tv64 += diff << 16; | ||
57 | #else | ||
58 | skb->tstamp += diff << 16; | ||
59 | diff --git a/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c b/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c | ||
60 | index e4d45bcf7..cdd0ba9a2 100644 | ||
61 | --- a/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c | ||
62 | +++ b/drivers/net/wireless/intel/iwlwifi/trans_slave/shared.c | ||
63 | @@ -796,7 +796,7 @@ void iwl_slv_tx_lat_add_ts_write(struct iwl_trans_slv *trans_slv, | ||
64 | |||
65 | ts_1 = ktime_to_ns(data_entry->skb->tstamp) >> 32; | ||
66 | diff = temp - ts_1; | ||
67 | -#if LINUX_VERSION_IS_LESS(4,10,0) | ||
68 | +#if LINUX_VERSION_IS_LESS(4,9,0) | ||
69 | data_entry->skb->tstamp.tv64 += diff << 16; | ||
70 | #else | ||
71 | data_entry->skb->tstamp += diff << 16; | ||
72 | diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c | ||
73 | index 94a348688..0f226c413 100644 | ||
74 | --- a/net/mac80211/tx.c | ||
75 | +++ b/net/mac80211/tx.c | ||
76 | @@ -2278,7 +2278,7 @@ static void ieee80211_tx_latency_start_msrmnt(struct ieee80211_local *local, | ||
77 | if (!tx_latency && !tx_consec && !tx_thrshld) | ||
78 | return; | ||
79 | temp = ktime_to_ms(ktime_get()); | ||
80 | -#if LINUX_VERSION_IS_LESS(4,10,0) | ||
81 | +#if LINUX_VERSION_IS_LESS(4,9,0) | ||
82 | skb->tstamp.tv64 += temp << 32; | ||
83 | #else | ||
84 | skb->tstamp += temp << 32; | ||
85 | -- | ||
86 | 2.13.5 | ||
87 | |||
diff --git a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb index 1453f519..71837318 100644 --- a/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb +++ b/recipes-kernel/iwlwifi/backport-iwlwifi_git.bb | |||
@@ -20,13 +20,9 @@ inherit module | |||
20 | PV = "30" | 20 | PV = "30" |
21 | SRCREV = "b31221a99488021300e7f89d2ecf9bdd2bc52dd2" | 21 | SRCREV = "b31221a99488021300e7f89d2ecf9bdd2bc52dd2" |
22 | 22 | ||
23 | # Add a patch for Intel's Production Kernel as it's got a backport of HRTimers | ||
24 | PK_PATCH = "${@bb.utils.contains('PREFERRED_PROVIDER_virtual/kernel','linux-intel','file://0001-hrtimer-fix-version-numbers-because-production-kerne.patch','',d)}" | ||
25 | |||
26 | SRC_URI = " \ | 23 | SRC_URI = " \ |
27 | git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi;branch=release/LinuxCore${PV} \ | 24 | git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi;branch=release/LinuxCore${PV} \ |
28 | file://0001-Makefile.real-skip-host-install-scripts.patch \ | 25 | file://0001-Makefile.real-skip-host-install-scripts.patch \ |
29 | ${PK_PATCH} \ | ||
30 | file://iwlwifi.conf \ | 26 | file://iwlwifi.conf \ |
31 | " | 27 | " |
32 | 28 | ||
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb deleted file mode 100644 index 0b81987a..00000000 --- a/recipes-kernel/linux/linux-intel-rt_4.9.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | |||
2 | require linux-intel.inc | ||
3 | |||
4 | # Skip processing of this recipe if it is not explicitly specified as the | ||
5 | # PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying | ||
6 | # to build multiple virtual/kernel providers, e.g. as dependency of | ||
7 | # core-image-rt-sdk, core-image-rt. | ||
8 | python () { | ||
9 | if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt": | ||
10 | raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") | ||
11 | } | ||
12 | |||
13 | KBRANCH = "4.9/yocto/base-rt" | ||
14 | KMETA_BRANCH = "yocto-4.9" | ||
15 | |||
16 | LINUX_VERSION ?= "4.9.84" | ||
17 | SRCREV_machine ?= "33b17c3a62dc470c849f85ce2a90cfa90e96bcf5" | ||
18 | SRCREV_meta ?= "bae5cc4e973f60baa35ed227ba0c3bdda4d16e87" | ||
19 | |||
20 | LINUX_KERNEL_TYPE = "preempt-rt" | ||
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb deleted file mode 100644 index 687c6be8..00000000 --- a/recipes-kernel/linux/linux-intel_4.9.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | |||
2 | require linux-intel.inc | ||
3 | |||
4 | KBRANCH = "4.9/yocto/base" | ||
5 | KMETA_BRANCH = "yocto-4.9" | ||
6 | |||
7 | SRC_URI_append = " \ | ||
8 | file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \ | ||
9 | " | ||
10 | |||
11 | LINUX_VERSION ?= "4.9.146" | ||
12 | SRCREV_machine ?= "0411ffc9047ee2b127991663660d2514ba451ef3" | ||
13 | SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422" | ||
14 | |||
15 | # For Crystalforest and Romley | ||
16 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
17 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
18 | |||
19 | # Functionality flags | ||
20 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" | ||
diff --git a/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch b/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch deleted file mode 100644 index 32b49b8d..00000000 --- a/recipes-kernel/lttng/lttng-modules/0002-lttng-modules-PKT-4.9-yocto-build-failed.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From ebfdc8b8af17f9cf23c6878eb52476fde7b48e5c Mon Sep 17 00:00:00 2001 | ||
2 | From: Priyalee Kushwaha <priyalee.kushwaha@intel.com> | ||
3 | Date: Fri, 22 Sep 2017 14:40:57 -0700 | ||
4 | Subject: [PATCH] lttng-modules: PKT 4.9 yocto build failed | ||
5 | |||
6 | PKT 4.9 yocto kernel backports a patch from upstream and that | ||
7 | changes header include/linux/ktimer.h. Since this backported | ||
8 | patch is only relevant for PKT kernel, we need to carry this | ||
9 | patch. | ||
10 | |||
11 | Upstream-Status: Backport | ||
12 | Signed-off-by: Kushwaha, Priyalee <priyalee.kushwaha@intel.com> | ||
13 | --- | ||
14 | instrumentation/events/lttng-module/timer.h | 6 +++--- | ||
15 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/instrumentation/events/lttng-module/timer.h b/instrumentation/events/lttng-module/timer.h | ||
18 | index d62fd25..59da988 100644 | ||
19 | --- a/instrumentation/events/lttng-module/timer.h | ||
20 | +++ b/instrumentation/events/lttng-module/timer.h | ||
21 | @@ -16,11 +16,11 @@ struct timer_list; | ||
22 | |||
23 | #endif /* _TRACE_TIMER_DEF_ */ | ||
24 | |||
25 | -#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)) | ||
26 | +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)) | ||
27 | #define lttng_ktime_get_tv64(kt) (kt) | ||
28 | -#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)) */ | ||
29 | +#else /* #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)) */ | ||
30 | #define lttng_ktime_get_tv64(kt) ((kt).tv64) | ||
31 | -#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,10,0)) */ | ||
32 | +#endif /* #else #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)) */ | ||
33 | |||
34 | LTTNG_TRACEPOINT_EVENT_CLASS(timer_class, | ||
35 | |||
36 | -- | ||
37 | 2.7.4 | ||
38 | |||
diff --git a/recipes-kernel/lttng/lttng-modules_%.bbappend b/recipes-kernel/lttng/lttng-modules_%.bbappend deleted file mode 100644 index dc1c4a74..00000000 --- a/recipes-kernel/lttng/lttng-modules_%.bbappend +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:" | ||
2 | |||
3 | |||
4 | LTTNG_PATCH = "${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/kernel','linux-intel linux-intel-rt','file://0002-lttng-modules-PKT-4.9-yocto-build-failed.patch','',d)}" | ||
5 | |||
6 | SRC_URI_append_intel-x86-common = " ${LTTNG_PATCH}" | ||
7 | |||