summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-01-29 11:17:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-01-30 09:39:30 +0800
commitf8c0af9c486188e81b2461cf30e29d5c0e389cbf (patch)
treeaba861db018d080ec580920be493869c67daa900 /recipes-kernel/linux
parent5bf189cd52ec5f4f575a98ff36b79349c4657cbd (diff)
downloadmeta-intel-f8c0af9c486188e81b2461cf30e29d5c0e389cbf.tar.gz
linux-intel-rt/5.4: introduce -rt recipe for 5.4
Linux stable v5.4.3 and -rt1 patchset. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
new file mode 100644
index 00000000..a2465a6b
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -0,0 +1,24 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
14
15KBRANCH = "5.4/preempt-rt"
16KMETA_BRANCH = "yocto-5.4"
17
18DEPENDS += "elfutils-native openssl-native util-linux-native"
19
20LINUX_VERSION ?= "5.4.3"
21SRCREV_machine ?= "b7a2b74892fe1341ddb5940104a1a4d4f8571be2"
22SRCREV_meta ?= "83d7bf143837e7d53e1ff1a575e7dc94a81f803b"
23
24LINUX_KERNEL_TYPE = "preempt-rt"