summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-01-04 14:27:45 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-01-04 14:54:09 +0800
commitda59d1a6b7607beaccc9281eeb6a114a1dbe12fb (patch)
tree69a59471289d6cee4eaf509fa185af02b7bb4ccc /recipes-kernel/linux
parent6267eaeee95b16bcf437ceadd69ba4691a7585d3 (diff)
downloadmeta-intel-da59d1a6b7607beaccc9281eeb6a114a1dbe12fb.tar.gz
linux-intel/5.10: add recipe
Add recipe to build LTS 5.10 kernel along with kernel configs from yocto-5.10 branch. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
new file mode 100644
index 00000000..51aa190f
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -0,0 +1,21 @@
1require linux-intel.inc
2
3KBRANCH = "5.10/yocto"
4KMETA_BRANCH = "yocto-5.10"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7
8SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
9
10DEPENDS += "elfutils-native openssl-native util-linux-native"
11
12LINUX_VERSION ?= "5.10.1"
13SRCREV_machine ?= "b8dd2066fae53c1bba0c7a6c73a08e137d5fca29"
14SRCREV_meta ?= "30c21625f9989859ade341ebe738664f3efbf122"
15
16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
18KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
19
20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"