summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-11-22 15:36:18 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-11-24 22:34:33 +0800
commit922d3cb1747ea657bb5668e24d6df5a606d9c5dd (patch)
tree2b0ca4705151234bc1679744acfc2d3c59c8b2dc /recipes-kernel/linux
parente69110ae036b25751b0eb7906d07609ad897e2c5 (diff)
downloadmeta-intel-922d3cb1747ea657bb5668e24d6df5a606d9c5dd.tar.gz
linux-intel/5.4: drop recipe
New LTS 5.15 is already added, so time to drop 5.4 support Drop linux-intel-rt/5.4 too. Drop cfg which is not required for LTS 5.10 & 5.15. Ref: https://github.com/torvalds/linux/commit/eb83479e18999e34b3b800f54aa31137f7f41c33 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb30
-rw-r--r--recipes-kernel/linux/linux-intel.inc1
-rw-r--r--recipes-kernel/linux/linux-intel/enable_lynxpoint_gpio.cfg1
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb26
4 files changed, 0 insertions, 58 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
deleted file mode 100644
index adc01e6b..00000000
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
13SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14"
15
16KBRANCH = "5.4/preempt-rt"
17KMETA_BRANCH = "yocto-5.4"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.4.143"
22SRCREV_machine ?= "2dc0f2c1ee89b9ce92944e397f2619062ebb77f8"
23SRCREV_meta ?= "e14d587eec888fba8693da2a072f729219acfb41"
24
25LINUX_KERNEL_TYPE = "preempt-rt"
26
27# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
28# linux-intel 5.4 specifically. This cause annoying warning during kernel config audit. So suppress the
29# harmless warning for now.
30KCONF_BSP_AUDIT_LEVEL = "0"
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 70a7e7dc..8112dc62 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -10,7 +10,6 @@ SRC_URI = " \
10 ${KERNEL_CONFIG_URI} \ 10 ${KERNEL_CONFIG_URI} \
11 " 11 "
12 12
13SRC_URI:append = " file://enable_lynxpoint_gpio.cfg"
14SRC_URI:append:core2-32-intel-common = " file://disable_skylake_sound.cfg" 13SRC_URI:append:core2-32-intel-common = " file://disable_skylake_sound.cfg"
15 14
16LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" 15LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
diff --git a/recipes-kernel/linux/linux-intel/enable_lynxpoint_gpio.cfg b/recipes-kernel/linux/linux-intel/enable_lynxpoint_gpio.cfg
deleted file mode 100644
index 49e70e67..00000000
--- a/recipes-kernel/linux/linux-intel/enable_lynxpoint_gpio.cfg
+++ /dev/null
@@ -1 +0,0 @@
1CONFIG_PINCTRL_LYNXPOINT=m
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
deleted file mode 100644
index 570f692b..00000000
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1require linux-intel.inc
2
3KBRANCH = "5.4/yocto"
4KMETA_BRANCH = "yocto-5.4"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
7
8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
9
10DEPENDS += "elfutils-native openssl-native util-linux-native"
11
12LINUX_VERSION ?= "5.4.143"
13SRCREV_machine ?= "8246417e2e14117a0a9f3625c2122fc26c92c6bd"
14SRCREV_meta ?= "e14d587eec888fba8693da2a072f729219acfb41"
15
16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
18KERNEL_MODULE_AUTOLOAD:append:corei7-64-intel-common = " uio"
19
20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
22
23# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
24# linux-intel 5.4 specifically. This cause warning during kernel config audit. So suppress the
25# harmless warning for now.
26KCONF_BSP_AUDIT_LEVEL = "0"