summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-12-07 16:40:22 -0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2017-12-07 16:42:45 -0800
commit8d37591e1186dcfbf679c1db660d6f9ffa41bb39 (patch)
tree5ac9d6a215468380bf0e72d4bb17d9e78706dce0 /recipes-kernel/linux
parentc811c0b33862a2f911fe2afdd2054958b1f28e40 (diff)
downloadmeta-intel-8d37591e1186dcfbf679c1db660d6f9ffa41bb39.tar.gz
linux-intel: Update 4.9 SRCREV and refactor
This has a SRCREV update to bring linux-intel to HEAD with some audio and pnp patches. The refactor moves the selection of branch to the versioned recipe so we can have a shared linux-intel-lts repo with multiple LTS version branches. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb9
-rw-r--r--recipes-kernel/linux/linux-intel.inc5
-rw-r--r--recipes-kernel/linux/linux-intel_4.9.bb9
3 files changed, 14 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
index 8fb184b7..7a14c053 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.9.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -10,8 +10,11 @@ python () {
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") 10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11} 11}
12 12
13KBRANCH = "base-rt" 13KBRANCH = "4.9/yocto/base-rt"
14SRCREV_machine ?= "3074f3308abdc15cbd2be92e5e5a7c0f31cfad84" 14KMETA_BRANCH = "yocto-4.9"
15SRCREV_meta ?= "f4e37e151102d89c4d0e110c88eb3b3c36bdeaa4" 15
16LINUX_VERSION ?= "4.9.61"
17SRCREV_machine ?= "8eb1a43e7232c412673aaaeb968b02122e42de4d"
18SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
16 19
17LINUX_KERNEL_TYPE = "preempt-rt" 20LINUX_KERNEL_TYPE = "preempt-rt"
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 057779a1..f03ef463 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -3,17 +3,16 @@ require recipes-kernel/linux/linux-yocto.inc
3FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
4 4
5KERNEL_CONFIG_URI ?= " \ 5KERNEL_CONFIG_URI ?= " \
6 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.9;destsuffix=${KMETA} \ 6 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
7 " 7 "
8SRC_URI = " \ 8SRC_URI = " \
9 git://github.com/01org/linux-intel-4.9.git;protocol=https;name=machine;branch=${KBRANCH}; \ 9 git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
10 ${KERNEL_CONFIG_URI} \ 10 ${KERNEL_CONFIG_URI} \
11 " 11 "
12 12
13SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 13SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
14 14
15 15
16LINUX_VERSION ?= "4.9.61"
17LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}" 16LINUX_VERSION_EXTENSION ?= "-intel-pk-${LINUX_KERNEL_TYPE}"
18 17
19PV = "${LINUX_VERSION}+git${SRCPV}" 18PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb
index dfaf34d9..85cb9bbe 100644
--- a/recipes-kernel/linux/linux-intel_4.9.bb
+++ b/recipes-kernel/linux/linux-intel_4.9.bb
@@ -1,9 +1,12 @@
1 1
2require linux-intel.inc 2require linux-intel.inc
3 3
4KBRANCH = "base" 4KBRANCH = "4.9/yocto/base"
5SRCREV_machine ?= "c2e99163add32c914514460fb67140409e287476" 5KMETA_BRANCH = "yocto-4.9"
6SRCREV_meta ?= "f4e37e151102d89c4d0e110c88eb3b3c36bdeaa4" 6
7LINUX_VERSION ?= "4.9.61"
8SRCREV_machine ?= "03469c2e703e40ed42ed72f415fd27c7d7f7f8cf"
9SRCREV_meta ?= "3e7fedea919b2c59801ceca25f57a23710ebadcd"
7 10
8# For Crystalforest and Romley 11# For Crystalforest and Romley
9KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"