summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.9.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-kernel/linux/linux-intel-rt_4.9.bb
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
new file mode 100644
index 00000000..02192735
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -0,0 +1,17 @@
1
2require linux-intel.inc
3
4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
6# to build multiple virtual/kernel providers, e.g. as dependency of
7# core-image-rt-sdk, core-image-rt.
8python () {
9 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11}
12
13KBRANCH = "base-rt"
14SRCREV_machine ?= "44f76edc2079f1551be33b8ab473349d00f814a7"
15SRCREV_meta ?= "3d5b27b2d138b71052a1d17a5cca73aa0ec75328"
16
17LINUX_KERNEL_TYPE = "preempt-rt"