summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.19.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-01-19 11:30:06 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-01-19 11:30:06 +0800
commit2e1a194b115e03bd81bb550a94569b4b7496aaf1 (patch)
tree2b873e4ebb92a54abaa4938652534b83ff15fb46 /recipes-kernel/linux/linux-intel-rt_4.19.bb
parente3319f2833e483954559968a7b7fd8bc3435321b (diff)
downloadmeta-intel-2e1a194b115e03bd81bb550a94569b4b7496aaf1.tar.gz
linux-intel-rt/4.19: introduce -rt recipe for 4.19
Linux stable v4.19.13 and -rt10 patchset. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.19.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.19.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.19.bb b/recipes-kernel/linux/linux-intel-rt_4.19.bb
new file mode 100644
index 00000000..6b2825f6
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_4.19.bb
@@ -0,0 +1,24 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch"
14
15KBRANCH = "4.19/preempt-rt"
16KMETA_BRANCH = "yocto-4.19"
17
18DEPENDS += "elfutils-native openssl-native util-linux-native"
19
20LINUX_VERSION ?= "4.19.13"
21SRCREV_machine ?= "135ff38d0e187434eb5fcf2c55087d1f0025d76f"
22SRCREV_meta ?= "ced14887c323f1cb6b3befe2b29e471e8fee1bc6"
23
24LINUX_KERNEL_TYPE = "preempt-rt"