summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-kernel/intel-ethernet
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-kernel/intel-ethernet')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe.bb45
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch31
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch40
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf.bb46
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-skip-host-depmod.patch31
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch32
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch23
7 files changed, 248 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbe.bb b/recipes-kernel/intel-ethernet/ixgbe.bb
new file mode 100644
index 00000000..181158d4
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe.bb
@@ -0,0 +1,45 @@
1SUMMARY="ixgbe kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="Intel 10-Gbps Ethernet driver for Magnolia Park"
3AUTHOR = "Ong Boon Leong"
4HOMEPAGE = "http://www.intel.com/network/connectivity/products/server_adapters.htm"
5SECTION = "kernel/network"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9PV = "5.1.3"
10PR = "r0"
11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbe%20stable/${PV}/ixgbe-${PV}.tar.gz \
13 file://0001-ixgbe-src-Makefile-change-make-install-to-make.patch \
14 file://0001-ixgbe-skip-host-depmod.patch \
15 "
16
17SRC_URI[md5sum] = "ae35ed547aa6a5087672c3f70ce1e676"
18SRC_URI[sha256sum] = "9f537d79bddf0a087a17af632d57812d26d26bcfebbd4bdcf10df656ff055bb4"
19
20S = "${WORKDIR}/${PN}-${PV}/src"
21SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
22
23EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" \
24 BUILD_ARCH="${TARGET_ARCH}" PREFIX="${D}" \
25 SYSTEM_MAP_FILE="${STAGING_KERNEL_BUILDDIR}/System.map-${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
26
27KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbe"
28KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbe"
29
30inherit module
31
32do_install_append () {
33 # Install scripts/set_irq_affinity
34 install -d ${D}/etc/network
35 install -m 0755 ${SCRIPT_DIR}/set_irq_affinity ${D}/etc/network
36}
37
38#SSTATE_DUPWHITELIST += "${STAGING_DIR_HOST}/lib/modules/${KERNEL_VERSION}/"
39
40PACKAGES += "${PN}-script"
41
42FILES_${PN}-script += "/etc/network/set_irq_affinity"
43
44#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
45INSANE_SKIP_${PN} = "installed-vs-shipped"
diff --git a/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch
new file mode 100644
index 00000000..e53f86e5
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch
@@ -0,0 +1,31 @@
1From e32eab62e3f79ddd40946ca698d9e650bd7d9b2d Mon Sep 17 00:00:00 2001
2From: sweeaun <swee.aun.khor@intel.com>
3Date: Sat, 7 Oct 2017 20:49:36 -0700
4Subject: [PATCH] ixgbe: skip host depmod
5
6Upstream-Status: Inappropriate [Cross-Compile]
7
8Depmod during do_install is irrelevant when cross-compiling.
9Remove the depmod steps during do_install.
10
11Signed-off-by: sweeaun <swee.aun.khor@intel.com>
12---
13 Makefile | 2 --
14 1 file changed, 2 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index fa92f81..b39283a 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -141,8 +141,6 @@ modules_install: default manfile
21 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
22 @echo "Installing modules..."
23 @+$(call devkernelbuild,modules_install)
24- @echo "Running depmod..."
25- @$(call cmd_depmod)
26
27 uninstall:
28 rm -f ${INSTALL_MOD_PATH}/lib/modules/${KVER}/${INSTALL_MOD_DIR}/${DRIVER}.ko;
29--
302.7.4
31
diff --git a/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
new file mode 100644
index 00000000..88f5335a
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
@@ -0,0 +1,40 @@
1From 09c7a5afa76530a3720d97726f2b372f72b0af08 Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Wed, 22 Jun 2016 11:18:37 +0800
4Subject: [PATCH] ixgbe: src/Makefile: change make install to make
5 modules_install
6
7Per guideline from Linux Documentation at
8Documentation/kbuild/modules.txt
9the correct target is "modules_install" not "install".
10
11Upstream-Status: Inappropriate [It is tarball released by Intel Network
12driver group]
13
14---
15 src/Makefile | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/Makefile b/Makefile
19index 852becb..480ecee 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -136,7 +136,7 @@ clean:
23 @-rm -rf *.${MANSECTION}.gz *.ko
24
25 # Install the modules and manpage
26-install: default manfile
27+modules_install: default manfile
28 @echo "Copying manpages..."
29 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
30 @echo "Installing modules..."
31@@ -191,6 +191,6 @@ help:
32 @echo ' Other variables may be available for tuning make process, see'
33 @echo ' Kernel Kbuild documentation for more information'
34
35-.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
36+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
37
38 endif # ifneq($(KERNELRELEASE),)
39--
402.8.3
diff --git a/recipes-kernel/intel-ethernet/ixgbevf.bb b/recipes-kernel/intel-ethernet/ixgbevf.bb
new file mode 100644
index 00000000..6a9636e6
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf.bb
@@ -0,0 +1,46 @@
1SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="Intel 10-Gbps Ethernet driver for Magnolia Park"
3AUTHOR = "Ong Boon Leong"
4HOMEPAGE = "http://www.intel.com/network/connectivity/products/server_adapters.htm"
5SECTION = "kernel/network"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9PV = "4.1.2"
10PR = "r0"
11
12SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/ixgbevf-${PV}.tar.gz \
13 file://0001-ixgbevf-src-Makefile-change-make-install-to-make.patch \
14 file://0002-ixgbevf_common.patch \
15 file://0001-ixgbevf-skip-host-depmod.patch \
16 "
17
18SRC_URI[md5sum] = "f02ec46369d1ca949a1e9d2e0eb74d5f"
19SRC_URI[sha256sum] = "ab2824541f8a2d8f7b7d26ccbb46359ef551c5d4625fb333014e2b8023ac3ab6"
20
21S = "${WORKDIR}/${PN}-${PV}/src"
22SCRIPT_DIR = "${WORKDIR}/${PN}-${PV}/scripts"
23
24EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" \
25 BUILD_ARCH="${TARGET_ARCH}" PREFIX="${D}" \
26 SYSTEM_MAP_FILE="${STAGING_KERNEL_BUILDDIR}/System.map-${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
27
28KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf"
29KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf"
30
31inherit module
32
33do_install_append () {
34 # Install scripts/set_irq_affinity
35 install -d ${D}/etc/network
36 install -m 0755 ${SCRIPT_DIR}/set_irq_affinity ${D}/etc/network
37}
38
39#SSTATE_DUPWHITELIST += "${STAGING_DIR_HOST}/lib/modules/${KERNEL_VERSION}/"
40
41PACKAGES += "${PN}-script"
42
43FILES_${PN}-script += "/etc/network/set_irq_affinity"
44
45#Ignore "ERROR: QA Issue: ixgbe: Files/directories were installed but not shipped"
46INSANE_SKIP_${PN} = "installed-vs-shipped"
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-skip-host-depmod.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-skip-host-depmod.patch
new file mode 100644
index 00000000..656a897d
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-skip-host-depmod.patch
@@ -0,0 +1,31 @@
1From 9677d09f5c3984997ac8e7d90b5d4b11fb9ce277 Mon Sep 17 00:00:00 2001
2From: sweeaun <swee.aun.khor@intel.com>
3Date: Sat, 7 Oct 2017 20:56:35 -0700
4Subject: [PATCH] ixgbevf: skip host depmod
5
6Upstream-Status: Inappropriate [Cross-Compile]
7
8Depmod during do_install is irrelevant when cross-compiling.
9Remove the depmod steps during do_install.
10
11Signed-off-by: sweeaun <swee.aun.khor@intel.com>
12---
13 Makefile | 2 --
14 1 file changed, 2 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index 91df705..1dcf350 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -104,8 +104,6 @@ modules_install: default manfile
21 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
22 @echo "Installing modules..."
23 @+$(call kernelbuild,modules_install)
24- @echo "Running depmod..."
25- @$(call cmd_depmod)
26
27 uninstall:
28 rm -f ${INSTALL_MOD_PATH}/lib/modules/${KVER}/${INSTALL_MOD_DIR}/${DRIVER}.ko;
29--
302.7.4
31
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
new file mode 100644
index 00000000..8234f589
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
@@ -0,0 +1,32 @@
1From 511ee0d8d40a3e76b3e9875a96228ff370dbdfc6 Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Wed, 22 Jun 2016 11:25:41 +0800
4Subject: [PATCH] ixgbevf_patch
5
6---
7 Makefile | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/Makefile b/Makefile
11index 8df134a..8d5660e 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -100,7 +100,7 @@ clean:
15 @-rm -rf *.${MANSECTION}.gz *.ko
16
17 # Install the modules and manpage
18-install: default manfile
19+modules_install: default manfile
20 @echo "Copying manpages..."
21 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
22 @echo "Installing modules..."
23@@ -145,6 +145,6 @@ help:
24 @echo ' Other variables may be available for tuning make process, see'
25 @echo ' Kernel Kbuild documentation for more information'
26
27-.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
28+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
29
30 endif # ifneq($(KERNELRELEASE),)
31--
322.8.3
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch b/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
new file mode 100644
index 00000000..d442e24d
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
@@ -0,0 +1,23 @@
1From f74fbcd821a394dec58263fd2c2ea62eae298b2f Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Sun, 26 Jun 2016 12:01:36 +0800
4Subject: [PATCH] ixgbevf patch
5
6---
7 common.mk | 1 +
8 1 file changed, 1 insertion(+)
9
10diff --git a/common.mk b/common.mk
11index b9b01c7..228a926 100644
12--- a/common.mk
13+++ b/common.mk
14@@ -289,6 +289,7 @@ export INSTALL_MOD_DIR ?= updates/drivers/net/ethernet/intel/${DRIVER}
15 kernelbuild = ${MAKE} $(if ${GCC_I_SYS},CC="${GCC_I_SYS}") \
16 ${CCFLAGS_VAR}="${EXTRA_CFLAGS}" \
17 -C "${KSRC}" \
18+ CONFIG_IXGBE=m \
19 CONFIG_${DRIVER_UPPERCASE}=m \
20 M="${CURDIR}" \
21 ${2} ${1};
22--
232.8.3