summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-04-20 08:42:13 +0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-23 11:11:38 -0700
commit632399bb6f72910f8949f3b6da24e4ff8293224a (patch)
tree72775a26d464455eae2f3a94b9371a928409b85d /recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
parentd5699efd24fd6ac2476c0dbe1d733f40ea4f8d59 (diff)
downloadmeta-intel-632399bb6f72910f8949f3b6da24e4ff8293224a.tar.gz
ixgbevf: cleanup recipeyocto-2.5sumo-19.0.0
* Remove unnecessary code and include version info in recipe. * Better description of the package and project page * Change do_install to use S instead of WORKDIR. Using S would fail when used with devtool that relies on externalsrc class. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
new file mode 100644
index 00000000..49a59496
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
@@ -0,0 +1,27 @@
1From b1d7f46442e50458311573443a5c78637874f62b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 12 Apr 2018 11:46:15 +0800
4Subject: [PATCH] Makefile: check for CONFIG_IXGBEVF instead
5
6Check for the correct config, otherwise it won't build with kbuild.
7
8Upstream-Status: Pending
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 src/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/Makefile b/Makefile
16index 968ef5e..e3cb81b 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),)
20 # Makefile for the Intel(R) 10GbE PCI Express Virtual Function Driver
21 #
22
23-obj-$(CONFIG_IXGBE) += ixgbevf.o
24+obj-$(CONFIG_IXGBEVF) += ixgbevf.o
25
26 define ixgbevf-y
27 ixgbevf_main.o