summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/intel-gpu-tools
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-11-07 10:32:26 -0800
committerSaul Wold <sgw@linux.intel.com>2017-11-20 15:33:02 -0800
commitd53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a (patch)
treefbe372dba00d45bbf9fbfbb3726708dc2590daeb /recipes-graphics/intel-gpu-tools
parent5adbf6df4fd89e7531ccccfb9cec7a5314d635f0 (diff)
downloadmeta-intel-d53dbb38c43da3fd04fed9a55e7b3b9e2c512b9a.tar.gz
meta-intel: Reorganize the layout to remove common
Remove the concept of the common directory and move all the recipes-* dirs to the top level as a normal layer would be. layer.conf is updated appropriately Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'recipes-graphics/intel-gpu-tools')
-rw-r--r--recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb b/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb
new file mode 100644
index 00000000..de9ed609
--- /dev/null
+++ b/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb
@@ -0,0 +1,40 @@
1require ${COREBASE}/meta/recipes-graphics/xorg-app/xorg-app-common.inc
2
3SUMMARY = "Intel GPU tools"
4DESCRIPTION = "Variety of small tools for testing intel graphics."
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4b3dd344780e0400593b21b115a6947"
7
8LICENSE_append = " & ISC"
9
10inherit autotools gtk-doc
11
12DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr procps"
13RDEPENDS_${PN} += "bash"
14RDEPENDS_${PN}-tests += "bash"
15
16PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests"
17
18SRC_URI[md5sum] = "4fdfa56acca3b046fc61fb12686656f3"
19SRC_URI[sha256sum] = "a49c8ae7c0431c1f33cd9492f83ec4e06e98a48429178e4bd22d9a1a87e3b0f1"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind,libunwind"
23
24EXTRA_OECONF = "--disable-nouveau --disable-shader-debugger"
25COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
26COMPATIBLE_HOST_libc-musl_class-target = "null"
27
28gputools_sysroot_preprocess() {
29 rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc
30}
31SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess"
32
33FILES_${PN} += "${libdir}/intel_aubdump.so"
34FILES_${PN}-benchmarks += "${libexecdir}/intel-gpu-tools/benchmarks"
35FILES_${PN}-tests += "\
36 ${libexecdir}/intel-gpu-tools/*\
37 ${datadir}/intel-gpu-tools/1080p-right.png\
38 ${datadir}/intel-gpu-tools/1080p-left.png\
39 ${datadir}/intel-gpu-tools/pass.png\
40 ${datadir}/intel-gpu-tools/test-list.txt"