summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/hdcp/hdcp_19.3.0.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-10-14 13:43:11 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-10-21 07:18:55 +0800
commitd2bc90498888b0621d1011642324441f92d69cc2 (patch)
tree33b31b52515aa4479c372d5e5cef083c08777cc7 /recipes-graphics/hdcp/hdcp_19.3.0.bb
parent62ac7ad8747118c3165e47707ae311282e6db77c (diff)
downloadmeta-intel-d2bc90498888b0621d1011642324441f92d69cc2.tar.gz
hdcp: upgrade 19.2.0 -> 19.3.0
Release notes can be found here: https://github.com/intel/hdcp/releases/tag/intel-HDCP-19.3.0 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-graphics/hdcp/hdcp_19.3.0.bb')
-rw-r--r--recipes-graphics/hdcp/hdcp_19.3.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-graphics/hdcp/hdcp_19.3.0.bb b/recipes-graphics/hdcp/hdcp_19.3.0.bb
new file mode 100644
index 00000000..12775f97
--- /dev/null
+++ b/recipes-graphics/hdcp/hdcp_19.3.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Intel(R) unified HDCP SDK"
2DESCRIPTION = "This is a user space implementation to prevent copying of \
3digital audio & video content across digital display interfaces. It provides \
4Linux user space implementation to enable the HDCP1.4 and HDCP2.2 protection \
5for external digital display interface"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c50969be4feb8b99c6baa3795ede4dce"
8SECTION = "lib"
9
10inherit pkgconfig cmake useradd systemd distro_features_check
11
12SRC_URI = "git://github.com/intel/hdcp.git \
13 file://0001-main-fix-hdcpd-service-failure.patch \
14"
15SRCREV = "9ba9511d3a5bea41442ba8507f378b931caf8981"
16S = "${WORKDIR}/git"
17
18REQUIRED_DISTRO_FEATURES = "systemd"
19
20DEPENDS = "libdrm virtual/mesa systemd"
21
22USERADD_PACKAGES = "${PN}"
23USERADD_PARAM_${PN} = "--system --no-create-home --shell /bin/false --gid nogroup media"
24
25SYSTEMD_SERVICE_${PN} = "hdcpd.service"
26SYSTEMD_AUTO_ENABLE = "disable"