summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-08-05 21:52:16 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-08-21 12:27:06 +0800
commit9c62233238a72a913090c175662f4b2550a2e3dd (patch)
tree805b6d058aac022bfcd6399d5885f6fa08c6610c /recipes-devtools
parent10b74dda871b4ce8244ef65f7c6463fd2217b181 (diff)
downloadmeta-intel-9c62233238a72a913090c175662f4b2550a2e3dd.tar.gz
opencl-clang: move to a separate recipe
Since this is managed as a separate repository, build it as a separate component instead of bundling with LLVM/clang. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/opencl/opencl-clang-native_8.0.0.bb25
1 files changed, 0 insertions, 25 deletions
diff --git a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
deleted file mode 100644
index cfba8d97..00000000
--- a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https"
9
10SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
11
12S = "${WORKDIR}/git"
13
14inherit native
15
16do_configure[noexec] = "1"
17
18do_compile() {
19 ${CC} linux_linker/linux_resource_linker.cpp -o linux_resource_linker
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 linux_resource_linker ${D}${bindir}/
25}