summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorNishioka, Toshiki <toshiki.nishioka@intel.com>2020-08-13 02:01:50 +0900
committerAnuj Mittal <anuj.mittal@intel.com>2020-08-13 11:45:27 +0800
commit1800273ed70815e64485e685dcd7e45883e85464 (patch)
tree703209a5dfe0cff37f223f28b8c5d24faf5f9977 /recipes-devtools
parent6d1ad9aa7e01c2718d1991d175a3daf12a238df0 (diff)
downloadmeta-intel-1800273ed70815e64485e685dcd7e45883e85464.tar.gz
slimboot-tools: add support for slimbootloader tools
add the recipe file to install the Slim Bootloader host tools which can generate the container images in a binary file format understood by Slim Bootloader to load and initialize Operating Systems or Hypervisors. Signed-off-by: "Yong, Jonathan" <jonathan.yong@intel.com> Signed-off-by: "Nishioka, Toshiki" <toshiki.nishioka@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/slimboot/slimboot-tools_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/slimboot/slimboot-tools_git.bb b/recipes-devtools/slimboot/slimboot-tools_git.bb
new file mode 100644
index 00000000..7d8b66be
--- /dev/null
+++ b/recipes-devtools/slimboot/slimboot-tools_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Slim Bootloader Host Tools"
2DESCRIPTION = "Native host tools to generate the container images in a \
3binary file format understood by Slim Bootloader to load and initialize\
4Operating Systems or Hypervisors."
5HOMEPAGE = "https://slimbootloader.github.io/tools/index.html"
6
7SRC_URI = "git://github.com/slimbootloader/slimbootloader;protocol=https"
8SRCREV = "9f146afd47e0ca204521826a583d55388850b216"
9PV = "0.0.0+git${SRCPV}"
10LICENSE = "BSD-2-Clause-Patent"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=d1ed89007e7aa232a4dc1c59b6c9efc4"
12S = "${WORKDIR}/git"
13
14inherit python3native
15BBCLASSEXTEND = "native"
16
17do_configure[noexec] = "1"
18do_compile[noexec] = "1"
19do_install() {
20 install -m 755 -d ${D}${libexecdir}/slimboot/Tools
21 install -m 755 ${S}/BootloaderCorePkg/Tools/*.py ${D}${libexecdir}/slimboot/Tools
22}