summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/opencl
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-03-29 13:19:27 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-05-17 19:33:15 +0800
commit613bc1ffc315ac940dc99071bcf13565cd9a40ce (patch)
treee1a83713f02399f3ae96472a18aa9245f600076e /recipes-devtools/opencl
parentec27f5a1c66464f8c20b0b0079ae66a52e86f6f2 (diff)
downloadmeta-intel-613bc1ffc315ac940dc99071bcf13565cd9a40ce.tar.gz
build linux_linker from common clang
Build only linux_linker component from common clang library for native use when compiling the target version. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-devtools/opencl')
-rw-r--r--recipes-devtools/opencl/opencl-clang-native_8.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
new file mode 100644
index 00000000..cfba8d97
--- /dev/null
+++ b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https"
9
10SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
11
12S = "${WORKDIR}/git"
13
14inherit native
15
16do_configure[noexec] = "1"
17
18do_compile() {
19 ${CC} linux_linker/linux_resource_linker.cpp -o linux_resource_linker
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 linux_resource_linker ${D}${bindir}/
25}