summaryrefslogtreecommitdiffstats
path: root/recipes-core/mkl-dnn
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-06-27 15:15:11 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-07-01 10:15:20 +0800
commit16d24415ed7640f2aa24fd78cd22c88964d689d5 (patch)
treee6cc5d5beec29f66ff0438bc4700f580863e1a5b /recipes-core/mkl-dnn
parent6372bb37d10bed4090f032b944fde4c6a87dd695 (diff)
downloadmeta-intel-16d24415ed7640f2aa24fd78cd22c88964d689d5.tar.gz
mkl-dnn: do not use host machine instructions
For GNU* Compiler Collection version 5 and newer the default options are `-march=native -mtune=native`, which should not happen in cross compilation environment. ARCH_OPT_FLAGS=\"\" does not allow to use host machine instructions. For more information, please check: http://intel.github.io/mkl-dnn/dev_guide_build_options.html Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-core/mkl-dnn')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_git.bb b/recipes-core/mkl-dnn/mkl-dnn_git.bb
index 14f4cec4..2858d876 100644
--- a/recipes-core/mkl-dnn/mkl-dnn_git.bb
+++ b/recipes-core/mkl-dnn/mkl-dnn_git.bb
@@ -23,3 +23,4 @@ EXTRA_OECMAKE += "-DMKLDNN_LIBRARY_TYPE=SHARED"
23EXTRA_OECMAKE += "-DMKLDNN_THREADING=OMP" 23EXTRA_OECMAKE += "-DMKLDNN_THREADING=OMP"
24EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON" 24EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
25EXTRA_OECMAKE += "-DWITH_TEST=ON" 25EXTRA_OECMAKE += "-DWITH_TEST=ON"
26EXTRA_OECMAKE += "-DARCH_OPT_FLAGS=''"