summaryrefslogtreecommitdiffstats
path: root/recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-04-20 15:27:26 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-04-21 22:07:00 +0800
commit53c87950e8bb913fab021213469ab8ea1d58c2f1 (patch)
tree8ab4b96e0ea058a84c7e3c80df04c468447913ed /recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb
parent28c9337302f0a4525c6696549c7ea7800d6c63a1 (diff)
downloadmeta-intel-53c87950e8bb913fab021213469ab8ea1d58c2f1.tar.gz
mkl-dnn: upgrade 1.2.2 -> 1.4
The name of project has changed to oneDNN. Enable GPU engine to be built by default which would need clang layer to be included. Also include two minor fixes to install logic that have been submitted for review upstream. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb53
1 files changed, 0 insertions, 53 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb b/recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb
deleted file mode 100644
index 1231fdf0..00000000
--- a/recipes-core/mkl-dnn/mkl-dnn_1.2.2.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1SUMMARY = "Deep Neural Network Library"
2DESCRIPTION = "This software is a user mode library that accelerates\
3deep-learning applications and frameworks on Intel architecture."
4LICENSE = "Apache-2.0 & BSD-3-Clause & BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=0c328b62744f16fbb96f4335c5b65325 \
6 file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
7 file://src/cpu/xbyak/COPYRIGHT;md5=3b9bf048d063d54cdb28964db558bcc7 \
8 file://src/cpu/jit_utils/jitprofiling/LICENSE.BSD;md5=e671ff178b24a95a382ba670503c66fb \
9 file://doc/assets/mathjax/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
10 "
11SECTION = "lib"
12
13inherit pkgconfig cmake ptest
14
15S = "${WORKDIR}/git"
16SRCREV = "8e96ef49488c65e0738c552cec5c0563ab92c1af"
17SRC_URI = "git://github.com/intel/mkl-dnn.git;branch=rls-v1.2 \
18 file://run-ptest \
19 "
20
21UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
22
23CVE_PRODUCT = "intel:math_kernel_library"
24
25COMPATIBLE_HOST = '(x86_64).*-linux'
26COMPATIBLE_HOST_libc-musl = 'null'
27
28EXTRA_OECMAKE += "-DDNNL_LIBRARY_TYPE=SHARED"
29EXTRA_OECMAKE += "-DDNNL_THREADING=OMP"
30EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
31EXTRA_OECMAKE += "-DWITH_TEST=ON"
32EXTRA_OECMAKE += "-DARCH_OPT_FLAGS=''"
33EXTRA_OECMAKE += "-DCMAKE_SKIP_RPATH=ON"
34
35do_install_append () {
36 install -d ${D}${bindir}/mkl-dnn
37 install -d ${D}${bindir}/mkl-dnn/tests
38 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn
39 install -d ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
40 install -m 0755 ${B}/tests/benchdnn/benchdnn ${D}${bindir}/mkl-dnn/tests/benchdnn
41 cp -r ${B}/tests/benchdnn/inputs/* ${D}${bindir}/mkl-dnn/tests/benchdnn/inputs
42}
43
44
45do_install_ptest () {
46 install -d ${D}${PTEST_PATH}/tests
47 install -m 0755 ${B}/tests/api-c ${D}${PTEST_PATH}/tests
48 install -m 0755 ${B}/tests/test_c_symbols-c ${D}${PTEST_PATH}/tests
49}
50
51PACKAGES =+ "${PN}-test"
52
53FILES_${PN}-test = "${bindir}/mkl-dnn/*"