summaryrefslogtreecommitdiffstats
path: root/recipes-core/microcode/intel-microcode_20190514a.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-06-19 11:18:39 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-06-19 19:53:43 +0800
commit2e47b48e5d1dead0b5a85e001ee8ad14dd341a6f (patch)
tree21b3b5680c8c49afd9bdbbd7e08a7c23fa5666ba /recipes-core/microcode/intel-microcode_20190514a.bb
parent934731535afe8bf47f4fd67f5933223869ceb716 (diff)
downloadmeta-intel-2e47b48e5d1dead0b5a85e001ee8ad14dd341a6f.tar.gz
intel-microcode: upgrade 20190514a -> 20190618
For changes in this version, see: https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/blob/940d904b7272edd689a5f0eef9dee09c13746748/releasenote Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-core/microcode/intel-microcode_20190514a.bb')
-rw-r--r--recipes-core/microcode/intel-microcode_20190514a.bb68
1 files changed, 0 insertions, 68 deletions
diff --git a/recipes-core/microcode/intel-microcode_20190514a.bb b/recipes-core/microcode/intel-microcode_20190514a.bb
deleted file mode 100644
index aec3c2a5..00000000
--- a/recipes-core/microcode/intel-microcode_20190514a.bb
+++ /dev/null
@@ -1,68 +0,0 @@
1SUMMARY = "Intel Processor Microcode Datafile for Linux"
2HOMEPAGE = "http://www.intel.com/"
3DESCRIPTION = "The microcode data file contains the latest microcode\
4 definitions for all Intel processors. Intel releases microcode updates\
5 to correct processor behavior as documented in the respective processor\
6 specification updates. While the regular approach to getting this microcode\
7 update is via a BIOS upgrade, Intel realizes that this can be an\
8 administrative hassle. The Linux operating system and VMware ESX\
9 products have a mechanism to update the microcode after booting.\
10 For example, this file will be used by the operating system mechanism\
11 if the file is placed in the /etc/firmware directory of the Linux system."
12
13LICENSE = "Intel-Microcode-License"
14LIC_FILES_CHKSUM = "file://license;md5=99b296eb12723fd1eeb52e24971eed84"
15
16SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https \
17 "
18
19SRCREV = "1dd14da6d1ea5cfbd95923653f31c04aac3aa655"
20
21DEPENDS = "iucode-tool-native"
22S = "${WORKDIR}/git"
23
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26
27inherit deploy
28
29# Use any of the iucode_tool parameters to filter specific microcodes from the data file
30# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
31UCODE_FILTER_PARAMETERS ?= ""
32
33do_compile() {
34 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
35 ${UCODE_FILTER_PARAMETERS} \
36 --overwrite \
37 --write-to=${WORKDIR}/microcode_${PV}.bin \
38 ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
39
40 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
41 ${UCODE_FILTER_PARAMETERS} \
42 --overwrite \
43 --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
44 ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/*
45}
46
47do_install() {
48 install -d ${D}${base_libdir}/firmware/intel-ucode/
49 install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
50 cd ${D}${base_libdir}/firmware/intel-ucode/
51 ln -sf microcode_${PV}.bin microcode.bin
52}
53
54do_deploy() {
55 install -d ${DEPLOYDIR}
56 install ${WORKDIR}/microcode_${PV}.cpio ${DEPLOYDIR}/
57 cd ${DEPLOYDIR}
58 rm -f microcode.cpio
59 ln -sf microcode_${PV}.cpio microcode.cpio
60}
61
62addtask deploy before do_build after do_compile
63
64PACKAGES = "${PN}"
65
66FILES_${PN} = "${base_libdir}"
67
68UPSTREAM_CHECK_GITTAGREGEX = "^microcode-(?P<pver>(\d+)[a-z])$"