summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/thermald/thermald_1.7.2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-06-06 12:20:51 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2018-06-07 13:11:00 +0800
commit2af366a36ddfcc6f39c779fdd2cc07e50a249ef6 (patch)
treee26c3bb5aac49cc44153e9548ea02d39697aaa57 /recipes-bsp/thermald/thermald_1.7.2.bb
parent6f7ed1ec43a65a00a6d67e1731423ef85a2b35ff (diff)
downloadmeta-intel-2af366a36ddfcc6f39c779fdd2cc07e50a249ef6.tar.gz
thermald: upgrade 1.7.1 -> 1.7.2
From README: - Workwround for platform with invalid thermal table - Error printing for RAPL constraint sysfs read on failure - thermal-conf.xml.auto can be read from /etc/thermald, which allows user to modify generated thermal-conf.xml from /var/run/thermald and copy to /etc/thermald Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp/thermald/thermald_1.7.2.bb')
-rw-r--r--recipes-bsp/thermald/thermald_1.7.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/thermald/thermald_1.7.2.bb b/recipes-bsp/thermald/thermald_1.7.2.bb
new file mode 100644
index 00000000..506cd4c8
--- /dev/null
+++ b/recipes-bsp/thermald/thermald_1.7.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux thermal daemon"
2
3DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
4overheating of platforms. This daemon monitors temperature and applies \
5compensation using available cooling methods."
6
7HOMEPAGE = "https://github.com/01org/thermal_daemon"
8
9DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native"
10DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
11DEPENDS_append_libc-musl = " argp-standalone"
12DEPENDS_append_toolchain-clang = " openmp"
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
15
16SRC_URI = "git://github.com/intel/thermal_daemon/ \
17 file://0001-Include-poll.h-instead-of-sys-poll.h.patch \
18 file://0002-Use-correct-format-specifier-for-X32.patch \
19 "
20SRCREV = "855c91c91b3b5b52c02cb1adc0dd940f8a39df1b"
21S = "${WORKDIR}/git"
22
23inherit pkgconfig autotools systemd
24
25FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
26
27SYSTEMD_SERVICE_${PN} = "thermald.service"
28
29COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
30
31CONFFILES_${PN} = " \
32 ${sysconfdir}/thermald/thermal-conf.xml \
33 ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
34 "
35
36UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"