diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2019-03-06 10:45:20 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2019-03-07 09:47:24 +0800 |
commit | 946c15720eea1e8e5b4640c7238d2aa60e248342 (patch) | |
tree | e475bf48a0613ecfe1eda348c1276cec62e52807 /recipes-bsp/systemd-boot | |
parent | b6fd099d2a1fd5b0587d727d7f6916432072536e (diff) | |
download | meta-intel-946c15720eea1e8e5b4640c7238d2aa60e248342.tar.gz |
systemd-boot: remove joule specific workaround
The platform isn't supported anymore and this isn't tested as a result
with recent kernels supported.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp/systemd-boot')
-rw-r--r-- | recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch | 31 | ||||
-rw-r--r-- | recipes-bsp/systemd-boot/systemd-boot_%.bbappend | 15 |
2 files changed, 0 insertions, 46 deletions
diff --git a/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch b/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch deleted file mode 100644 index 8d0b6149..00000000 --- a/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 58669ad764767afea4de53f8a97357773b1855ef Mon Sep 17 00:00:00 2001 | ||
2 | From: Saul Wold <sgw@linux.intel.com> | ||
3 | Date: Tue, 25 Oct 2016 12:54:08 -0700 | ||
4 | Subject: [PATCH] efi/boot.c: workaround for Joule BIOS hang | ||
5 | |||
6 | This patch should be removed when the BIOS is fixed | ||
7 | |||
8 | Authored-by: Steve Sakoman <steve@sakoman.com> | ||
9 | |||
10 | Upstream-Status: Inappropriate [machine specific workaround] | ||
11 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
12 | --- | ||
13 | src/boot/efi/boot.c | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c | ||
17 | index 3dcd9a5..3c6ed8c 100644 | ||
18 | --- a/src/boot/efi/boot.c | ||
19 | +++ b/src/boot/efi/boot.c | ||
20 | @@ -649,7 +649,7 @@ static BOOLEAN menu_run(Config *config, ConfigEntry **chosen_entry, CHAR16 *load | ||
21 | } | ||
22 | |||
23 | /* timeout disabled, wait for next key */ | ||
24 | - wait = TRUE; | ||
25 | + wait = FALSE; | ||
26 | continue; | ||
27 | } | ||
28 | |||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/recipes-bsp/systemd-boot/systemd-boot_%.bbappend deleted file mode 100644 index d46ef410..00000000 --- a/recipes-bsp/systemd-boot/systemd-boot_%.bbappend +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:" | ||
2 | |||
3 | SRC_URI_append_intel-x86-common = " \ | ||
4 | file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \ | ||
5 | " | ||
6 | |||
7 | PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" | ||
8 | |||
9 | do_compile_append_intel-x86-common() { | ||
10 | ninja src/boot/efi/linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub | ||
11 | } | ||
12 | |||
13 | do_deploy_append_intel-x86-common() { | ||
14 | install ${B}/src/boot/efi/linux*.efi.stub ${DEPLOYDIR} | ||
15 | } | ||