diff options
author | Alexander Usyskin <alexander.usyskin@intel.com> | 2019-06-19 13:14:11 +0300 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2019-06-19 20:06:51 +0800 |
commit | f765d1cb70bce2c56ea79531b2a1c7ef1876ca91 (patch) | |
tree | 2dad701bc74f26e489eec5637eb3ffe63154dba9 /recipes-bsp/ace | |
parent | 2e47b48e5d1dead0b5a85e001ee8ad14dd341a6f (diff) | |
download | meta-intel-f765d1cb70bce2c56ea79531b2a1c7ef1876ca91.tar.gz |
ace: add recipe for 6.5.3 version
The ADAPTIVE Communication Environment library.
Sources: http://download.dre.vanderbilt.edu/
To be used by LMS service.
Signed-off-by: Alexander Usyskin <alexander.usyskin@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-bsp/ace')
-rw-r--r-- | recipes-bsp/ace/ace_6.5.3.bb | 37 | ||||
-rw-r--r-- | recipes-bsp/ace/files/ace_config.patch | 12 |
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/ace/ace_6.5.3.bb b/recipes-bsp/ace/ace_6.5.3.bb new file mode 100644 index 00000000..53ec3243 --- /dev/null +++ b/recipes-bsp/ace/ace_6.5.3.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "C++ network programming framework that implements many core \ | ||
2 | patterns for concurrent communication software" | ||
3 | LICENSE = "ACE-TAO-CIAO" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=407a202d1b887b998dc9480442840630" | ||
5 | |||
6 | DEPENDS += "openssl gperf-native" | ||
7 | |||
8 | SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 \ | ||
9 | file://ace_config.patch \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "4cc5f109ebd17cd56f0539d1b47d16b3" | ||
13 | SRC_URI[sha256sum] = "b1d6a716394bd15c21bb90037b8a12a4d8034cc9d8878b0ad39b3c467df19b1a" | ||
14 | |||
15 | COMPATIBLE_HOST_libc-musl = "null" | ||
16 | |||
17 | S = "${WORKDIR}/ACE_wrappers" | ||
18 | B = "${WORKDIR}/ACE_wrappers/ace" | ||
19 | export ACE_ROOT="${WORKDIR}/ACE_wrappers" | ||
20 | |||
21 | inherit pkgconfig | ||
22 | |||
23 | CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations" | ||
24 | |||
25 | do_install() { | ||
26 | export D="${D}" | ||
27 | oe_runmake install | ||
28 | |||
29 | for i in $(find ${D} -name "*.pc") ; do | ||
30 | sed -i -e s:${D}::g \ | ||
31 | -e s:/${TARGET_SYS}::g \ | ||
32 | $i | ||
33 | done | ||
34 | |||
35 | rm -r ${D}/usr/share | ||
36 | } | ||
37 | |||
diff --git a/recipes-bsp/ace/files/ace_config.patch b/recipes-bsp/ace/files/ace_config.patch new file mode 100644 index 00000000..207b85ab --- /dev/null +++ b/recipes-bsp/ace/files/ace_config.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | diff -ruN ACE_wrappers1/ace/config.h ACE_wrappers/ace/config.h | ||
2 | --- ACE_wrappers1/ace/config.h 1970-01-01 02:00:00.000000000 +0200 | ||
3 | +++ ACE_wrappers/ace/config.h 2019-01-10 13:36:52.698012477 +0200 | ||
4 | @@ -0,0 +1,1 @@ | ||
5 | +#include "ace/config-linux.h" | ||
6 | diff -ruN ACE_wrappers1/include/makeinclude/platform_macros.GNU ACE_wrappers/include/makeinclude/platform_macros.GNU | ||
7 | --- ACE_wrappers1/include/makeinclude/platform_macros.GNU 1970-01-01 02:00:00.000000000 +0200 | ||
8 | +++ ACE_wrappers/include/makeinclude/platform_macros.GNU 2018-10-31 15:11:18.265392460 +0200 | ||
9 | @@ -0,0 +1,3 @@ | ||
10 | +INSTALL_PREFIX = $(D)$(exec_prefix) | ||
11 | +INSTALL_LIB = $(base_libdir) | ||
12 | +include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU | ||