summaryrefslogtreecommitdiffstats
path: root/meta-sys940x
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-01-26 10:36:30 -0800
committerDarren Hart <dvhart@linux.intel.com>2012-02-03 09:25:17 -0800
commit7b1d216a133d3df4597c336e3a6c3c941e69989a (patch)
treefca5713d8cbc2802cd9b1e27732495c17b293a1c /meta-sys940x
parent6aad7407464ec9cc807916b71068fdae323bfcd1 (diff)
downloadmeta-intel-7b1d216a133d3df4597c336e3a6c3c941e69989a.tar.gz
ranpwd: Add ranpwd recipe
ranpwd is used to generate random strings of various types, including passwords, UUIDs, and MAC addresses. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-sys940x')
-rw-r--r--meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb b/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
new file mode 100644
index 00000000..b4e0f549
--- /dev/null
+++ b/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Random password generator"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://ranpwd.c;beginline=1;endline=11;md5=0e8585e19117526efedfaeb50c345d7a"
4SECTION = "console/utils"
5PV = "1.2+git${SRCPV}"
6PR = "r0"
7
8inherit autotools
9
10SRC_URI = "git://git.zytor.com/utils/ranpwd.git"
11SRCREV = "b62aab579e288715b82d5575befaa2b8ff210c2b"
12
13S="${WORKDIR}/git"
14
15do_configure_prepend () {
16 if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
17 cp aclocal.m4 acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 0755 ${S}/ranpwd ${D}/${bindir}/ranpwd
24}