summaryrefslogtreecommitdiffstats
path: root/meta-sys940x
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-01-23 15:46:07 -0800
committerDarren Hart <dvhart@linux.intel.com>2012-02-03 09:25:17 -0800
commit6aad7407464ec9cc807916b71068fdae323bfcd1 (patch)
treeb2c72e5be10717494a98a9e6d59a64debf8f429b /meta-sys940x
parentc6d991cf83b3047419cc0076ea4ab1297b9cfb6d (diff)
downloadmeta-intel-6aad7407464ec9cc807916b71068fdae323bfcd1.tar.gz
meta-intel: Add Inforce SYS940x BSP
The Inforce SYS940x-ECX Developer-Ready Reference Platform features: o Intel Atom E6xx (0.6-1.6 GHz) o Up to 1GB on-board DDR2 o Intel Platform Controller Hub EG20T o VGA,LVDS o HD Audio o SD Card o Dual SATA o Mini-PCIe http://www.inforcecomputing.com/SYS940X_ECX.html Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-sys940x')
-rw-r--r--meta-sys940x/COPYING.MIT17
-rw-r--r--meta-sys940x/README140
-rw-r--r--meta-sys940x/README.sources18
-rw-r--r--meta-sys940x/binary/.gitignore0
-rw-r--r--meta-sys940x/conf/layer.conf10
-rw-r--r--meta-sys940x/conf/machine/sys940x-noemgd.conf19
-rw-r--r--meta-sys940x/conf/machine/sys940x.conf23
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig3
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig3
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x-noemgd/xorg.conf26
-rw-r--r--meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf48
-rw-r--r--meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend14
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto_3.0.bbappend17
15 files changed, 344 insertions, 0 deletions
diff --git a/meta-sys940x/COPYING.MIT b/meta-sys940x/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-sys940x/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-sys940x/README b/meta-sys940x/README
new file mode 100644
index 00000000..e349008f
--- /dev/null
+++ b/meta-sys940x/README
@@ -0,0 +1,140 @@
1This README file contains information on building the meta-sys940x BSP
2layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The Inforce SYS940x platform consists of the Intel Atom E6xx
6processor, plus the Intel EG20T Platform Controller Hub (Tunnel Creek
7+ Topcliff).
8
9It also supports the E6xx embedded on-chip graphics via the Intel
10Embedded Media and Graphics Driver (EMGD) 1.10 Driver.
11
12
13Dependencies
14============
15
16This layer depends on:
17
18 URI: git://git.openembedded.org/bitbake
19 branch: master
20
21 URI: git://git.openembedded.org/openembedded-core
22 layers: meta
23 branch: master
24
25 URI: git://git.yoctoproject.org/meta-intel
26 layers: intel
27 branch: master
28
29
30Patches
31=======
32
33Please submit any patches against this BSP to the Yocto mailing list
34(yocto@yoctoproject.org) and cc: the maintainer:
35
36Maintainer: Darren Hart <dvhart@linux.intel.com>
37
38Please see the meta-intel/MAINTAINERS file for more details.
39
40
41Table of Contents
42=================
43
44 I. Building the meta-sys940x BSP layer
45 II. Booting the images in /binary
46
47
48I. Building the meta-sys940x BSP layer
49===================================
50
51In order to build an image with BSP support for a given release, you
52need to download the corresponding BSP tarball from the 'Board Support
53Package (BSP) Downloads' page of the Yocto Project website.
54
55Having done that, and assuming you extracted the BSP tarball contents
56at the top-level of your yocto build tree, you can build an sys940x image
57by adding the location of the meta-sys940x layer to bblayers.conf, along
58with the meta-intel layer itself (to access common metadata shared
59between BSPs) e.g.:
60
61 yocto/meta-intel \
62 yocto/meta-intel/meta-sys940x \
63
64The meta-sys940x layer contains support for two different machine
65configurations. These configurations are identical except for the fact
66that the one prefixed with 'sys940x' makes use of the Intel-proprietary
67EMGD 1.10 graphics driver, while the one prefixed with 'sys940x-noemgd'
68does not.
69
70If you want to enable the layer that supports EMGD graphics add the
71following to the local.conf file:
72
73 MACHINE ?= "sys940x"
74
75The 'sys940x' machine includes the emgd-driver-bin package, which has a
76proprietary license that must be whitelisted by adding the string
77"license_emgd-driver-bin_1.10" to the LICENSE_FLAGS_WHITELIST variable
78in your local.conf. For example:
79
80 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.10"
81
82If you want to enable the layer that does not support EMGD graphics
83add the following to the local.conf file:
84
85 MACHINE ?= "sys940x-noemgd"
86
87You should then be able to build an sys940x image as such:
88
89 $ source oe-init-build-env
90 $ bitbake core-image-sato
91
92At the end of a successful build, you should have a live image that
93you can boot from a USB flash drive (see instructions on how to do
94that below, in the section 'Booting the images from /binary').
95
96As an alternative to downloading the BSP tarball, you can also work
97directly from the meta-intel git repository. For each BSP in the
98'meta-intel' repository, there are multiple branches, one
99corresponding to each major release starting with 'laverne' (0.90), in
100addition to the latest code which tracks the current master (note that
101not all BSPs are present in every release). Instead of extracting a
102BSP tarball at the top level of your yocto build tree, you can
103equivalently check out the appropriate branch from the meta-intel
104repository at the same location.
105
106
107II. Booting the images in /binary
108=================================
109
110This BSP contains bootable live images, which can be used to directly
111boot Yocto off of a USB flash drive.
112
113Under Linux, insert a USB flash drive. Assuming the USB flash drive
114takes device /dev/sdf, use dd to copy the live image to it. For
115example:
116
117# dd if=core-image-sato-sys940x-20101207053738.hddimg of=/dev/sdf
118# sync
119# eject /dev/sdf
120
121This should give you a bootable USB flash device. Insert the device
122into a bootable USB socket on the target, and power on. This should
123result in a system booted to the Sato graphical desktop.
124
125If you want a terminal, use the arrows at the top of the UI to move to
126different pages of available applications, one of which is named
127'Terminal'. Clicking that should give you a root terminal.
128
129If you want to ssh into the system, you can use the root terminal to
130ifconfig the IP address and use that to ssh in. The root password is
131empty, so to log in type 'root' for the user name and hit 'Enter' at
132the Password prompt: and you should be in.
133
134----
135
136If you find you're getting corrupt images on the USB (it doesn't show
137the syslinux boot: prompt, or the boot: prompt contains strange
138characters), try doing this first:
139
140# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-sys940x/README.sources b/meta-sys940x/README.sources
new file mode 100644
index 00000000..c6cab4d3
--- /dev/null
+++ b/meta-sys940x/README.sources
@@ -0,0 +1,18 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10# FIXME: update the following link after the Yocto Project 1.2 release
11http://www.yoctoproject.org/downloads/yocto-1.2/poky-RELEASENAME-6.0.tar.bz2
12
13The metadata used to generate the images shipped with this BSP, in
14addition to the code contained in this BSP, can also be found at the
15following locations:
16
17git://git.yoctoproject.org/poky.git
18git://git.yoctoproject.org/meta-intel
diff --git a/meta-sys940x/binary/.gitignore b/meta-sys940x/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-sys940x/binary/.gitignore
diff --git a/meta-sys940x/conf/layer.conf b/meta-sys940x/conf/layer.conf
new file mode 100644
index 00000000..459c7102
--- /dev/null
+++ b/meta-sys940x/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "sys940x"
9BBFILE_PATTERN_sys940x := "^${LAYERDIR}/"
10BBFILE_PRIORITY_sys940x = "6"
diff --git a/meta-sys940x/conf/machine/sys940x-noemgd.conf b/meta-sys940x/conf/machine/sys940x-noemgd.conf
new file mode 100644
index 00000000..8a1c20f5
--- /dev/null
+++ b/meta-sys940x/conf/machine/sys940x-noemgd.conf
@@ -0,0 +1,19 @@
1#@TYPE: Machine
2#@NAME: sys940x
3
4#@DESCRIPTION: Machine configuration for Inforce SYS940X systems
5# i.e. E660 + EG20T
6
7include conf/machine/include/tune-atom.inc
8include conf/machine/include/ia32-base.inc
9
10# Add "pcbios" if you have a non-efi version of the firmware
11MACHINE_FEATURES += "efi pcbios"
12
13XSERVER ?= "${XSERVER_IA32_BASE} \
14 ${XSERVER_IA32_EXT} \
15 ${XSERVER_IA32_VESA} \
16 "
17
18SERIAL_CONSOLE = "115200 ttyS0"
19APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-sys940x/conf/machine/sys940x.conf b/meta-sys940x/conf/machine/sys940x.conf
new file mode 100644
index 00000000..ceb6e0fa
--- /dev/null
+++ b/meta-sys940x/conf/machine/sys940x.conf
@@ -0,0 +1,23 @@
1#@TYPE: Machine
2#@NAME: sys940x
3
4#@DESCRIPTION: Machine configuration for Inforce SYS940x systems
5# i.e. E660 + EG20T
6
7include conf/machine/include/tune-atom.inc
8include conf/machine/include/ia32-base.inc
9
10# Add "pcbios" if you have a non-efi version of the firmware
11MACHINE_FEATURES += "efi pcbios"
12
13XSERVER ?= "${XSERVER_IA32_BASE} \
14 ${XSERVER_IA32_EXT} \
15 ${XSERVER_IA32_EMGD} \
16 "
17
18PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
19PREFERRED_VERSION_mesa-dri ?= "7.11"
20PREFERRED_VERSION_emgd-driver-bin ?= "1.8"
21
22SERIAL_CONSOLE = "115200 ttyS0"
23APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..54da0ffd
--- /dev/null
+++ b/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC = "1"
diff --git a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x-noemgd/xorg.conf b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x-noemgd/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x-noemgd/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf
new file mode 100644
index 00000000..73736aca
--- /dev/null
+++ b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf
@@ -0,0 +1,48 @@
1##
2## X Config options generated from CED
3## x11 conf skeleton
4## DriverVer=
5##
6
7Section "Screen"
8 Identifier "Screen0"
9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
13EndSection
14
15# Primary (First/only) display
16Section "Device"
17 Identifier "IntelEMGD-0"
18 Driver "emgd"
19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "32400"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/General/TuningWA" "1"
30 Option "ALL/1/Port/4/General/name" "lvds"
31 Option "ALL/1/Port/4/General/EdidAvail" "3"
32 Option "ALL/1/Port/4/General/EdidNotAvail" "1"
33 Option "ALL/1/Port/4/General/Rotation" "0"
34 Option "ALL/1/Port/4/General/Edid" "0"
35EndSection
36
37Section "ServerLayout"
38 Identifier "Default Layout"
39 Screen 0 "Screen0" 0 0
40 # InputDevice "Mouse0" "CorePointer"
41 # InputDevice "Keyboard0" "CoreKeyboard"
42 # InputDevice "DevInputMice" "SendCoreEvents"
43EndSection
44
45Section "ServerFlags"
46 Option "DontZap" "0"
47 Option "AutoAddDevices" "False"
48EndSection
diff --git a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..5d3567d5
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,14 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_sys940x = "sys940x"
4KMACHINE_sys940x = "sys940x"
5KERNEL_FEATURES_append_sys940x += " cfg/smp.scc cfg/efi-ext.scc"
6
7COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
8KMACHINE_sys940x-noemgd = "sys940x"
9KERNEL_FEATURES_append_sys940x-noemgd += " cfg/smp.scc cfg/efi-ext.scc"
10
11# Update the following to use a different BSP branch or meta SRCREV
12#KBRANCH_sys940x = "yocto/standard/preempt-rt/base"
13#SRCREV_machine_pn-linux-yocto-rt_sys940x ?= XXXX
14#SRCREV_meta_pn-linux-yocto-rt_sys940x ?= XXXX
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..1d8bfb81
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_sys940x = "sys940x"
5KMACHINE_sys940x = "sys940x"
6KBRANCH_sys940x = "yocto/standard/base"
7KERNEL_FEATURES_append_sys940x += " cfg/smp.scc cfg/efi-ext.scc"
8
9COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
10KMACHINE_sys940x-noemgd = "sys940x"
11KBRANCH_sys940x-noemgd = "yocto/standard/base"
12KERNEL_FEATURES_append_sys940x-noemgd += " cfg/smp.scc cfg/efi-ext.scc"
13
14SRCREV_machine_pn-linux-yocto_sys940x ?= "5df0b4c2538399aed543133b3855f809adf08ab8"
15SRCREV_meta_pn-linux-yocto_sys940x ?= "77ca4855e80acb8dad21acea946908716c308b5b"
16SRCREV_machine_pn-linux-yocto_sys940x-noemgd ?= "5df0b4c2538399aed543133b3855f809adf08ab8"
17SRCREV_meta_pn-linux-yocto_sys940x-noemgd ?= "77ca4855e80acb8dad21acea946908716c308b5b"