diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2013-01-11 09:28:41 -0800 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2013-01-19 12:54:35 -0600 |
commit | 417825f175d9f5c4a1b25d309323c6d809c98047 (patch) | |
tree | 6d3cc1f3ce4b4897844dc276b379cb13a066f913 /meta-sys940x/recipes-kernel | |
parent | 8e200220c256c522d115e3ef9ea0a39416bc8c8d (diff) | |
download | meta-intel-417825f175d9f5c4a1b25d309323c6d809c98047.tar.gz |
sys940x: create a v3.4 kernel recipe
The sys940x & sys940x-noemgd BSPs are still using v3.2 linux-yocto kernel.
This commit provides a v3.4 kernel recipe for these BSPs.
This addresses the bug/feature request:
[YOCTO #2268]
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-sys940x/recipes-kernel')
-rw-r--r-- | meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend new file mode 100644 index 00000000..10f8e949 --- /dev/null +++ b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend | |||
@@ -0,0 +1,22 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | KMETA = "meta" | ||
4 | |||
5 | COMPATIBLE_MACHINE_sys940x = "sys940x" | ||
6 | KMACHINE_sys940x = "sys940x" | ||
7 | KBRANCH_sys940x = "standard/base" | ||
8 | KERNEL_FEATURES_sys940x = " features/drm-emgd" | ||
9 | |||
10 | COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd" | ||
11 | KMACHINE_sys940x-noemgd = "sys940x" | ||
12 | KBRANCH_sys940x-noemgd = "standard/base" | ||
13 | KERNEL_FEATURES_sys940x-noemgd = " cfg/vesafb" | ||
14 | |||
15 | SRCREV_machine_pn-linux-yocto_sys940x ?= "${AUTOREV}" | ||
16 | SRCREV_meta_pn-linux-yocto_sys940x ?= "${AUTOREV}" | ||
17 | SRCREV_emgd_pn-linux-yocto_sys940x ?= "${AUTOREV}" | ||
18 | |||
19 | SRCREV_machine_pn-linux-yocto_sys940x-noemgd ?= "${AUTOREV}" | ||
20 | SRCREV_meta_pn-linux-yocto_sys940x-noemgd ?= "${AUTOREV}" | ||
21 | |||
22 | SRC_URI_sys940x = "git://${KSRC_linux_yocto_3_4_repo};nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd" | ||