diff options
author | Tom Zanussi <tom.zanussi@intel.com> | 2012-11-11 22:46:42 -0600 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2012-11-13 09:24:46 -0600 |
commit | 787d5d8c933577307d5c231f5ba3e9aa41db3aea (patch) | |
tree | ba888d181e1eec4c3aed5d071b5b5bb6bf036bad /meta-sugarbay | |
parent | 52a9a5aec7cc61d115e72015fd2451facec739cb (diff) | |
download | meta-intel-787d5d8c933577307d5c231f5ba3e9aa41db3aea.tar.gz |
meta-intel: remove explicit kernel SRCREVs
To ease development on unreleased BSPs, let the kernel SRCREV float.
This avoids constantly having to update the SRCREVs manually, and
assures we won't get into a situation where LINUX_VERSION doesn't
match the version set by the kernel recipe.
We'll lock down the kernel SRCREVs and set the matching LINUX_VERSION
when we do releases, but in the meantime, we can use AUTOREV.
Note that individual BSPs are always free to override this maintain
their own SRCREVs if they want to.
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-sugarbay')
-rw-r--r-- | meta-sugarbay/recipes-kernel/linux/linux-yocto_3.2.bbappend | 6 | ||||
-rw-r--r-- | meta-sugarbay/recipes-kernel/linux/linux-yocto_3.4.bbappend | 6 |
2 files changed, 4 insertions, 8 deletions
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.2.bbappend index fad7c06b..935e5756 100644 --- a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.2.bbappend +++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.2.bbappend | |||
@@ -5,9 +5,7 @@ COMPATIBLE_MACHINE_sugarbay = "sugarbay" | |||
5 | KMACHINE_sugarbay = "sugarbay" | 5 | KMACHINE_sugarbay = "sugarbay" |
6 | KBRANCH_sugarbay = "standard/default/common-pc-64/sugarbay" | 6 | KBRANCH_sugarbay = "standard/default/common-pc-64/sugarbay" |
7 | 7 | ||
8 | SRCREV_machine_pn-linux-yocto_sugarbay ?= "1b6466421bc314e7e07fe4dd48c5fc67cdc3fc40" | 8 | SRCREV_machine_pn-linux-yocto_sugarbay ?= "${AUTOREV}" |
9 | SRCREV_meta_pn-linux-yocto_sugarbay ?= "486f7aec824b4127e91ef53228823e996b3696f0" | 9 | SRCREV_meta_pn-linux-yocto_sugarbay ?= "${AUTOREV}" |
10 | |||
11 | LINUX_VERSION = "3.2.18" | ||
12 | 10 | ||
13 | KERNEL_FEATURES_append_sugarbay = " features/tmp/rc6" | 11 | KERNEL_FEATURES_append_sugarbay = " features/tmp/rc6" |
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.4.bbappend index 0a481e29..4e0c2884 100644 --- a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.4.bbappend +++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.4.bbappend | |||
@@ -5,7 +5,5 @@ COMPATIBLE_MACHINE_sugarbay = "sugarbay" | |||
5 | KMACHINE_sugarbay = "sugarbay" | 5 | KMACHINE_sugarbay = "sugarbay" |
6 | KBRANCH_sugarbay = "standard/common-pc-64/sugarbay" | 6 | KBRANCH_sugarbay = "standard/common-pc-64/sugarbay" |
7 | 7 | ||
8 | SRCREV_machine_pn-linux-yocto_sugarbay ?= "218bd8d2022b9852c60d32f0d770931e3cf343e2" | 8 | SRCREV_machine_pn-linux-yocto_sugarbay ?= "${AUTOREV}" |
9 | SRCREV_meta_pn-linux-yocto_sugarbay ?= "68a635bf8dfb64b02263c1ac80c948647cc76d5f" | 9 | SRCREV_meta_pn-linux-yocto_sugarbay ?= "${AUTOREV}" |
10 | |||
11 | LINUX_VERSION = "3.4.11" | ||