summaryrefslogtreecommitdiffstats
path: root/meta-sugarbay/conf
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-01-31 01:05:15 -0600
committerTom Zanussi <tom.zanussi@intel.com>2011-01-31 01:05:15 -0600
commit2deb57956fc6a721c46c67bcdf844ed29c71f3a3 (patch)
tree4bac2da3a3c4dc87b3e87a8527451e3d5f9e2a00 /meta-sugarbay/conf
parentc5ecc11dec2402aa05e68bd03b65a6460837b748 (diff)
downloadmeta-intel-2deb57956fc6a721c46c67bcdf844ed29c71f3a3.tar.gz
meta-sugarbay: new layer for Sandy Bridge/Cougar Point systems
This layer provides support for Sandy Bridge + Cougar Point Intel systems. The 'Sugar Bay' platform consists of the Intel Sandy Bridge processor, plus the Cougar Point PCH (Q67 Express or B65 Express chipsets). This BSP assumes that the Sandy Bridge integrated graphics are being used, and makes use of the grub2 and associated live-install changes in meta-intel/common. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-sugarbay/conf')
-rw-r--r--meta-sugarbay/conf/layer.conf12
-rw-r--r--meta-sugarbay/conf/machine/sugarbay.conf57
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-sugarbay/conf/layer.conf b/meta-sugarbay/conf/layer.conf
new file mode 100644
index 00000000..e23d1233
--- /dev/null
+++ b/meta-sugarbay/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend \
7 ${LAYERDIR}/../common/recipes-*/*/*.bb \
8 ${LAYERDIR}/../common/recipes-*/*/*.bbappend"
9
10BBFILE_COLLECTIONS_sugarbay += "sugarbay"
11BBFILE_PATTERN_sugarbay := "^${LAYERDIR}/"
12BBFILE_PRIORITY_sugarbay = "6"
diff --git a/meta-sugarbay/conf/machine/sugarbay.conf b/meta-sugarbay/conf/machine/sugarbay.conf
new file mode 100644
index 00000000..4d58d050
--- /dev/null
+++ b/meta-sugarbay/conf/machine/sugarbay.conf
@@ -0,0 +1,57 @@
1#@TYPE: Machine
2#@NAME: sugarbay
3
4#@DESCRIPTION: Machine configuration for Sugar Bay systems
5# i.e. Sandy Bridge + Cougar Point
6
7TARGET_ARCH = "x86_64"
8PACKAGE_EXTRA_ARCHS = "x86 snb"
9
10BASE_PACKAGE_ARCH="snb"
11
12MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
13 acpi serial usbgadget"
14
15KERNEL_IMAGETYPE = "bzImage"
16
17PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
18PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
19
20PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
21PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
22PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
23PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
24XSERVER ?= "xserver-xf86-dri-lite \
25 xf86-input-mouse \
26 xf86-input-keyboard \
27 xf86-input-evdev \
28 xf86-input-synaptics \
29 xf86-video-intel"
30
31SERIAL_CONSOLE = "115200 ttyS0"
32
33MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
34
35GUI_MACHINE_CLASS = "bigscreen"
36
37IMAGE_ROOTFS_SIZE_ext3 = "2000000"
38
39IMAGE_FSTYPES ?= "ext3 cpio.gz"
40
41GLIBC_ADDONS = "nptl"
42GLIBC_EXTRA_OECONF = "--with-tls"
43
44MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub"
45
46TARGET_CC_ARCH = "-m64"
47
48PREFERRED_VERSION_xf86-video-intel ?= "2.14.0"
49PREFERRED_VERSION_mesa-dri ?= "7.10"
50PREFERRED_VERSION_libdrm ?= "2.4.23"
51PREFERRED_VERSION_cairo ?= "1.10.2"
52PREFERRED_VERSION_xserver-xf86-dri-lite ?= "1.9.3"
53
54PREFERRED_VERSION_grub ?= "1.98"
55
56#SRCREV_machine_pn-linux-yocto_sugarbay ?= "0431115c9d720fee5bb105f6a7411efb4f851d26"
57#SRCREV_meta_pn-linux-yocto_sugarbay ?= "39b796c508a80dcab6b4511b46183d4dfee6284d"