summaryrefslogtreecommitdiffstats
path: root/meta-romley
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2011-10-27 14:21:43 -0700
committerTom Zanussi <tom.zanussi@intel.com>2011-10-28 00:04:20 -0500
commit478969defe862a2779bf7eb3bca30e2067827d7e (patch)
tree7f4eca944555205306c3a9d2145268a31cead89a /meta-romley
parentb5c9f0af18b80c2b4c478fd7cfb537e0a04a4e22 (diff)
downloadmeta-intel-478969defe862a2779bf7eb3bca30e2067827d7e.tar.gz
New Romley BSP created. Uses Matrox MGA graphics driver.
This layer provides new BSP meta-romley. This provides the support for Romley + Patsburg Chipset for Intel Systems. Romley refers to the Intel Rosecity Board. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-romley')
-rw-r--r--meta-romley/COPYING.MIT17
-rw-r--r--meta-romley/README88
-rw-r--r--meta-romley/README.sources17
-rw-r--r--meta-romley/binary/.gitignore0
-rw-r--r--meta-romley/conf/layer.conf10
-rw-r--r--meta-romley/conf/machine/romley.conf46
-rw-r--r--meta-romley/recipes-bsp/formfactor/formfactor/romley/machconfig3
-rw-r--r--meta-romley/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-romley/recipes-core/tasks/task-core-tools.bbappend2
-rwxr-xr-xmeta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb19
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf26
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend1
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend8
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.0.bbappend7
15 files changed, 250 insertions, 0 deletions
diff --git a/meta-romley/COPYING.MIT b/meta-romley/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-romley/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-romley/README b/meta-romley/README
new file mode 100644
index 00000000..d242534d
--- /dev/null
+++ b/meta-romley/README
@@ -0,0 +1,88 @@
1This README file contains information on building the meta-romley
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'romley' platform consists of the Intel Sandy Bridge processor,
6plus the Patsburg chipset. This BSP assumes Matrox graphics is being used.
7
8Table of Contents
9=================
10
11 I. Building the meta-romley BSP layer
12 II. Booting the images in /binary
13
14
15I. Building the meta-romley BSP layer
16=======================================
17
18In order to build an image with BSP support for a given release, you
19need to download the corresponding BSP tarball from the 'Board Support
20Package (BSP) Downloads' page of the Yocto Project website.
21
22Having done that, and assuming you extracted the BSP tarball contents
23at the top-level of your yocto build tree, you can build a romley
24image by adding the location of the meta-romley layer to
25bblayers.conf e.g.:
26
27 yocto/meta-intel/meta-romley \
28
29To enable the romley layer, add the romley MACHINE to local.conf:
30
31 MACHINE ?= "romley"
32
33You should then be able to build a romley image as such:
34
35 $ source oe-init-build-env
36 $ bitbake core-image-sato
37
38At the end of a successful build, you should have a live image that
39you can boot from a USB flash drive (see instructions on how to do
40that below, in the section 'Booting the images from /binary').
41
42As an alternative to downloading the BSP tarball, you can also work
43directly from the meta-intel git repository. For each BSP in the
44'meta-intel' repository, there are multiple branches, one
45corresponding to each major release starting with 'laverne' (0.90), in
46addition to the latest code which tracks the current master (note that
47not all BSPs are present in every release). Instead of extracting a
48BSP tarball at the top level of your yocto build tree, you can
49equivalently check out the appropriate branch from the meta-intel
50repository at the same location.
51
52
53II. Booting the images in /binary
54=================================
55
56This BSP contains bootable live images, which can be used to directly
57boot Yocto off of a USB flash drive.
58
59Under Linux, insert a USB flash drive. Assuming the USB flash drive
60takes device /dev/sdf, use dd to copy the live image to it. For
61example:
62
63# dd if=core-image-sato-romley-20111007220323.hddimg of=/dev/sdf
64# sync
65# eject /dev/sdf
66
67This should give you a bootable USB flash device. Insert the device
68into a bootable USB socket on the target, and power on. This should
69result in a system booted to the Sato graphical desktop.
70
71If you want a terminal, use the arrows at the top of the UI to move to
72different pages of available applications, one of which is named
73'Terminal'. Clicking that should give you a root terminal.
74
75If you want to ssh into the system, you can use the root terminal to
76ifconfig the IP address and use that to ssh in. The root password is
77empty, so to log in type 'root' for the user name and hit 'Enter' at
78the Password prompt: and you should be in.
79
80----
81
82If you find you're getting corrupt images on the USB (it doesn't show
83the syslinux boot: prompt, or the boot: prompt contains strange
84characters), try doing this first:
85
86# dd if=/dev/zero of=/dev/sdf bs=1M count=512
87
88
diff --git a/meta-romley/README.sources b/meta-romley/README.sources
new file mode 100644
index 00000000..8e006fb1
--- /dev/null
+++ b/meta-romley/README.sources
@@ -0,0 +1,17 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.1/poky-edison-6.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-romley/binary/.gitignore b/meta-romley/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-romley/binary/.gitignore
diff --git a/meta-romley/conf/layer.conf b/meta-romley/conf/layer.conf
new file mode 100644
index 00000000..c5eeaaba
--- /dev/null
+++ b/meta-romley/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "romley"
9BBFILE_PATTERN_romley := "^${LAYERDIR}/"
10BBFILE_PRIORITY_romley = "6"
diff --git a/meta-romley/conf/machine/romley.conf b/meta-romley/conf/machine/romley.conf
new file mode 100644
index 00000000..38bd17a8
--- /dev/null
+++ b/meta-romley/conf/machine/romley.conf
@@ -0,0 +1,46 @@
1#@TYPE: Machine
2#@NAME: romley
3
4#@DESCRIPTION: Machine configuration for Sugar Bay systems
5# i.e. Sandy Bridge + Patsburg Chipset
6
7require conf/machine/include/tune-x86_64.inc
8
9MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
10 acpi serial usbgadget"
11
12KERNEL_IMAGETYPE = "bzImage"
13
14PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
15PREFERRED_VERSION_linux-yocto = "3.0%"
16
17PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
18PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
19PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
21PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xorg"
22XSERVER ?= "xserver-xorg \
23 xserver-xorg-extension-dri \
24 xserver-xorg-extension-dri2 \
25 xserver-xorg-extension-glx \
26 xserver-xorg-extension-extmod \
27 xserver-xorg-extension-dbe \
28 xserver-xorg-module-libint10 \
29 xserver-xorg-module-xaa \
30 xf86-input-mouse \
31 xf86-input-keyboard \
32 xf86-input-evdev \
33 xf86-input-synaptics \
34 xf86-video-mga \
35 mesa-dri"
36
37SERIAL_CONSOLE = "115200 ttyS0"
38
39MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
40
41IMAGE_FSTYPES ?= "ext3 cpio.gz live"
42
43GLIBC_ADDONS = "nptl"
44GLIBC_EXTRA_OECONF = "--with-tls"
45
46MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub"
diff --git a/meta-romley/recipes-bsp/formfactor/formfactor/romley/machconfig b/meta-romley/recipes-bsp/formfactor/formfactor/romley/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-romley/recipes-bsp/formfactor/formfactor/romley/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-romley/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-romley/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..54da0ffd
--- /dev/null
+++ b/meta-romley/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC = "1"
diff --git a/meta-romley/recipes-core/tasks/task-core-tools.bbappend b/meta-romley/recipes-core/tasks/task-core-tools.bbappend
new file mode 100644
index 00000000..aba487f5
--- /dev/null
+++ b/meta-romley/recipes-core/tasks/task-core-tools.bbappend
@@ -0,0 +1,2 @@
1RRECOMMENDS_task-core-tools-profile_append_romley = " systemtap"
2
diff --git a/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb b/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb
new file mode 100755
index 00000000..b48e56d8
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-driver/xf86-video-mga_1.4.13.bb
@@ -0,0 +1,19 @@
1require recipes-graphics/xorg-driver/xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Matrox MGA display driver"
4
5DESCRIPTION = "mga is an Xorg driver for Matrox video cards"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=bc1395d2cd32dfc5d6c57d2d8f83d3fc"
8
9DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
10 virtual/libgl xineramaproto libpciaccess"
11
12EXTRA_OECONF += "--enable-dri"
13
14PR = "r0"
15
16COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
17
18SRC_URI[md5sum] = "f967fb3e655f6f68aa3f495eaadcaac2"
19SRC_URI[sha256sum] = "b657bd5fec4aade6396c683886739b7c8ce57924278bee0e36f13a966eeddff6"
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf
new file mode 100644
index 00000000..28ad0bf7
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config/romley/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Matrox MGA"
3 Driver "mga"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Matrox MGA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend b/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend
new file mode 100644
index 00000000..b2808ef2
--- /dev/null
+++ b/meta-romley/recipes-graphics/xorg-xserver/xserver-xorg_1.11.1.bbappend
@@ -0,0 +1 @@
EXTRA_OECONF += "--enable-dga"
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..d630dc4f
--- /dev/null
+++ b/meta-romley/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_romley = "romley"
3KMACHINE_romley = "romley"
4
5# Update the following to use a different BSP branch or meta SRCREV
6#KBRANCH_sugarbay = "yocto/standard/preempt-rt/base"
7#SRCREV_machine_pn-linux-yocto-rt_sugarbay ?= XXXX
8#SRCREV_meta_pn-linux-yocto-rt_sugarbay ?= XXXX
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..558be955
--- /dev/null
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_romley = "romley"
4KMACHINE_romley = "yocto/standard/common-pc-64/romley"
5
6SRCREV_machine_pn-linux-yocto_romley ?= "dbe820c277dfa6cbc249d410e8b083286ec484b7"
7SRCREV_meta_pn-linux-yocto_romley ?= "353d43d340e87996b4be4c5f6ddb4447e050b65c"